Jump to content
You must now use your email address to sign in [click for more info] ×

URGENT!! Affinity Photo now crashes after update to 1.10.3.

Recommended Posts

I'm have trouble with the new update as well. The program is crashing constantly. My 2019 Macbook pro 16 inch updated to Monterey and with that Affinity Photo got updated as well. Now it is unusable. It mostly crashes as I'm trying to export but it can crash randomly while editing too. I get the spinning wheel and Affinity stops responding. My hard drive has plenty of space, I use external hard drives for all storage. I have very little on my actual computer and everything else seems to be running fine. I have a lot of work to do for clients. I have to get this fixed fast. 

Link to comment
Share on other sites

I have been seeing display (and image data) corruption similar to what Ozzoo describes, and which I reported here in another thread (link included below).

A workaround is to go into Affinity Photo's Preferences, then the Performance panel, and turn off the Metal acceleration: untick a checkbox at the bottom of the panel. For me and others this makes 1.10.3 usable, albeit without the performance improvements from hardware acceleration. (These instructions are for Mac users, but I think are similar for Windows users where I think it also works around the problem.)

Another alternative is to revert to version 1.10.1: either from a Time Machine backup (just restore the application in your /Applications folder) or, if you bought the software direct from Serif, by downloading the older installer from the Affinity website.



Link to comment
Share on other sites

  • Staff

Hi All,

If you are having the issue in Ozzoo's screen shot please could you try disabling Open CL in the apps preferences as it should temporarily fix this issue. If you are experiencing random crashes with the apps and purchased from us you can try rolling back to a previous version below using the link below.

If you are still having problems with the latest version please provide the latest crash log which you can find by following the below guide.



Please tag me using @ in your reply so I can be sure to respond ASAP.

Link to comment
Share on other sites

Just in case it may be of help here...

I had this problem.  Crashing constantly, high cpu etc.  Even simply opening the Export... dialog would result in a total hang/crash.

If you're running Time Machine (which you should be) then going back to 1.10.1 solves the problem for the time being.

Grumpy, but faithful (watch out all you cats)

Link to comment
Share on other sites

Just upgraded to 1.10.3, won't work at all. (MacBook Pro 16" 2019, 16GB, 6-core intel processor, 2.6GHz. I just upgraded to Monterey) It just stops working. I have closed down and re-opened, nothing. Please advise on what steps I need to make to get this running again. I love the app.
Edit - I can process photos if I do them one at a time from my computer hard drive, but if I try to open a batch from either original RAW or DxO it only loads 3 , or none at latest attempt, then beach ball of doom, and I have to Force Quit.
Previous version worked, a bit slow if I was opening multiple photos, but I was working off my Seagate external disk. I have tried the newest version with that drive disconnected, and using my computer's hard drive, but still same issues. 
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.