Jump to content

Search the Community

Showing results for tags 'Designer'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests, Suggestions & Discussions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
    • (Pre 1.7) Affinity Range Bugs Forums
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1,895 results

  1. Hi, Usually I can copy and paste from inkScape without any problem. But today I opened a PDF made with Illustrator in inkScape (to convert fonts to curves), and tried to paste it in AD. Problem: the objects are pasted at the right position, but some have a clipped path (and Illustrator add them to a lot of elements), and those pathes aren't at the right position, but somewhere in the top left corner of the page. At first glance, it seem 3/4 of the map is missing. I need to hide/delete the clipping pathes to get back the elements. (I can't share the PDF file on this forum.)
  2. Hi, When opening a file with missing fonts, and exporting it as SVG (and perhaps other formats), AD shouldn't export text using Arial font infos, but keep original font infos. The replacement font is only a way to visialize text until we've got the missing font installed, the document shouldn't be modified this way (this is important, since the replacement is usually a poor one).
  3. Hi there, I am currently working on a project in Affinity Designer. Somehow, since a week, the app is very slow. If I draw a line with the vector brush tool, it takes about 8 seconds for the app to process and display the line (see attached video file). I've tried the following: - restarting the app - restarting the iPad several times - disconnect and reconnect the Apple pencil - checked if everything is up to date in the App Store - whether the iPad is charging, charged 100% or detached from a charger: it reacts the same - the Apple pencil is fully charged Other drawing programs such as Procreate are working perfectly, so it's nothing to do with the iPad or the Apple Pencil. The app is somehow crashing all the time. It's been like this for five days now, without any changes. Hopefully you can help me with this! WhatsApp Video 2019-09-17 at 15.23.54.mp4
  4. Dear forum, I have an annyoing issue with using artboards in Affinity designer: In pixel mode, as well as in pdf exports, I get a very small, but noticeable white or light-coloured edge on my objects. This is only noticeable in affinity on zooms of 10000% but easily noticeable in pdfs on lower zoom levels (See scrawly annotated attachement). I already tried adjusting the contour, deselecting any effects, as well as playing around with edge or radius options. This for me makes artboards completely useless, as in print outputs (where I normally use them) this issue is fatal. I hope that anyone could suggest any hints! Thank you very much!
  5. When modifying hte opacity of a colour, the swatch/round/rectangle that shows the colour should display the colour at 100%, not lighter (colour panel) or darker (gradient panel).
  6. I've been playing around with affinity designer and I was trying to make some font corrections when I spotted this problem; I found no way to convert layer effects to vectors, more specifically, the layer's stroke. Is there a way to do this? To expand curves to layer effects and include them in so that they are regarded when I i.e. use geometry functions using them?
  7. I have a unusual issue with my designer file, I can't open export persona with this file. (tested on 2 computers also). I have a new designer project and see that nothing wrong. Just this file has problem. icon.afdesign Affinity Designer 1.7.2.471
  8. HI All, I recently purchased all three programs and moved to Windows 10 OS. I have a new PC so I'm starting from scratch - installing fonts onto my system. I'm still using Adobe CS6 products while I transition to Affinity, I have a lot of print files (Magazines, Ads, Flyers etc.) which use specific fonts that I have to continue using so in order to move I have to be able to access the font files in Affinity. I have hundreds of fonts Truetype, Open Type and Postscript Type 1. The installed fonts all showed up in my Adobe Suite but not in Affinity? I use FontExpert to manage installs but I have also tried installing directly to Win10 fonts folder. The results are quite random. I get a different (Limited) selection of installed fonts each time I open a program - and never the full range of typeface options (Light, medium, regular, bold etc) Is there a setting I am missing to activate the installed fonts? Any solutions welcome? Thanks in advance
  9. Hi, Manual rotation of the object (with handle) does not recognize choosen rotation reference point in Transform panel. It always rotate it from center.
  10. I’m am new to bleeds, so maybe I’m doing something wrong, but… If I create a new document in Designer for iPad, and in the document setup dialog I don’t create an artboard, then once the document is created, I can select Bleed from the document menu and add & change bleeds on any side. If, however, I create a new document and select Artboard in the document setup dialog, then once the document is created, I select Bleed from the Document menu, I get the options to view & create bleeds, but they don’t show up. Also, the Include Bleed option is disabled on PDF Export. Likewise, if I create a document without artboards, and then add a bleed (say, on just 2 sides), it works fine, but once I selecte Document—>Artboards and add an artboard, I can no longer add or edit the existing bleeds. Are bleeds meant to work with artboards? Can different artboards within a single document have different bleeds? (I’m guessing not.) Thanks.
  11. Hi all, I'm considering buying Designer but one thing that I can't find is if there is a way to fill an object using vector or patterns. I only find gradients and bitmap. I know we can duplicate an object to create hand made pattern but I can't then edit the repetitions like if is a bitmap fill. Cheers, Juan
  12. Hello, Affinity community, has anyone noticed importing brush error? This is after the latest updates. Have never had this problem before. Since the problem exists in the affinity designer as well as affinity photo, i thought better ask the community. i cannot import any brushes in either of the programs. If anyone knows the fix, please lmk. Thank you Gyan
  13. Good afternoon, I've just had designer crash/immediately close on its own while trying to follow an online tutorial to make a seamless pattern utilizing the symbols function. For five times in a row now, I've gone to move the small black rectangle/resize it to fit inside/snap to the edges of the red square, and upon each attempt to resize the program has immediately closed itself with no warning. Please advise? Thanks, S.Freeze SeamlessPatternForTechSupport.afdesign
  14. Hi everyone I'm completely new to vector editing (so you'll have to bear with me if I use the wrong terminology to describe what I've done/am trying to do or need to ask you to clarify what you're telling me) but I said I'd help my wife create a logo for her blog and potential YouTube channel, and have dabbled a bit with Affinity Photo, so here I am, giving the trial version of Designer a whirl. My aim is to export the end result as an SVG and in a bitmap format so she can do with it what she wishes (or as is more likely to be the case, tell me what she wants me to do with it) So, what I'm trying to do is create a stylised ball of yarn, with the lines depicting the strands transparent so that if there's something behind the ball of yarn it will show through. I've managed to do this but I think I may well have done it the hard way, and my result is a bit scruffy in places, so I want to find out if there's a better way to achieve what I want before I do any further editing. I started out with a fresh document with no background and created a circle. Then, in a new layer, I drew a white curve which I copied & pasted & rotated to form the outlines of the strands of yarn. This is the first point where I got stuck and may have chosen the wrong (or at least, a non-optimal) way to go about things. I needed to remove parts of some of the curves where the "strands" they were being used to depict needed to look like they were going underneath other strands. From my limited understanding of such things, I thought I should just need to add some additional nodes to the curve either side of where I needed to remove it and then delete the section of curve between those. I can't quite remember what it was I tried (this was last night) but I couldn't seem to get this to work. After a quick google, the only method I could seem to find that worked was to go into the Pixel persona and use the Erase tool to remove the parts in question, but that's where things got a teensy bit scruffy. Having completed the erasing, I had my pattern of defining lines I wanted to use to cut out of the circle. Again, I got quite stuck here. From another quick google, I thought that if I grouped the lines all together into one shape, I'd then be able to cut that shape out from the base circle by selecting both layers and using Subtract. But when I had both layers selected, Subtract wasn't an option, only "Divide", and clicking this didn't appear to have any effect. I tried various different things, including selecting individual curves rather than the whole lot (but that didn't achieve the desired effect and one of the things I did appeared to remove a "D" shaped section rather than the shape of the curve, although I've a theory as to why that was) but wasn't having an awful lot of joy. In the end, what I've done this morning on my commute to work, is create a selection from the white curves and then I (somehow, can't quite remember what I did now) managed to select the base circle layer and use the Eraser tool again to erase the bits of the circle within the selection. The end result looks right, apart from some scruffy areas from when I erased parts of the white curves, but I'm sure there must be an easier way to achieve the same result. I've attached the design as it stands so far. Any tips or pointers towards tutorials that'll help me figure out the best way to do things will be much appreciated. yarn-logo.afdesign
  15. Hi there, I’m currently in the process of evaluating the Affinity apps to replace the Adobe-subscriptions for me and some colleagues. Photo and Designer look very promising so far (Publisher not yet). Actually I’m using Affinity Designer to replace Illustrator for over a year now, doing more and more real client work. But there is one thing I think is too complicated/cumbersome compared to Illustrator and I almost can’t believe this isn't easier in Affinity Designer. That’s exporting. I often have a file with many Artboards (for iconfonts). I need to export individual SVG-files for every Artboard. When I go to the Export-Persona, I can change the export settings for every Artboard in the Slices-palette. But I have to do this for every single Artboard. Is there no way to just export all checked Artboards as SVGs (or whatever) or change the settings all together and not individually? And while I am at it: Is there a way to make a new document with, let’s say 100 Artboards of the same sice, neatly ordered with a certain distance in rows and columns. In Illustrator I can do that right in the New-File dialog. In Affinity I copied and layed out the Artboards by hand. I Hope someone can help me to overcome the last hurdles and rid of Adobe ;-) Thanks a lot.
  16. is there a way to trace images to vectors paths?
  17. I have noticed perhaps a significant issue in both Designer 1.7.2 and Publisher 1.72 after loading Affinity Photo 1.7.2 Images in either app. Designer and Publisher both crash when a <Print> command is entered. I have attached macOS 10.14.6 (18G95) error reports and uploaded them to Apple. I have been forced to export from Photo to a .png or .jpg format for the 2 apps to work properly. Please advise ASAP as it is much better to have a Designer + Publisher + Photo workflow rather than being forced through an extra stage of exporting .afphoto images. Many thanks amcd Publisher Crash on Print.rtf Designer Crash on Print.rtf
  18. Hi, I've made an attempt to run Affinity Designer on Linux via Wine. I managed to run the program myself, but it is not possible to create or edit a document. The problem is probably with Direct3D support in Wine or in my GPU (maybe drivers). I will describe how to install and run the Designer via Wine. Maybe someone can successfully create or edit a document (eg with a different GPU). The operating system used is Ubuntu 18.04. What we need? Windows (yes, I know) - it can be a virtual machine. It will be used to extract the installation of the program because the standard installer does not work under the Wine. Wine with some patches - we must add MoveFileTransactedA/W stubs to kernel32. The building of Wine is required. Winetricks. 64-bit mscms.dll library. Affinity Designer installer and license. Offline installer of .NET Framework 4.0 and .NET Framework 4.7.2. Step 1 – build Wine We must build and install 64-bit and 32-bit Wine with patch. Building of Wine on Ubuntu is very well described on the WineHQ wiki: Building Biarch Wine On Ubuntu. Don't forget to apply the patch from attachment (fix.patch). During the building process I installed additional libraries like libvulkan-dev and libvkd3d. Step 2 – create MSI installer of Designer This step must be done on Windows. Open the command line (cmd.exe) and go to the directory where the Affinity Designer installer is located. Run the affinity-designer.exe /extract command (the file name may be different). Complete the required data and create an MSI installer. Transfer the created MSI file to your system with Wine. Step 3 – install Winetricks The Winetricks installation is described on the project page: Winetricks. I prefer a manual installation of latest Winetricks instead install outdated version from repo. Step 4 – create Wine prefix and install .Net framework Installation of .Net Framework with Winetricks doesn't work for me, that's why I do it manually. Initialize new Wine prefix: WINEPREFIX=~/Designer wineboot –init Change the system to Windows XP (for correct installation of .Net Framework 4.0) and remove the mono if installed: WINEPREFIX=~/Designer winetricks winxp WINEPREFIX=~/Designer winetricks remove_mono Download and install .NET Framework 4.0: wget 'http://download.microsoft.com/download/9/5/A/95A9616B-7A37-4AF6-BC36-D6EA96C8DAAE/dotNetFx40_Full_x86_x64.exe' WINEPREFIX=~/Designer wine ./dotNetFx40_Full_x86_x64.exe /q Change the system to Windows 7 and switch mscoree to native (this is very important): WINEPREFIX=~/Designer winetricks win7 WINEPREFIX=~/Designer winecfg Download and install .NET Framework 4.7.2: wget 'http://download.microsoft.com/download/D/D/3/DD35CC25-6E9C-484B-A746-C5BE0C923290/NDP47-KB3186497-x86-x64-AllOS-ENU.exe' WINEPREFIX=~/Designer wine ./NDP47-KB3186497-x86-x64-AllOS-ENU.exe /q Step 5 - run Affinity Designer Switch system to Windows 8.1 or 10. Designer will not start in Windows 7 mode due to Aero errors. WINEPREFIX=~/Designer winetricks win81 Install Affinity Designer (in my case MSI installer is Affinity.msi) WINEPREFIX=~/Designer wine msiexec /passive /i ./Affinity.msi Copy the missing mscms.dll library to Affinity Designer instalation directory. In my case it is ~/Designer/drive_c/Program Files/Affinity/Affinity Designer/. I have found the missing library on dlldownloader.com: mscms.dll. Start Affinity Designer: WINEPREFIX=~/Designer wine "C:\Program Files\Affinity\Affinity Designer\Designer.exe" The program should start and you will see the welcome screen. I can open preferences and change options, but creating a new document causes a crash. In Performance tab my GPU is displayed as Intel(R) HD Graphivs 4000 (I have Intel® UHD Graphics 620). Crash report: Attempting to create Direct3D device with adapter Intel(R) HD Graphics 4000 c:\buildagent10\work\live\persona\windows\libraries\serif.directx\dxrenderer.cpp(676): error 0x80004001 (Unknown error 0x80004001) In the last step I tried to start the Designer using Vulkan-based D3D10/D3D11 implementation. After this (and install mesa-vulkan-drivers) in Performance tab my GPU is displayed correctly, but the program still crash while creating a new document. WINEPREFIX=~/Designer winetricks dxvk Crash report: Attempting to create Direct3D device with adapter Intel(R) UHD Graphics 620 (Kabylake GT2) c:\buildagent10\work\live\persona\windows\libraries\serif.directx\dxrenderer.cpp(676): error 0x80004001 (Unknown error 0x80004001) I know that Serif developers don't provide support for running Affinity programs via Wine. The post is for information purposes only. fix.patch
  19. Hello, I've been tasked with making a logo for a client of mine and have ran into a dead end basically at the very end. My issue is this, I have my completed artwork ready to export, I use the default (EPS for export) preset and created the file. When previewing my file on the default Macos image viewer it displays it correctly with my shapes, gradients etc. Now I want to take my EPS files and open them in Affinity Photo and Publisher, both for mockup and business card work respectively. My vector artwork has missing elements and the elements that did stick have wrong gradients/colors. I thought this was a issue with my document so I opened a new one but the problem persists. When opening the said eps file Publisher and Photo they will always display the same missing elements and artwork. Ive tried expanding the artwork but the issue persists. I have no idea what else to do, I can only come to a assumption that Affinity Designer can't export EPS correctly. I even selected the artwork and changed it to one of the default grays found in the swatches and when exporting it the artwork comes out intact!!! Below are the steps I did to come these same results every time along with screenshots. 1. At my original document where the logo was created I then selected the one I want to use. 2. Next hit the menu bar and choose export 3. From there choose EPS for export and for the AREA choose selection without background and leave the other options untouched. 4. For this example I made a folder and exported the file to that location my desktop. 5. Here you can see the file in the folder I created and the preview it ends up showing. * There is no text because it is colored white so its hidden here. 6. Here I'm going to open the file in Designer. Notice how the artwork and the gradient looks. > These are just shots of the same EPS opening in Publisher and Photo. > I copy and pasted the same artwork but changed it to one of the greys in the default Greys swatches panel. Here I opened the EPS and it came it out intact! In the end maybe I'm still doing something wrong with the way the export is. If someone can help me with this I would definitely appreciate it! I want to continue using Designer to make my branding, and logos, etc.
  20. I am not sure if this is the right place... I did some artboards in DESIGNER - then i switched to PUBLISHER where the artboards were converted into pages... !!!! and then I want to switch back into DESIGNER (CAUSE I CAN)... BUT... pain!!! Where are all my PAGES OR ARTBOARDS?!?!??! only one left?
  21. Hi, On AD .445 (because some bugs prevent me to use last versions), it's impossible to add a second style with a stroke of a different width, and the only solution is to add a new category to save this style. But there's another bug: I tried again today — why not? another day, another AD behaviour?! — to add another stroke with a different width and a different pressure curve, and this actions deleted all styles from the 2 previous categories with styles of the same ilk!!!! Going back in the history or reopening the file didn't restored the styles in those categories.
  22. Good morning everybody, I am finding another thing that seems to be missing from Designer which I use an awful lot in CorelDRAW and which is kind worrying to me unless maybe I'm missing something. In Corel I have a blend tool. I believe Illustrator has the same thing though I don't use Illustrator. It allows me to create two objects and blend them together. This is particularly useful for creating interesting drop shadows and so on. Is there really no way to do this in Designer? I'm attaching a screenshot to show you what I mean. Corel allows me to choose which aspects of each object interact with one another. Hopefully there is some way of doing this or it will be added as it seems like a very important tool to me. Thanks very much and let me know! Phil
  23. Not exactly sure how to call this "feature" but I think in Illustrator it was called "Isolation Mode". What I want to be able to do is, for example, enter a group and drag a selection over a few elements without interfering with background elements. Without, obviously, having to lock them previously. Is there something to accomplish this? It seems like a really basic feature and it's essential to my workflow. How do you guys deal with this type of situations?
  24. Since updating to 1.7, the BASIC erase brush has been very choppy, only erasing in what seems to be full circles, just repeated. Before the update, Erasing was smooth and I was able to mask cleanly and accurately, but this has made that no longer possible. Is there any way to fix this?
  25. Application Hang macOS - Designer Computer: iMac Retina 4K, 21.5, 2017, Radeon Pro 560 4 GB macOS: 10.14.6 (all updates) Designer: 1.7.2 Used the Duplicate command to copy a simple rectangular shape. After using Command J four (4) times I used Command S to save the recent changes. The application hung with a spinning beach ball and had to force quit to recover. Report attached: Affinity Designer _2019-09-09-204251_iMac.hang.zip
×