Jump to content

Search the Community

Showing results for tags 'fonts'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
    • (Pre 1.7) Affinity Range Bugs Forums
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 283 results

  1. Hello all. My name is Eryk and I'm a font-a-holic. I just got Affinity to see how it will work compared to Illustrator and unfortunately, at this point, I can't really try it because the loading time is unacceptable due to the number of fonts on my system. I don't want to remove my fonts, or deactivate/reactivate as needed. I like to browse different fonts as I'm working on a project, I rarely go into a project with a set font in mind. Is there anything I can do on my windows 10 PC, to speed up Affinity's loading of my fonts? Sorry if this question has been answered already. I promise I did a search on the forums for slow loading with too many fonts, and I didn't find anything relevant. Thank you and warm regards, --Eryk
  2. I have been a user of Serif products for years and wish to convert to Affinity products. So I have many Serif projects to convert into Affinity Designer projects. I have exported the Serif Draw Plus files to SVG files so they can be imported into Affinity Designer. The SVG files from Serif Draw have text boxes stored as: <text x="0px" y="0px" style="font-family:'TimesNewRoman', serif;font-size:32px;">Mains Power Security</text> The text boxes have been changed after importing into Affinity into: <text x="0px" y="0px" style="font-family:'TimesNewRomanPSMT', 'Ugly Face', serif;font-size:32px;">Mains Power Security</text> All my text boxes are now displayed in Ugly Face. YES - it is ugly and not usable. I have tried edting the SVG file to change TimesNewRomanPSMT to TimesNewRoman and remove Ugly Face but my text boxes are still displayed in Ugly Face. What needs to be done to ensure that the text boxes are displayed correctly in TimesNewRoman? Richard
  3. Please help. I bought a new MacBook Pro, and did a successful migration of data and files from my other MacBook Pro. Affinity Photo appears to have migrated over, but it's not recognizing most of my fonts in Font Book. These unrecognized fonts have an exclamation point before their names in the character window module. Quite frustrating. I'd be grateful for any help. Thanks in advance!
  4. Hi guys. I need an advice. I know there is no such a thing like "Faux Italics" or "Faux Bold" in Affinity products. I tried to find the way how to push Photo to do that... and there is way. ITALICS: In Character - Positioning and Transform there is an option Shear to slant selected text = set an angle. BOLD: Add the stroke to selected text Fine, it works, I could do it manually so let's make some macros and set couple of possible options which I can use in the future. I was able to record the macros for both, even for combo "faux bolditalic". It's not a rocket science, macros are really simple 1 or 2 steps. But it might helps you, guys... or inspire you to play with macros and set some other interesting text styles And my question is: Is there any other, more elegant way how to do this kind of trick? Edit: I uploaded macros for you FauxBoldItalics.afmacros
  5. Tengo dos meses luchando con un problema en Affinity Designer, sucede cada vez que quiero cambiar el tipo de fuente, al dar clic a la caja se Fuentes se queda frisado y tengo que hacer cierre forzoso porque no vuelve a responder, he actualizado a la ultima versión y el error sigue, he desinstalado toda la aplicación y he vuelto a instalar y el error sigue. Agradezco a quien pueda aportar una ayuda a solucionar este problema. Saludos. -----------ENGLISH------------ I have two months struggling with a problem in Affinity Designer, it happens every time I want to change the font type, by clicking on the box Fuentes is frozen and I have to do forced closure because he does not respond again, I updated the last version and the error continues, I have uninstalled the entire application and I have reinstalled and the error continues. I am grateful to anyone who can help to solve this problem. Greetings.
  6. Hi All, Just wondering if like the 'notification' we could somehow get a menu item to display all fonts used and those that are currently unavailable to the document. Pretty much all illustration/layout programs have a feature except Designer. Apologies if this has already been asked for, but I would think it's quite an easy 'win' for the roadmap? Regards, M
  7. Hello Dave & Crew, Any chance of supporting descriptive names in stylistic sets? I can send an updated version of the font you have of mine if you would like one to test if you desire. Mike
  8. AD 1.6.1 and AP 1.6.7 on macOS High Sierra 10.13.3 When I click on the "Fonts" select/dropdown menu in the top left corner when I'm using the Artistic/Frame Text tools nothing happens - the drawer that usually shows all fonts doesn't even open - but a beachball appears until infinity and then I have to force quit the app. What I tried to do that didn't solve the crash: 1. Resetting all preferences by holding Ctrl when opening both apps. 2. Completely deleting and reinstalling both apps. 3. Using Font Book, disabling all "User" fonts and also validating all "Computer" fonts. I've been using AD and AP for a while with no issues for a long time. The only recent change that I can think of which could be possibly triggering this is that I updated Pages/Keynote/Numbers to the latest versions that were released yesterday (7.0, 8.0 and 5.0 respectively) and since then I'm getting the Affinity crashes (but the Apple iWork apps work all fine). Could the updates be a coincidence or is there a relevance? How can I troubleshoot further?
  9. I have a reasonably powerful Windows 10 PC (64-bit) and it takes about 2.5 minutes to start Designer or Photo. I have a large number of fonts installed but that's necessary to because I'm a font designer. I'm often dealing with font specimens and I need them all there. Is there are way to reduce loading lime besides reducing the number of installed fonts? Would it make much of a difference if it was installed on a SSD?
  10. I would find it very helpful if I could call up a font list with a RMB and subsequently roll through choices for some selected text. The location of the font menu to the far left of the workspace is a bit tedious at times.
  11. I am currently at a loss on what could be happening. After downloading all faces for OpenSans, I get duplication within the font selection menu in Affinity Designer (see screenshots). The specific issue comes when I select "semibold" which then causes the faces menu to go blank and and "?" question mark to appear in the fonts menu for OpenSans. Where is Affinity designer look for its fonts (directories)? Does Affinity Designer use OpenSans internally? I think the simple work around is to just install the non-duplicates (it is what I will end up doing if I can't resolve this). I've tried to do several things, to find the duplicates: 1) Uninstalled OpenSans (the Light, Light Italic, Regular, Italic, Semibold, Bold faces remain) 2) Installing OpenSans again (I get duplicates, but the only one that causes the blank menu is the "SemiBold" face) 3) Disabling OpenSans (same as #1) 4) Searching for the fonts files, Terminal: find / -name "OpenSans*" 5) Checking specific font locations https://support.apple.com/en-us/HT201722 6) Restart 7) Preferences > Clear Fonts
  12. Hello, I just tried to print something that I have prepared from the latest version of AD 1.6.1. While on the screen the design looks good, when I am printing it, the quality of the fonts is very poor. They look sort of "pixelised" or out of "focus" if I am allowed to say. When I am using to print from any other application, the quality of the same font, or any other fonts looks as it is expected to be. Definitely, it is not a printer problem. Am I missing something or is it a bug? Best regards, A. Ps. This is an image of the print page.
  13. Affinity Designer does not correctly decode the available font variants. I believe this is a regression from AD 1.5 affecting the new font panel in 1.6, but I could be wrong. Please reference the attached screenshot, showing the actually installed fonts, the font selected in AD, and the font styles available per AD. This is under Windows 10 1709. I can provide the font files in question if a private email address I can send them to is provided.
  14. Hi after I've updated to Affinity Designer 1.6 font AmSans which used to work on previous version now is missing. Thankfully I had old backup of Affinity, so I'm back on version 1.5.5 where everything works. While on 1.6. I've tried disabling a reenabling this font as well as reinstalling it, nothing has worked, Affinity DEsigner as well as Affinity Photo ca not see this font. I'm using Mac Os High Sierra, MBP 13inch 2013.
  15. Affinity Photo version 1.6.6; MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports); macOS High Sierra version 10.13.3 I have installed some fonts on my Mac and some of them are not showing in the font list in Affinity Photo. These fonts work and appear correctly in other Mac apps. The attachments showing an example of Bittersweet Capital showing as installed in the Font Book but not in Affinity Photo. Can you please advise if I did not install the font properly or there is a fix on its way? Thanks, Dat
  16. Hello, Apologies if this is already a topic but I am literally at my wit's end trying to figure out what is causing font issues in Affinity. This is my first week using the program and I have read over a dozen different sites on how to fix these issues and nothing is working! I am working with marketing materials within Affinity and noticed a message saying I was missing some fonts (attached). Naturally, I knew that missing these was causing existing text to size improperly because my Mac did not have said fonts. So I installed the needed fonts: Futura LT, Futura Std, Open Sans, Pier Sans, Proxima Nova, Proxima Nova Condensed and Source Sans Pro. These were downloaded through my employer and are working for other computers but mine is having issues. After downloading these fonts, the alert saying that I was missing them is now gone. But, the documents are still messed up as if I do not have the font. When I click on the impacted text in my documents it shows: ? Futura LT (Can be seen in the upper left corner of the second attached image) Is this display essentially saying the text is a form of Futura LT which my Mac doesn't recognize, aka I don't have the font? Because I am not longer receiving the missing font message. I have tried uninstalling and reinstalling. Removing and reinstalling the fonts from font book on Mac, everything, and it still is not displaying the text correctly! I am also looking for Mac info regarding Font Book. Some of these fonts downloaded and installed are showing as yellow when validating but am not entirely sure how that impacts Affinity. Once removed from Font Book its back to step 1 which are the display messages saying I am missing fonts. I am running out of options after trying so many different things. ANY help would be greatly appreciated. Will be talking to our designer tomorrow morning to see if he may be able to figure it out. But for now, I am looking for any assistance. Thank you!
  17. Completely new to this so not sure what I'm missing. In photoshop I could change the fonts just by having the text layer selected and scrolling through the list of fonts that I have. That doesnt seem to work in Designer. After I've typed in something and press enter I get a layer with all the letters on separate layers under it and picking different fonts doesn't change anything. How do you change fonts after you've typed in something?
  18. Hi - I have been trying to change the font (Raleway) on a file repeatedly and as soon as I hover the font I need (Reem Kufi) AP crashes. RK is used everywhere else in the file, but as soon as I try to change the paragraphs in Raleway to RK AP crashes. I can change Raleway to all other fonts however that doesn't solve the problem as I need all fonts to be consistent.
  19. Any ideas why my fonts change to an odd assortment of characters when exporting a file to PDF for print? This test is shown on a selection of fonts from A to C from my fonts on iMac when using Affinity Designer. The other pdf is exported as the flattened option that shows the correct fonts. If I am going to send a file to a printer with bleed and crop marks then I need to use the Export to Print option. This really worries me as every character will need to be checked. Export flattened.pdf Export to print.pdf
  20. Hi, I am starting into designing a simple, mostly text logo and have run into something I haven't seen before with fonts. I am hoping somewhere here can help. As I had a piece of text highlighted and was trying out different fonts shown in Designer's font list, I noticed that there are many non-English fonts (likely Mac OS system fonts) that are being displayed with English characters. Might anyone here know: 1) Why is this occurring? 2) Is it possible to make non-English fonts not appear in Designer? 3) Is it possible to find out which English font is being substituted in for the chosen non-English font? For example, I happened upon Malayalam MN which looks good for what I need, but the actual Malayalam MN font isn't an English one, and I need to know what is the actual font replacing it in Designer.) Thanks!
  21. Hey, Just wondering where Affinity Designer (not sure about Photo) downloads missing fonts from when you open up a document without them installed. Never really needed the feature, just curious. Popped a screenshot in to highlight my question. Cheers!
  22. Hi, I am trying to use Gujarati fonts in my Affinity Photo on my MacBook - I can see in the Font Book there are 2 Gujarati fonts available, 1. Gujarati MT and 2. Gujarati Sangam MN and they both are looking good in Font Book. However when I try to use the same font in Affinity Photo, somehow the writing remains in English only!!! Steps: Add either Artistic Text Tool or Frame Text Tool in the Photo Now select any of the above mentioned Gujarati fonts from the drop down above Start writing words Actual: It is writing in English only Expected: It should write in Gujarati fonts For your reference I have attached the screenshot of my image and in that words "asd" should have come in Gujarati however it has not.
  23. I think this is a bug. Latest Affinity Designer from Apple Store on latest MacOS. Font is Segoe Print from Microsoft. The last closing bracket is too close to the previous text. See pic included. I think this is incorrect kerning? Perhaps the font definition itself is faulty?
  24. Helllo, guys. I'm new to the fórum and I'm using Affinity Designer since the beta for Windows. Since the beta I'm having trouble handling new fonts. Seriously, from update to update the fonts just don't work. I have to unninstall everything, losing my color palletes because we don't have na export tool. Today I've got very frustrated by wanting to use a very especific font from Google Fonts and I can't. I can't use Lato. I can't seem to find the reason why this is happening. Sometimes unninstalling Works, sometimes not. I've searched for this problem in other places, didn't find much. Nobody seems to be with this issue, but me. Do you guys have any idea why this is happening? I already tried launching the app with administrator rights, as well. No good.
  25. I am using the version 1.6.2.97 of affinity designer, the font menu runs very slow for me in windows 8, when I try to select a different font, the whole program lags. I uninstalled every font WIndows would let me so there are only 30 or so fonts left and I ctrl+ opened Affinity to reset the defaults but the lag is still there. I love the program but right now it's unusable any help?
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.