Jump to content

Recommended Posts

Hello,

I used to use Photoshop until it became a monthly fee, and now I use and love Affinity.

I had a question though on plugins for Photoshop, specifically Mr Retro plugins. I have Mr. Retro plugins, and while Affinity can locate and recognize them as plugins, they never actually work when I try to run a filter in the plugin. It always just freezes or crashes Affinity. I was wondering if this is something in the works for Affinity in the future, to be able to use these efficiently. 

Thank you very much for your help.

Share this post


Link to post
Share on other sites

Hi ScottP,

Welcome to the forums.

Plugin development is always ongoing so hopefully more will be supported as updates continue to be released.  Looking at the Mister Retro site, they don't list as being compatible with Affinity Photo and I can't recall this make being one that we know has been tested. Even though the plugins are detected, the issue may be the way Affinity passes the file to the plugin or the way the plugin applies effects. It may be worth trying different colour modes RGB 8Bit/16Bit as some plugins may only work with a particular colour mode.

Share this post


Link to post
Share on other sites

Hi ScottP,
Welcome to Affinity Forums :)
What Mister Retro plugins are you using? I remember testing a few on a Mac for an older of Affinity Photo version (1.5). Most of them didn't work (see here for details - select Mister Retro on the left column -click on the link's name for details on the right). I don't believe this has changed but I can take a look again.

Share this post


Link to post
Share on other sites

Thank you,

 

I use Permanent Press 2, and it is literally the only thing I sometimes (regrettably) go back to Photoshop for aside from the real brush media. Everything else is faster and more efficient in Affinity Photo for me. Thank you for your help.

Share this post


Link to post
Share on other sites

Hi ScottP,
Sorry the delay getting back to you. That was one of the few I tried that didn't work/was not compatible with Affinity Photo 1.5 (on Mac) at the time. I haven't tried the latest version of the  Permanent Press 2 plugin with the latest version of Affinity Photo (1.7.2) but it's possible it still doesn't work/it's still not compatible. I will check/confirm this. What OS are you running - macOS or Windows?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.