Jump to content
Peter Pokorny

Performance Problems with AP 1.7.2.147

Recommended Posts

After some Time of edditing a picture affinity Photo is going rapidly down in Performance so that drawing a Color Ort sizing the picture hast some Second Delay on my iPad Pro 12.9 3. Generation Running iOS 12.4.

Share this post


Link to post
Share on other sites
3 hours ago, Peter Pokorny said:

After some Time of edditing a picture affinity Photo is going rapidly down in Performance so that drawing a Color Ort sizing the picture hast some Second Delay on my iPad Pro 12.9 3. Generation Running iOS 12.4.

Seriously Peter Pokorny, are you really serious?   Really? 

Maybe you should try Pixelmator P P.  They have a forum over there as well, maybe you can comment over there.  

I find nothing valid about your comments about the beta version 1.7.2.147 and iOS 12.4.  

Stop complaining about everything and send us a video or perhaps some specific descriptions of just exactly what the problems are. The only thing that I still can't do is Share to Photo.  

As far as wasting space on this forum, please stop unless you are willing to be specific.   

>:(

Share this post


Link to post
Share on other sites

I can be very specific and I am serious. 

I start with opening the RAW picture out of the app Pixave, also tried it with opening the picture out of apple Fotos Mediathek, then do raw editing in develop persona including noise reduction, what is since iOS 12.4 now working. After developing I start with filter frequency splitting and group the 2 layers into a group. After this I create a new pixel layer for skin color adjustment and than I can watch when drawing on this layer the brush lines I draw will be displayed seconds after I was drawing them and even enlarging or shrinking the picture with finger gestures seem to react after some seconds and not imidiatly as it was before update to iOS 12.4. And this is true for the versions 1.7.1 and 1.7.2.147. And one other thing I am not the only person with performance issues on iPad. 

Share this post


Link to post
Share on other sites
2 hours ago, Peter Pokorny said:

I can be very specific and I am serious. 

I start with opening the RAW picture out of the app Pixave, also tried it with opening the picture out of apple Fotos Mediathek, then do raw editing in develop persona including noise reduction, what is since iOS 12.4 now working. After developing I start with filter frequency splitting and group the 2 layers into a group. After this I create a new pixel layer for skin color adjustment and than I can watch when drawing on this layer the brush lines I draw will be displayed seconds after I was drawing them and even enlarging or shrinking the picture with finger gestures seem to react after some seconds and not imidiatly as it was before update to iOS 12.4. And this is true for the versions 1.7.1 and 1.7.2.147. And one other thing I am not the only person with performance issues on iPad. 

I can do same steps but I'm on iOS 12.31. No issues here. 


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Have you done a reset to clear cache memory? Hold power button on till you see Apple logo and then let it restart.


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Hey Peter Pokorny,

I think you really need to either provide us with a video or at the very least a file with steps for us to follow. I've done something similar to what is seen i DM1's video and it's fine for me too. 

Share this post


Link to post
Share on other sites

I completely believe Peter, I have similar issues with the Beta with my work, I've given an example video on the beta forum.  However the issues aren't just limited to resizing/rotating they can crop up seemingly at random given enough time and complexity of work.

Share this post


Link to post
Share on other sites

Thanks Frank!

I think it could have something todo with memory management. When the iPad runs longer and I try to work on a picture it starts to happen shortly after the frequency splitting of the picture and grouping the two layers. I just tried it again after I have had the iPad for a longer time shut off. this time the issue didn't show up. But I guess if I leave the iPad in stand by and try the same later it will appear again. 

 

Share this post


Link to post
Share on other sites

But I can provide the steps until it happens for sure. 

1.) I open the RAW (ARW-File) out of the Pixave library

2) i do raw processing including noise reduction and say develop

3) i do auto corrections in photo persona

4) i do frequency separation with the filter and group the two resulting layers

after that AP starts to freeze from time to time. the steps are usually that how they are explained in the AP Workbook for beauty retouching. 

 

Share this post


Link to post
Share on other sites

Your iPad Pro has 1T so it has 6Gb of ram.  Not quite sure that anything that you have show here could be considered workflow but I did the scribble test as well using the same iPad Pro as yours, with iOS 12.4 and do not understand what you are complaining about.  My suggestion is that you show an image that you have worked on rather than the scribble test   

For both frankthechicken and Peter, here is a vid that I recorded, using AP for iPad beta and a 1T iPad Pro (3 gen).  Absolutely no problems. 

Share this post


Link to post
Share on other sites

p_mac, I can't see where you tried rotating, or resizing any of the groups of layers?

 

If you notice, the slow down occurs when I try resizing or rotating groups of layers on a large document.

 

I only demonstrated this as it represents what happens during my workflow when I am using a number of layers and groups and trying to perform operations on them.

 

I suggest you try making a large document (say 16000x8000 pixels), scribble a few layers, say seven, combine them into a group and then try to resize/rotate them.

Share this post


Link to post
Share on other sites

p_mac

I tried to let AP open in background for several hours and activated the app after that time. and before I have done anything in AP I was expiring a laggy app. now I try to downgrade my iPad to 12.3.1 where such things didn't happen and try it again. 

Share this post


Link to post
Share on other sites

I can also demonstrate it using a smaller document say a 4000 x 4000 pixel document.  Although it requires a few more operations in a row (though still around 7/8 layers in 1 group).  All it requires is a few rotations/resizing as demonstrated in the video I made and the app begins to considerably slow down.  Eventually the app will cease responding.

 

No, this is not a genuine use case, but it demonstrates that there is a flaw in the app.

 

This flaw rears its ugly head again and again in my general work (i.e. slow down with eventual app crashing), so much so that I have to keep returning to the main menu in an attempt to ensure the document is saved before it freezes completely.

Share this post


Link to post
Share on other sites

Is it any better with new beta1.7.2.149?


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.