Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

frankthechicken

Members
  • Posts

    47
  • Joined

  • Last visited

Everything posted by frankthechicken

  1. Not a huge issue, but slightly annoying iPad Pro 2018 1TB EDIT **Not sure why I've got 2 videos here** RPReplay_Final1596633213.mp4 RPReplay_Final1596633213.mp4
  2. I still get a line and a dot unfortunately. I would rather only allow the context menu to be dismissed by pressing OK, rather than having to go back in history/erase whenever I forget. But there are bigger things to worry about!!
  3. This has regressed to prior .168 Beta with the last two versions (1.8.2.172 and previous) In other words the line is being drawn again after tapping off the context menu.
  4. Thanks for letting us know. I think I would have preferred forcing the user to tap OK on the popup as it is easy to forget and having to correct the error blob much later is a pain.
  5. Beta .168 Partial fix to tapping away from popups Still get a dot when tapping away, no longer get a line forming it seems. The dot is the size of the previous brush size. A start I guess!
  6. This bug was, I think, first introduced in 1.7. After my limited testing 1.8 seems like a huge improvement on 1.7, so huge congratulations to the team. It seems to be back to the wonderful standards of 1.6, which is great. My main annoyance of 1.7 was the slowdown when resizing layers, this seems to be vastly improved in the new version. There are a few occasions when resizing/moving layers long slow downs occur but it's nowhere near the levels of 1.7.
  7. After changing the size of the pencil width or colour, tapping off the menu to close it with the pencil causes a straight line to be drawn. The only effective way is to tap with your finger. Clearly one should be able to tap off the menu with the pencil. *Edit* I should have stated this is 1.8.0.165 on a 1TB iPad Pro 2018 RPReplay_Final1582029380.mp4
  8. Photo still cannot cope with transformations of groups, though I'm wondering whether its just shrinking the groups which causes issues (particularly shrinking smaller than their original size?) In these videos one shows that no issues occur when simply enlarging the groups, however there is significant lag when one attempts to shrink the groups (these are unadjusted sample pictures pixel dimensions 2560x1440):- This is with the latest Photo release 1.7.2.153 on a 1TB iPad RPReplay_Final1566425259.mp4 RPReplay_Final1566425594.mp4
  9. As a further example, I've made a video of a document which is 10000 x 10000 pixels (equivalent to about four layers of 5000 x 5000 I guess) and performed the same scaling and translating with no lag. Surely this should be further evidence that there is something wrong with the group implementation? RPReplay_Final1565273562.mp4
  10. However, I can manipulate single layers with wild abandon, with no slowdown whatsoever. Note these videos are done at 5000 x 5000 pixels RPReplay_Final1565254091.mp4
  11. I have just been testing the latest version 1.7.2.151, and unfortunately the same problems occur. Any kind of manipulation of groups of layers is resulting in complete slowdown, and degradation of work. Leading to files being unable to be saved. I realise that I am probably coming off as a pain, but I just want Photo to be back to the glory of 1.6. When I try to manipulate groups of layers (in this case, just two), even with kid gloves, I experience horrendous slow down. Note that when the blue touch circle is on screen (and paused) the app has hung. When there is no blue circle I am giving the app every chance to recover. RPReplay_Final1565253975.mp4
  12. Thank you so much for the detailed reply. I'm glad that something has been sorted out, I'm looking forward to loving this amazing program once more. I'm not quite sure I understand the reasoning that given as I would have expected similar problems when dealing with single layers. Unless one is dealing with the group as a whole (rather than individually) and then referencing memory that has not been allocated I guess.
  13. To be honest it doesn't require much to get the app to slow down to a crawl, just manipulate a group of 3 layers or more on a reasonably large canvas for a few operations and you will experience serious slow down. If one works on individual layers then the app seems fine and smooth as it was on 1.6, however working with groups of layers is still very buggy.
  14. Just as a further example, I've performed the same operations to individual layers (i.e. not in a group) and it is far harder to get the system to slow down. RPReplay_Final1565092284.mp4
  15. I have an iPad Pro 1TB edition on iOS 12.4, and I can demonstrate a very simple video to show how the lagging occurs. Whenever it seems my touch is staying in one place, lagging is occurring (I have not simply held the touch there) It seems to be most prevalent when using groups of layers, the lag also builds up over a period of time. Eventually the system becomes inoperable, and one can lose all work or progress. It should also be noted that if one were to try to return to the main menu after the lag has begun, the file sometimes will not save. RPReplay_Final1565081610.mp4
  16. To be honest I was not running into any of the halting problems on the previous 1.6 build, I think there is a flaw in the coding somewhere. It feels like a memory leak. The iPad is a very capable device nowadays.
  17. The latest beta (1.7.2.149 RC1) stills shows the problem. What I haven't demonstrated is that once this slowdown has started, the app can stay very unresponsive, even if one waits long enough for the app to have finished calculating what it needs to. As soon as the slowdown occurs, it becomes necessary to quit the app, and hope it is able to save your document, else one faces lost work. Also worth noting that it is not just resizing/moving/rotating the groups of layers, this is just the most easily demonstrable. I find it occurs with almost any task when dealing with groups of layers. It is such a problem that I have to either dramatically reduce the amount of layers of work with, or (and this only occasionally works) hide the layers I am not working on. I can also demonstrate this happens with smaller documents (in this case 5000 x 5000 pixels). At the end of this video I was trying to choose a colour but the app was unresponsive. Please note, I am manipulating a group of layers RPReplay_Final1564513172.mp4
  18. Ive decided to record a video of the issues, please note I've done it this way as its always reproducible. However I find the with any large documents with just a few layers, the app slowly grinds to a halt and then needs to be forcibly quit. This will happen for any work I do over a short period of time, with enough complexity. iPad Pro 12 1TB HD iOs 12.4 The end of the video is where the app has hung, occasionally it manages to eventually fix itself, but mostly I have to forcibly quit the app and lose all my progress. RPReplay_Final1564486371.mp4
  19. Still terrible performance on large documents (16000 x 8000 pixels), I can add about 3 photos to this, and then try drawing and get enormous lag and general slow down. I also have to duplicate originally saved images in order to save them to iPad. Simply saving them to iPad does not work. None of this was occurring on 1.6
  20. I have used this beta fairly extensively, and there have been lots of improvements. However I am still finding fairly significant slow down on larger documents (I'm using 16000 x 8000 pixels) once we enter into a few layers of use (around 15 to 20). There tend to be significant slowdowns when trying to move or resize the layers (or groups of layers). I find that sometimes saving the document and then trying again to move the layers can improve performance. However this can lead to other issues such as significant delays in saving the files and sometimes not even being able to get back to the main menu. I am having to reduce the number of layers I work on to get work done unfortunately. I am also finding that occasionally I am unable to choose a new tool, the UI seems to acknowledge my presses but does not respond until I reset Photo. I was not facing these issues on 1.6. I am using an iPad Pro 12.9 with 1TB HD space
  21. I have been trying the new Photo for iPad 1.7.1.141, and the same issues as before. Terrible lag on drawing with large document. And if the document is detailed enough (i.e. enough layers) simply moving a layer is enough to cause a crash.
  22. I have been trying the new beta of photo on my iPad as 1.7 introduced significant lags on pencil use for large documents. Although this has improved, there is still quite considerable lag noticeable, especially as one adds layers and details. This is noticeable on drawing, erasing, most pencil interactions. To use an example to demonstrate the lag, create a 16000 x 8000 document, start drawing on a layer, add a new layer start drawing, repeat. It generally only takes around 6 or 7 layers for severe lag to start occurring. This did not happen for Photo 1.6 and previous versions. EDIT I should have stated this is 1.71.140
  23. Many thanks for the quick reply, I think I'll try the beta once the issue has been fixed. Thank you letting me know how to join the beta program, all fantastic information. And thank you for the superb application, it really is joyous (when working!).
  24. Wonderful, hopefully this has fixed the lag when drawing with the pencil on a larger document. How does one install the app? If I open a document with the beta can I no longer open the document with a previous photo version? Many thanks in advance.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.