Jump to content
MannaTheBerserk

Affinity Photo - Multiple selections and custom shortcuts

Recommended Posts

Hi everybody,

Probably a silly question, though still worth asking: how do you ad selections when you have already created one?

Example: pick the Lazo tool and select an area of your image (or the Rectangular Marquee... Any selection tool really). Now select another area while maintaining the previous one intact.
Just add more selections after the first one in the same image.
In Photoshop you just hold "Shift" and keep adding selections.

Second question: customizing the keyboard shortcut doesn't seem to work. When I insert a new shortcut, in my case "ALT + Backspace" to fill the canvas with the foreground colour, the software doesn't let me write the "Backspace" bit after the "ALT".

I hope someone will be able to answer and clarify both my questions?

 

Thank you in advance!

 

Mauro

 

P. S. I forgot to mention that I am on Windows and the last version of Photo.

Edited by MannaTheBerserk

Share this post


Link to post
Share on other sites

Hello @MannaTheBerserk and welcome to the forum.

1. The modifier to add to a selection is unusual, and takes a bit of practice!

Hold the left mouse, then hold the right mouse, then drag (the mouse cursor will change to show a + if you did it right)

Note also that the status bar will always tell you the modifiers that apply to your current situation.

Alternatively you can change the mode to Add in the context toolbar.

2. I can confirm that Backspace (even with a modifier) is not accepted as a shortcut - could be a bug?


Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites
2 minutes ago, Aammppaa said:

Hello @MannaTheBerserk and welcome to the forum.

1. The modifier to add to a selection is unusual, and takes a bit of practice!

Hold the left mouse, then hold the right mouse, then drag (the mouse cursor will change to show a + if you did it right)

Note also that the status bar will always tell you the modifiers that apply to your current situation.

Alternatively you can change the mode to Add in the context toolbar.

2. I can confirm that Backspace (even with a modifier) is not accepted as a shortcut - could be a bug?

Awesome! The add selection works. Though I think it's counterintuitive and I will change it if possible.

 

Regarding the shortcut yes, it's definitely a bug then, otherwise how would you explain the other shortcuts containing the Backspace (like inpaint)?

 

Thanks a lot!

Share this post


Link to post
Share on other sites

I think we intentionally prevent you from assigning shortcuts to certain keys such as Backspace and Delete. For example, Ctrl+Alt+Del would always bring up the security dialog and I don't think we could override it. Perhaps we also blocked Backspace to prevent you deleting objects/text without realising... Saying that—I don't know why we elected to use Backspace for Inpainting... it seems like an odd choice and that is what is unusual here...

I think this is probably 'by design'.

 

Update - I should have checked macOS. We can add Backspace on macOS so I'll check with the Windows dev's.

Share this post


Link to post
Share on other sites
8 minutes ago, Chris B said:

I think we intentionally prevent you from assigning shortcuts to certain keys such as Backspace and Delete. For example, Ctrl+Alt+Del would always bring up the security dialog and I don't think we could override it. Perhaps we also blocked Backspace to prevent you deleting objects/text without realising... Saying that—I don't know why we elected to use Backspace for Inpainting... it seems like an odd choice and that is what is unusual here...

I think this is probably 'by design'.

 

Well, these choices don't make much sense to be honest with you.

If I "accidentally" delete something, or make a mistake, I can always go back (Undo) and I am fine.

I have been using Photoshop since v2 (no layers back then), quite a long time I would say. The total customization of the shortcut keys should be in Affinity as well.
If you are afraid that some beginner will make mistakes, then preventing the use of certain keys in the shortcut is not the right way to help them, nor a valid excuse.

If you want to achieve that kind of "design" choice, then just add a "beginner" level and an "advanced/expert" level option to the general preferences.

Share this post


Link to post
Share on other sites
5 minutes ago, MannaTheBerserk said:

Well, these choices don't make much sense to be honest with you.

I'm speculating whilst I wait to hear back from development. I didn't say it was a choice. If it is a choice, I will let you know why once I get my reply.

Share this post


Link to post
Share on other sites
Just now, MannaTheBerserk said:

I am pretty sure it's a bug, trust me.

If functionality is different from the macOS version then yes, it generally is considered a bug if it isn't something OS specific. I edited my first reply to say I should have checked macOS before replying as we can use the keys on there.

Share this post


Link to post
Share on other sites

I have just verified what happens on my wife's iMac.

The Mac OS version works as expected. I was able to customize the shortcuts by assigning "ALT + BACKSPACE" to "Fill with foreground" and "CMD + BACKSPACE" to "Fill with background".

So it's definitely a bug with the Windows version.

Share this post


Link to post
Share on other sites
17 hours ago, MannaTheBerserk said:

So it's definitely a bug with the Windows version.

Yep—because we can do it on macOS, it is considered a bug on Windows so this has been logged.

Share this post


Link to post
Share on other sites

@Leo Leong

Are you using it on a rasterised layer? I have just assigned Alt+Backspace to the  operation “Fill Primary Colour” (I had to unassign it from Inpaint first). Rasterised my layer and used it with success. 
 

Cheers!

Chris

 

Share this post


Link to post
Share on other sites
On 6/9/2019 at 9:29 PM, MannaTheBerserk said:

the software doesn't let me write the "Backspace" bit after the "ALT".

 

Hi @MannaTheBerserk

You don’t write the word backspace, you simply click in the box and press the keys you would like to use for the shortcut.

Cheers!

Chris

Share this post


Link to post
Share on other sites
3 hours ago, Chris J said:

@Leo Leong

Are you using it on a rasterised layer? I have just assigned Alt+Backspace to the  operation “Fill Primary Colour” (I had to unassign it from Inpaint first). Rasterised my layer and used it with success. 
 

Cheers!

Chris

 

I did.

The problem is that no custom shortcut works. I have assigned "CTRL+BACKSPACE" to "Fill with Primary Colour". Nothing, it just doesn't work.

It's the exact same behaviour that occurred last year.

Share this post


Link to post
Share on other sites
4 hours ago, Chris J said:

@Leo Leong

Are you using it on a rasterised layer? I have just assigned Alt+Backspace to the  operation “Fill Primary Colour” (I had to unassign it from Inpaint first). Rasterised my layer and used it with success. 
 

Cheers!

Chris

 

On a pixel layer. I have Ctrl+backspace for Fill secondary colour, and it is working, but the shortcut with Alt+Backspace is not responding.

Share this post


Link to post
Share on other sites
8 hours ago, MannaTheBerserk said:

I did.

The problem is that no custom shortcut works. I have assigned "CTRL+BACKSPACE" to "Fill with Primary Colour". Nothing, it just doesn't work.

It's the exact same behaviour that occurred last year.

Can you post a screenshot of the Shortcuts window with the “Fill Primary” option showing please?

Also, what version of Photo are you using?

Share this post


Link to post
Share on other sites
6 hours ago, Leo Leong said:

On a pixel layer. I have Ctrl+backspace for Fill secondary colour, and it is working, but the shortcut with Alt+Backspace is not responding.

What version of Affinity Photo are you using please?

Share this post


Link to post
Share on other sites

This is working for me, please see this video of what I did:

At 17 seconds I pressed Alt+Backspace and you can see it fills the pixel layer. If this still is not working for you, you might want to reset the app. I would recommend doing this safely as we can restore and potential lose customisations. Please follow these steps:

  1. On your keyboard, press the Windows key + R
  2. In the RUN box type %appdata% and click OK
  3. Now go to Affinity\Photo and rename the 1.0 folder to 1.1
  4. Now restart the app and reassign the shortcut and see if it works!
  5. Note - the screen recording was done in the beta because that's just the second app that I tried it in. It works in the current retail 1.8.5.703.

Share this post


Link to post
Share on other sites
7 hours ago, Chris B said:

This is working for me, please see this video of what I did:

At 17 seconds I pressed Alt+Backspace and you can see it fills the pixel layer. If this still is not working for you, you might want to reset the app. I would recommend doing this safely as we can restore and potential lose customisations. Please follow these steps:

  1. On your keyboard, press the Windows key + R
  2. In the RUN box type %appdata% and click OK
  3. Now go to Affinity\Photo and rename the 1.0 folder to 1.1
  4. Now restart the app and reassign the shortcut and see if it works!
  5. Note - the screen recording was done in the beta because that's just the second app that I tried it in. It works in the current retail 1.8.5.703.

 

Hey Chris,

The fill with primary colour works now. Though the fill with secondary doesn't, no matter what shortcut I assign it to.

Share this post


Link to post
Share on other sites

It is working now.

I went and delete the assinged "Alt + Backspace" on fill primary colour and assign it for cut function, it worked.

Then I reassigned it to fill primary colour, now it is working 😂 Hopefully it lasts.

I have been reassigning it previously but no result, this is the first time i assign it on another function and reassign it back, and it fixes it, kinda.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.