Jump to content
will w

grid turns off when document is closed then re-opened.

Recommended Posts

With 1.7, when I exit out of a document then re-open, or when I open Designer and select a document I have previously worked on, the Grid is turned off. This did not happen in 1.6.

Also, it would be nice to have a grid toggle button somewhere, though that's more of a feature request.

I am running latest version of iOS, iPad Pro 11" with Pencil.

 

Thanks!

Share this post


Link to post
Share on other sites

Great update with v1.7 Serif. 

For this post’s issue, I’m experiencing the same problem.

Regarding a grid toggle button, you can...

- Select Grid in the document menu

- Tap Show Grid in the Context bar at the bottom


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites

Sorry, by a toggle button I meant a button that stays on the screen (like the snapping toggle button lower left side), so the grid can be quickly toggle off and on. 

In general, it would be great to be able to customize what tools have dedicated on screen buttons.

Share this post


Link to post
Share on other sites

Excellentttt. Would put a Mr Burns cartoon here (The Simpsons)


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites
18 hours ago, will w said:

Sorry, by a toggle button I meant a button that stays on the screen (like the snapping toggle button lower left side), so the grid can be quickly toggle off and on. 

In general, it would be great to be able to customize what tools have dedicated on screen buttons.

Agreed


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites

Quick addition: I am finding that the grid also sometimes turns off while I'm working. When I go the the menu and select "grid", the show grid button is on (highlighted), and I have to turn off then on to get the grid back. I'm not sure what I'm doing when the grid goes off, as I have not noticed it when its happening---I just notice at some point that its gone.

Share this post


Link to post
Share on other sites
12 hours ago, will w said:

Quick addition: I am finding that the grid also sometimes turns off while I'm working. When I go the the menu and select "grid", the show grid button is on (highlighted), and I have to turn off then on to get the grid back. I'm not sure what I'm doing when the grid goes off, as I have not noticed it when its happening---I just notice at some point that its gone.

Hi will w,

Could you keep an eye out for what you're doing and let us know if you spot anything that is causing it!

Share this post


Link to post
Share on other sites

Hi Sean,

Update: If I select "Place Image", then place the image and double click on it to edit/add to assets, then click the <-- button to return to my document, the grid is gone. When I select  "Grid" to turn it back on, the show grid button is already activated, and I have to click then unclick to reactivate the grid.

I guess maybe as far as AD is concerned, moving to an embedded document and then returning to main document is the same as exiting the document then reopening, so might not be different than the issue already discussed.

On a side note, when I return from editing the embedded document the main document is always highly pixelated until I pan the canvas. This happened in previous versions as well, though, so I assume devs are aware of this bug?

Also, I have had a lot more trouble lately with failing palm rejection, gestures being interpreted as non-gestures, and even eratic behaviour when trying to pan/zoom (also panning and zooming is often not smooth or fails or ends up moving an object). I think at this point the most egregious issue is this, plus the fact that the "touch for gestures only" option doesn't really work at all.

Thanks!

 

Share this post


Link to post
Share on other sites

This issue still exists in 1.7.1. (though many far more important issues were fixed---palm rejection, issues with gestures and touch, etc.)

Share this post


Link to post
Share on other sites

The new 1.7 version is a great achievement, but....hopefully we will see another release before too long as there are still a number of major bugs that the devs are aware of but are yet to fix. :(

Multiple artboards priniting as single page PDF.

Guides not working with multiple artboards.

Bleed Settings not working properly.

Set rotation target not  adjusting in Transform studio.

Copy pasting symbols across docs causes crash.

Corner tool context menu not updating correctly.

Pen tool context menu Node Adjustment can't smooth nodes (breaks original node).

Grid spacing issue makes impossible to set exact grid spacing.

Grids not displaying accurately when zoomed in.

..... and so on.

 


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Just a note that as of 1.7.3.1, the grid issue described in this thread is still happening. I've also noticed that when rotating the canvas, the grid can become (or at least render) slightly off from the geometry that has already been snapped to it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.