Jump to content
MattP

Affinity Designer Customer Beta RC2 (1.1.2.23562)

Recommended Posts

Again Matt, thanks a lot. I know this is nothing what could be "corrected" in a second and the RC has priority. Cause I know about the difficulties I can currently live with it - it's no showstopper at all, so please take your time. :)

 

Document Setup - Transparent background - Assign/Convert. Ouch, truley this confused me and so I never had the idea to try it out. Thanks for that tip. Sometimes ... I think moving the Transparent button down under will help :D

Is it correct that Assign/Convert is only vissible if I have a document open and not when creating a new document? Ok, that may make sense.

Hm, if I change from Convert to Assign, close the dialogue and reopen it - it's back to Convert. A bug, wanted or do I still something wrong :huh:

I'm so sorry for again bothering you ...


iMac (Retina 5K, 27-inch, 2017), i7 4.2, Radeon 580 Pro 8 GB, 40 GB DDR4-RAM, 1 TB Flash, macOS 10.13.6

Share this post


Link to post
Share on other sites

Hi Markus,

 

Please don't apologise for anything at all - we're both trying to make the program as good as it can be and iron out the niggles! :) I'm currently trying to see if I can make it default to CMYK import as a quick-fix (because it is arguably more important to be able to retain exact CMYK values than RGB values). I have also come up with a very simple way to detect what the EPS file format was meant to be (or if not we can offer a choice as you suggested). If it turns out to be very safe, I'll add it before the App Store update - if not, I'll add it to the beta...

 

It's arguable what the 'convert/assign' button should default to after you have closed that dialog - but I think I'd like it to remember what I last selected as I'm more likely to want the same again next time, so we'll try to sort that out in future. Incidentally, the 'transparent background' check box has now been moved! :)

 

Thanks again,

Matt

Share this post


Link to post
Share on other sites

Not sure if it was reported but I found serious bug in RC2. Basically I cannot change font of the text. The font selection box is disabled and it even doesn’t show the currently selected font. The only way for me to change typeface is via Character window. See attachment.

 

 

post-4735-0-98823600-1426157128_thumb.png

Share this post


Link to post
Share on other sites

Not sure if it was reported but I found serious bug in RC2. Basically I cannot change font of the text. The font selection box is disabled and it even doesn’t show the currently selected font. The only way for me to change typeface is via Character window. See attachment.

 

Do you get the 'All Fonts' collection in the character window?

 

Can you run the console application, and then start up Designer and go into the text tool. Do you get any error messages in console?

 

Edit: Can you also give us your computer specs, and OS X version?

Share this post


Link to post
Share on other sites

Hi Markus,

 

Please don't apologise for anything at all - we're both trying to make the program as good as it can be and iron out the niggles! :) I'm currently trying to see if I can make it default to CMYK import as a quick-fix (because it is arguably more important to be able to retain exact CMYK values than RGB values). I have also come up with a very simple way to detect what the EPS file format was meant to be (or if not we can offer a choice as you suggested). If it turns out to be very safe, I'll add it before the App Store update - if not, I'll add it to the beta...

 

It's arguable what the 'convert/assign' button should default to after you have closed that dialog - but I think I'd like it to remember what I last selected as I'm more likely to want the same again next time, so we'll try to sort that out in future. Incidentally, the 'transparent background' check box has now been moved! :)

 

Thanks again,

Matt

 

Perfect Matt, so I'm curious if it's in. :) Big Tx! :)


iMac (Retina 5K, 27-inch, 2017), i7 4.2, Radeon 580 Pro 8 GB, 40 GB DDR4-RAM, 1 TB Flash, macOS 10.13.6

Share this post


Link to post
Share on other sites

Hi Markus,

 

In the Mac App Store update version we are now performing a test to try to establish if the eps file is likely to be rgb or cmyk. If it is a mixture then I have assumed cmyk. This is a safe change, but to throw up the dialog to ask which format you would prefer is starting to get more dangerous, so I have not done that.

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Do you get the 'All Fonts' collection in the character window?

 

Can you run the console application, and then start up Designer and go into the text tool. Do you get any error messages in console?

 

Edit: Can you also give us your computer specs, and OS X version?

 

I do get All Fonts in character window. In the console I didn’t find any recent error message for AD beta. Currently I am running OS X 10.10.2 on MacBook Air 13" mid-2013 (MacBookAir6,2)

Share this post


Link to post
Share on other sites

Was anyone from the Affinity Labs able to reproduce the Division Operation error and if so, would that be something that will be fixed for the RC.  It is something that I use all the time and I had to revert back to prior beta because it is broken in this one. 

Share this post


Link to post
Share on other sites

Hi Signguy,

 

Yes, I mentioned in my 'improvements/fixes' that divide now produces the results it used to and doesn't crash any more.

 

Sorry about that,

Matt

Share this post


Link to post
Share on other sites

I did notice it listed in the improvements/fixes section but yet it isn't working in this beta 1.1.2.23562.  That is why I was wondering if you were able to fix it for the next beta or RC.

Share this post


Link to post
Share on other sites

I did notice it listed in the improvements/fixes section but yet it isn't working in this beta 1.1.2.23562.  That is why I was wondering if you were able to fix it for the next beta or RC.

 

Can you possibly send me a file which isn't working? support@seriflabs.com

 

Thanks! :)

Share this post


Link to post
Share on other sites

I forget if this has been mentioned—I'm working with a vector file with some wonderful layered gradients, and it seems to be exporting a TIFF quite nicely in CMYK (which I plan on using), but on attempting to export an EPS with unsupported effects rasterized, I'm getting what looks like a reversed image.

post-5843-0-53768200-1426188014_thumb.png

Share this post


Link to post
Share on other sites

Thanks guys for making such a great app! Just downloaded for first time yesterday. A couple of things I haven't seen in the forum that deserve some attention are that in the Help "drop down" menu the Affinity Designer Tutorial handbook is not printable (major bug which shows a bunch of weird stuff in the print que), and the Eraser in the pixel persona "tools", does not work for me AT ALL. I hope you guys are able to fix both of these when the new version comes out. When do you believe the newest app version will be released? Thank you for your time. ~Ricky.

Share this post


Link to post
Share on other sites

The printed image comes out just like the preview in the Print dialogue.

 

The missing part of the ELO has a gradient and a gaussian blur on it.

 

I can export and print the image and it prints perfectly via the Preview app.

 

 

post-4679-0-11277500-1426225873_thumb.png

Share this post


Link to post
Share on other sites

Thanks guys for making such a great app! Just downloaded for first time yesterday. A couple of things I haven't seen in the forum that deserve some attention are that in the Help "drop down" menu the Affinity Designer Tutorial handbook is not printable (major bug which shows a bunch of weird stuff in the print que), and the Eraser in the pixel persona "tools", does not work for me AT ALL. I hope you guys are able to fix both of these when the new version comes out. When do you believe the newest app version will be released? Thank you for your time. ~Ricky.

 

Hi Ricky,

 

Thanks for the feedback! :) On the Eraser tool - have you got something selected first before trying to erase it? It operates on a selection and automatically applies a pixel mask to it that you could then paint back in later if you wanted to change things...

 

[EDIT:] Actually, thinking about things... if you haven't got a selection and you use the Eraser, I think it's quite reasonable that you'd expect to insert a mask layer at the current point in the layers panel and you'd expect to be erasing from that... Hmmm, now there's an idea! :)

 

I'm hoping to be finished coding the App Store update within the next hour or so, but I'm waiting for some of the translated resources to come back - hopefully we can upload it on Monday or Tuesday and then it's in Apple's hands - typically they turn it around in about 11 days from past experience, but as soon as it's ready we'll push the button - I'm very keen for users to see the real Affinity Designer, not just the one we released to the App Store in November last year! (that's the last time it was officially updated)

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

I forget if this has been mentioned—I'm working with a vector file with some wonderful layered gradients, and it seems to be exporting a TIFF quite nicely in CMYK (which I plan on using), but on attempting to export an EPS with unsupported effects rasterized, I'm getting what looks like a reversed image.

 

Hi Smallreflection!

 

Nice drawing! :) Is there any chance you'd send it to us at support@seriflabs.com and I can pass this to Dave who wrote the new EPS exporter so he can have a look - it could be something that is very trivial to fix and would obviously be great to get sorted at this point :)

 

Thanks!

Matt

 

 

EDIT: Just noticed that you've already sent it - thank you! :D

Share this post


Link to post
Share on other sites

I forget if this has been mentioned—I'm working with a vector file with some wonderful layered gradients, and it seems to be exporting a TIFF quite nicely in CMYK (which I plan on using), but on attempting to export an EPS with unsupported effects rasterized, I'm getting what looks like a reversed image.

 

Thanks for reporting this. It'll be fixed in the next beta/RC.

Share this post


Link to post
Share on other sites

Not sure if this is just a beta issue or just my issue but the latest beta doesn't seem to remember latest open files when you try to open recent.

Share this post


Link to post
Share on other sites

Thx MattP and RussellBWilson for the reply. Come to find out Matt that the entire app just froze on me, so I redownloaded it from the app store, reopened, suffered through several crashes, but now seems to be working fine. Not sure what the problem was, but I'm on a iMac Early 2009 24inch screen, 64 bit. Russell, I'll have to try the Preview and see if I have better luck, thx.

Share this post


Link to post
Share on other sites

Guess we aren't on the same page after all RussellBWilson. I'm trying to print the Affinity Designer Tutorial Booklet that is reached by going into the drop down Help menu. I would rather read the instruction manual in print than on my Mac. Anytime I try to print it, it does some really crazy things in the print dialogue box, and only lets me print one page at a time, however pretty much all of the content is missing or cut off. Any ideas on this one Russell or MattP? I'm very new to this, as a matter of fact have never used a vector based application before, and also have never used Adobe Illustrator. Thanks again to you both for your time.

Share this post


Link to post
Share on other sites

Hi Matt,

 

I don’t know if this is by design, but if it’s a bug, it is still there ... sorry, if this is a duplicate ...

 

Cheers,

Alex  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×