Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Confused by spot colours (naming problem)


Recommended Posts

Hi there!

For a little greeting card I intended to use a transparent coating on some parts of the design. The print shop asked me to create an extra layer for this (at the very top of all other layers) and paint all areas in question with a new spot colour named "lack". So I created a new global spot colour, named it "lack", set the option "overprint" and painted the areas in that top layer with the new spot colour. As requested I exported the document as a PDF/X3 file.

Unfortunately the print shop is not able to print the design as the can't identify any colour named "lack". Additionally they say that there was no top layer. So I'm a bit confused... How can I fulfill the requirements of the print shop?

Any hints are highly appreciated.

Kind regard,
Volker

 

 

Link to comment
Share on other sites

  • Moderators

Hi VolkerMB,

When creating the global colour and setting the Overprint option, did you also enable Spot Colour? Also when exporting to PDF have you made sure the Honour spot colours is enabled under More options?

Link to comment
Share on other sites

Hi Lee,

 

yes, my initial tought was that I might have missed an option (and I probably have) but both options you mentioned were set: spot colour enabled (when creating the global colour) and "honour spot colours" (when expoting to PDF). So I a bit puzzled....

 

Perhaps the original file might give you a clou what went wrong?

03_Weihnachtskarten_A6_v2.afdesign

Link to comment
Share on other sites

You created a spot color named "lack." Is it only suppose to be covering the Frohe text on the first artboard?.

 

Is this a "flood" fill or is it only to be applied to the one element? The attached AD file is a revision. It exports to PDF/X-3 and the spot color is there on that text. Now, they mention to place it on a layer. But PDF/X-3 cannot have layers. So do check that is their desired PDF format. I did add a layer to put it on, though. Oh, I also didn't load the fonts.

 

capture-001564.png.220161d0221ce5832ec013f60164e1c9.png

 

Also, it is possible that whatever they are using for loading the PDF cannot handle the Use Advanced Features in a PDF. that is located under the More button and can be turned off.


Mike

03_Weihnachtskarten_A6_v2-Modified.afdesign

Link to comment
Share on other sites

Hi MikeW,

 

thanks a ton for your effort and your explanation!

 

Yes, the coating is supposed to cover just the word "Frohe", nothing else. 

 

The print shop asked me to create a spot colour named "lack" (just the German word for coating) and use this spot colour for anything that needs to be coated. As this is in fact a transparent colour that goes an top of the other colours I was asked to use this on an extra layer on top of all other layers. Then I was asked to "convert it to PDF/X3 (compatibility with 1.3 preferred)" - and then they complained about not being able to find a spot coloured named "lack" in the file... I guess I need to talk to them now knowing that the generated PDF was okay (apart from the fact, thatX3 doesn't support layers).

 

Again, thanks a lot.

 

Best, Volker

Link to comment
Share on other sites

You're most welcome, Volker.

 

Do note that your file ought to have worked, but I also didn't see the PDF that was submitted to them.

 

Also, if they are loading that PDF into anything like AI for imposing, for whatever reason, then there likely would have been issues regardless of how your PDF was structured.

 

If you would like me to take a look at the PDF you generated and sent or another version, just let me know. If you have Acrobat or pdfToolbox you could just do so yourself as a check, too. But like mentioned, I'm usually around. I do disappear sometimes due to being busy, but a PM will send an alert to my email, so that's a means of catching my attention.

 

Take care, Mike

Link to comment
Share on other sites

Hi Mike,

wow, you offer quite a service!

In the meantime I requested the print shop to specify in detail why they are having trouble to print the document. If you are interested: I've attached the original PDF that I sent to the print shop. Even my Acrobat shows clearly that there is a spot colour named "lack" in the document.

Best,
Volker

 

 

 

 

03_Weihnachtskarten_A6_v2_final.pdf

Link to comment
Share on other sites

Yeah, your pdf is just fine. With perhaps two exceptions. You need bleed unless it is built into your page size. And there is opacity, if I recall on the spot color text. Could be wrong on that but I am traveling and cannot reopen the file at the moment. 

 

Sorry. I should have noted that earlier but was too focused on the spot color to notice. 

 

And I think there is a regression that you should file in the bug section for your OS. That is the snowflakes are becoming bitmaps when they should not be. I thought this was once fixed.

Link to comment
Share on other sites

I was confused by the transparency as well and had to look it up. But that you spotted the regression regarding the bitmaps - remarkable. I'll get it reported (credit goes to you).

By the way: The print shop folks have not been able to specify so far why they can't print the file... I guess, I need to find another print shop...

Again: Thanks for all your help!

Best, Volker

Link to comment
Share on other sites

If possible find a place that can keep transparency live and use pdf/x-4. The text shapes in the upper right that will get the varnish coverage has noise. So those shapes will always become bitmaps. 

 

Even so, if you up the document resolution to 300, bitmaps are fine.

Link to comment
Share on other sites

  • 1 month later...
7 hours ago, Alena said:

My affinity doesn't export layers to PDF at all. The EPs same thing.

How specifically are you trying to do the export? What happens when you try?

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

  • 2 years later...

I created a sticker. The printshop asked for an extra layer named Through Cut with an extra layer including curve with a spot colour (Pantone Proces Magenta U) wich I named CutContour Through Cut. U I saved the afdesign document and exported it to PDF for print (checked Honour Spot Colours). But unfortunately the PDF doesn't show the name CutContour Through Cut in Adobe so the printshop can't use the file. Why doesn't Affinity export the spotcolour-name to the PDF? Or am I doing something wrong?

Schermafbeelding 2020-04-22 om 12.11.16.png

image003.png

Sticker buiten gebruik.pdf Sticker buiten gebruik.afdesign

Link to comment
Share on other sites

28 minutes ago, Lagarto said:

You can add a custom global spot color (here also overprinting) from the context menu of the Swatches panel using e.g. CMYK value M100 and give it a name of your choice:

custom_spot.jpg.4d498b6fd29824f11c2baeaf59a9be4e.jpg

...and it would show as its own plate:

custom_spot_02.jpg.6563ca2e5cb30fc925a4a7c54c273019.jpg

Does the printer really need to have a specific name for the spot colot to be able to use it?

Yes the name is specific and required, upper and lower case. It is how the software sees and knows what it is to use for the cut line. Normal label for cut contours is "CutContour" without the quotes obviously. Did they specifically ask for the spot colour to be named "CutContour Through Cut"?

Link to comment
Share on other sites

3 hours ago, Ingrid Ensing said:

unfortunately the PDF doesn't show the name CutContour Through Cut

Note that every custom spot color swatch in Affinity may get two names: 1 internal in the swatches panel and 1 for output. With a right-click on the swatch you can adjust them separately:

554652674_renamespotswatch.jpg.9994436febb726d673d08eaffe08f364.jpg

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

54 minutes ago, Lagarto said:

Does the printer really need to have a specific name for the spot colot to be able to use it?

In particular in case of a cutting edge it might be useful in an automated printing workflow to prevent this color get printed at all.

This reminds me to bad experience: A client delivered a logo file with a color swatch named "gold". An advertisement using this logo was sent to a few newspapers, they all printed fine except one, which appeared different. Finally it came out it was this printer's RIP which had manually set its own definition to translate an incoming spot color named "gold" into the 4-c process.

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

4 hours ago, Lagarto said:

You can add a custom global spot color (here also overprinting) from the context menu of the Swatches panel using e.g. CMYK value M100 and give it a name of your choice:

custom_spot.jpg.4d498b6fd29824f11c2baeaf59a9be4e.jpg

...and it would show as its own plate:

custom_spot_02.jpg.6563ca2e5cb30fc925a4a7c54c273019.jpg

Does the printer really need to have a specific name for the spot colot to be able to use it?

Thanx everybody for your help! And yes, the printshop requested the specific name CutColour Through Cut.

Link to comment
Share on other sites

  • 2 years later...
On 11/11/2022 at 10:51 AM, MKTJ said:

it's still not clear to me how this works, I still can't give a spot color name what is visible in the pdf that I export, I'm now using version 2.

Hi @MKTJ,
welcome to the Affinity forums!

See the screenshot 3 posts above. I haven't tried in V2 but I assume the process via right-clicking the spot swatch is the same.

Unfortunately naming spot colours appears not to be mentioned in the Affinity Help.

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

8 hours ago, MKTJ said:

If I do that and export to PDF is the name is gone!

"Is gone"? – Does it appear before export? Can you show a screenshot of the Swatches Panel and the Colours Panel (> Tint slider) with a custom named global swatch selected?

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

14 hours ago, thomaso said:

"Is gone"? – Does it appear before export? Can you show a screenshot of the Swatches Panel and the Colours Panel (> Tint slider) with a custom named global swatch selected?

That is what I say, I am not so good in English.

See screenshots, I put a name on it (Name for print).

Scherm­afbeelding 2022-11-22 om 10.27.07.png

Scherm­afbeelding 2022-11-22 om 10.27.33.png

Scherm­afbeelding 2022-11-22 om 10.28.59.png

Link to comment
Share on other sites

4 hours ago, MKTJ said:

See screenshots, I put a name on it (Name for print).

None of your screenshots shows the export name but the Affinity global swatch name only. You can see both names for a spot colour in the Colour Panel > Tint slider.

Example below: The Affinity name "client logo" + the export name "PANTONE 801 C".

1387997884_spotcolour2names.jpg.07aa1f303bf66fe17ba8ef0644bcce8f.jpg

Note in the screenshot above there are two menu entries to change the name, one for the Global colour and below for the spot colour. What your screenshot shows is the name for the global colour. I assume you have not used the menu item "Rename Spot…" yet.

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.