Jump to content
You must now use your email address to sign in [click for more info] ×

Affinity Publisher automatically replacing (A) with @


Recommended Posts

In...

Edit > Settings > Auto-Correct

You can delete that particular replacement

 

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

23 minutes ago, Demonskunk said:

Or it would be lovely if it had worked. I removed (A) -> @ from the list of replacements, but it's still replacing it. This could be a mac bug?

Works fine here on Windows. Someone else will need to confirm on a Mac

In that same dialog you have a check box for "Replace Text While Typing"

Does switching that off prevent the replacing from happening?

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

The same kind of replacement is also possible via the macOS Settings > Keyboard. 

https://support.apple.com/fr-fr/guide/mac-help/mh35735/mac

So perhaps is it to change there… 

Affinity Suite 2.3.1 – Monterey 12.7.2 – MacBookPro 14" 2021 M1 Pro 16Go/1To

I apologise for any approximations in my English. It is not my mother tongue.

Link to comment
Share on other sites

In Affinity Publisher, you can try going to the "Edit" menu and then selecting "Preferences." Look for the "Auto-correct" or "Auto-replace" settings, and you might find the (A) -> @ replacement there. Just delete that entry or disable auto-correct if you can.

Link to comment
Share on other sites

9 hours ago, stokerg said:

Hi @Demonskunk,

Which version of MacOS are you running?  I've tried this on Sonoma and deleting the (A) from Settings > Auto-Correct works fine here.  Didn't even need to untick Replace Text While Typing.

I'm running Ventura.

8 hours ago, Oufti said:

The same kind of replacement is also possible via the macOS Settings > Keyboard. 

https://support.apple.com/fr-fr/guide/mac-help/mh35735/mac

So perhaps is it to change there… 

There's no (A) > @ in that autocorrect menu, alas.

Link to comment
Share on other sites

1 hour ago, Demonskunk said:

Can you post me a screenshot of where to find that?

⌘⇧T or menu Text > Show Typography

PNG50-Capturedcran2023-11-1101_23_31.png.995248308e44ce8c6817fc6ad7546c89.png

Affinity Suite 2.3.1 – Monterey 12.7.2 – MacBookPro 14" 2021 M1 Pro 16Go/1To

I apologise for any approximations in my English. It is not my mother tongue.

Link to comment
Share on other sites

Did you try this, as asked earlier?

"In that same dialog you have a check box for "Replace Text While Typing"

Does switching that off prevent the replacing from happening?"

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

On 11/10/2023 at 9:43 PM, carl123 said:

Did you try this, as asked earlier?

"In that same dialog you have a check box for "Replace Text While Typing"

Does switching that off prevent the replacing from happening?"

Switching off "Replace Text While Typing" *Does* prevent it from happening.

Link to comment
Share on other sites

OK, switching that setting off will affect all other auto-correct replacements that you may want to keep

So, you could try switching it back on and adding a replacement that replaces

(A) with (A)

If that works it looks like it is/was Publisher specific

If not then maybe there's a Mac setting also affecting this

Unfortunately, I do not know anything about Macs to help with that

 

 

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

45 minutes ago, carl123 said:

OK, switching that setting off will affect all other auto-correct replacements that you may want to keep

So, you could try switching it back on and adding a replacement that replaces

(A) with (A)

If that works it looks like it is/was Publisher specific

If not then maybe there's a Mac setting also affecting this

Unfortunately, I do not know anything about Macs to help with that

 

 

Adding (A) -> (A) doesn't change the behavior. It still wants to be @.

Link to comment
Share on other sites

OK, thanks for trying

I'll let the Mac experts continue with this, just in case it's something Mac specific

 

 

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

Doh!

Just remembered that auto corrects are language specific

Your text has to be set to the same language as the auto-correct language setting you are changing

So, for example, if your text is set to no language or English (United States) changing the auto-correct setting for English (United Kingdom) will have no effect

Please check the language your text is set to by highlighting the text and then checking the language setting in the character panel

 

autocorrect.png

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

On 11/12/2023 at 9:40 AM, carl123 said:

Doh!

Just remembered that auto corrects are language specific

Your text has to be set to the same language as the auto-correct language setting you are changing

So, for example, if your text is set to no language or English (United States) changing the auto-correct setting for English (United Kingdom) will have no effect

Please check the language your text is set to by highlighting the text and then checking the language setting in the character panel

 

autocorrect.png

Oh, you've GOT to be pooping me. My language is set to Default (which is English) but the default autocorrect opens to English (UK).

That's... Why isn't the default autocorrect tab set to the same as your general language!?!

Thanks, this fixed it. I just had to edit English instead of Wrong English /s

Link to comment
Share on other sites

1 hour ago, jimrome said:

I removed the replacement definition in the correct language, but (a) still got replaced. But hitting Cmd-z a few times turned it back!

Make sure you don't have any system-wide replacements causing problems. And also try saving and restarting Publisher.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.