Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Another fail with Photo

Recommended Posts

This is my 3rd thread on this release and the 1.9 release. This time I have lots of evidence (attached). 

Basically 1.10 and 1.9 is unusable on my Win10 64bit PC because it is so unreliable. The primary symptom is hangs while doing simple edits. This forces me to rollback to 1.8.5 where I have no problems.

Here are the most recent facts: 

1. indefinite hang while attempting to adjust the brightness on an .afphoto file with 4 layers
2. OpenCl runtime 3.0 (up to date) direct from Intel on my i7-8700k CPU graphics engine
3. Task manager shows Photo not responding, power usage "Very high", 9.7% CPU utilization, about 2 GB memory utilization on a 16 GB system
4. CPU core temperatures all good with the highest being 48C in core 1

See the evidence attached. 

This is the only app on my PC that fails. Other than this my system is fast, cool, reliable, and up to date. 

I like using Affinity Photo, but I'll need to look for alternatives if this continues. 

Any thoughts on how to resolve this?


Affinity Photo 10 not responding.jpg

OpenCl 3.0 from Intel.jpg

Not responding power usage high CPU 11 percent.jpg

Not responding Task Manager.jpg

not responding CPU temps.jpg

Link to comment
Share on other sites

Hello @Muldune

Even if you don't like it now, I recommend that you switch off the hardware acceleration. It's not the ultimate, but it's the only way to use Affinity Photo at the moment. 

AMD Ryzen 7 5700x | INTEL Arc A770 | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.1194)
Affinity Suite V2.0.4
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

"Life is one of the hardest"

Link to comment
Share on other sites

Komatos:  OK, I turned off the hardware acceleration and Photo 1.10 seems to be working now. I recognize that you recommended I do this before, but I wanted to get it to work with my current hardware (and it doesn't). I wanted to make sure that there is/was nothing wrong with my hardware and it seems that my hardware is fine. 

I've got to call this a bug in Photo 1.10 and 1.9. 

I appreciate your response and suggestion.



Link to comment
Share on other sites

  • Moderators

The driver you have for the UHD Graphics 630 seems to be flagged as not working by other forum users. Reports of rolling back to 27.xxx seems to allow OpenCL to function correctly.

For what it's worth, my personal rig is on 27.xxx and works seemlessly. I will update to 30.xxx and see if I can reproduce the issue being flagged.

Link to comment
Share on other sites

Hi Chris, 

I used the original failing document (meteorite watch poster rock 2.afphoto) to test 1.10 yesterday with hardware acceleration turned off. Because it worked, I saved it with changes. So I doubt you will find a problem with it. 

I attach a second document (meteorite watch poster.afphoto) which is untouched by 1.10 and was created in 1.8.5. 

Here are the steps I took when I experienced the latest hang:

1. Open .afphoto file
2. Select the meteorite image brightness layer (see screen shot)
3. Go to "Adjustment" and select "Brightness Contrast"
4. Select one of the adjustment images which brings up the Brightness/Contrast popup
5. Slide Brightness to the left to darken the image about -60%

Note that I experienced hangs under a variety of other circumstances, typically when doing simple edits. 

Select layer.jpg

meteorite watch poster rock 2.afphoto meteorite watch poster.afphoto

Link to comment
Share on other sites

I tried many times to get a crash using your file but I never got one.

-- Window 11 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad Pro 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 9th gen 256 gb - Apple Pencil 1

Link to comment
Share on other sites

AlainP: Yes, I'm not surprised.

The thinking is that Photo is hanging because I am using the Intel CPU's built in graphics function rather than a separate graphics card. By turning off hardware acceleration in Photo, I can use 1.10 without hanging (so far). The idea is that Intel's OpenCl is not compatible with Affinity's use of OpenCl. Because all my other image applications work without issue, it seems that Affinity's use of OpenCl is the issue. 

Link to comment
Share on other sites

  • Moderators

Hey Muldune,

Thanks for the file. I have tried it this morning and again, it's fine for me... I don't think there's anything wrong with the hardware at all - we're both using the UHD 630 for this test.

It's likely a driver more than anything. We often recommend completely removing any trace of the driver using DDU and doing a clean install. For some reason, just updating the driver doesn't always work.

For now, I'd recommend keeping OpenCL disabled - you aren't losing anything per se over the 1.8 version. Development will continue improving OpenCL over time so I'd check out any Windows beta's that pop up if you want to keep trying.

If you decide to keep trying OpenCL and if you get crashes we could look at the reports or if the app hangs, we can look at the dmp files from Task Manager. 

Link to comment
Share on other sites

18 hours ago, Muldune said:

ChrisB, I found the original file that had the subject issue on one of my backup drives. Please find attached. 

meteorite watch poster rock 2.afphoto 36.94 MB · 1 download

I could not provoke a crash with the file either. I also had no lags.
Do you have any third-party antivirus software in use?

Perhaps there are also Windows system components that are outdated or even defective. To rule this out, you should use the sfc tool.
To do this, click with the right mouse button on the Windows Start symbol. Select CMD (Administrator) from the list. Type sfc /scannow and confirm with Enter.

AMD Ryzen 7 5700x | INTEL Arc A770 | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.1194)
Affinity Suite V2.0.4
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

"Life is one of the hardest"

Link to comment
Share on other sites

Let's try this again:

ChrisB and Komatös: Thank you for your suggestions and support. 

I've worked about 6 hours on this issue today. Here is a summary:

- ran DISM.exe successfully
- ran sfc.exe, it found and repaired some corrupt files
- ran sfc.exe again, it did not find any integrity violations
- ran a full system scan with Microsoft Defender (anti-virus), it found an adware executable and deleted it, my system is now completely clean
- enabled "UAC Virtualization" in the BIOS
- as instructed by my BIOS, installed Intel Rapid Storage Technology
- upgraded the BIOS on my ASUS Z390-A motherboard to the latest stable version, 1802
- upgraded Photo to

After each change above, I rebooted and tried Photo again with the same unfortunate result. I looked at the logs, error report, and Task Manager. They provided little insight: "Photo Not responding", "UAC virtualization Disabled", "Hardware error", "Power usage Very High", "Memory(active private working set) 1,119,436K" (see excerpts attached).

My goal is to understand the root cause. If there is something wrong with my system, I want to fix it. 

Your thoughts?


DISM and sfc run 1 & 2.jpg

No current threats.jpg

Virtualization enabled.jpg

Hardware error.jpg

Photo Not Responding.jpg

Photo memory and UAC virtualization.jpg

Task Manager.jpg

UAC virtualization Disabled.jpg

Windows error report.txt

Link to comment
Share on other sites

5 hours ago, Muldune said:

Hardware error details

A hardware error can have various causes, including faulty RAM.

To check the RAM, you can use the Windows Memory Diagnostic Tool.

Open the Windows search and type in Windows Memory Diagnostics (be careful, the memory test can take a long time).

AMD Ryzen 7 5700x | INTEL Arc A770 | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.1194)
Affinity Suite V2.0.4
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

"Life is one of the hardest"

Link to comment
Share on other sites

  • Moderators

Google suggests the LiveKernelEvent 141 doesn't seem to have a specific cause but is hardware releated - as you've probably already read.

I'd try things like unseating the RAM and graphics card along with the suggestion from Komatös. I will continue to poke this as well.

Link to comment
Share on other sites

ChrisB and Komatös: Thank you for your thoughts on this. 

Here is today's summary: 

- ran Windows Memory Diagnostic and "No memory errors were detected"
- ran Windows Defender offline scan, no viruses or other problems were found
- opened Capture One 21 and it took about 9 minutes for "Setting up hardware acceleration" 
- found that Capture One 21 automatically detects and uses OpenCL
- created a Catalog in Capture One and included a large .tif file
- did multiple edits, saves, and exports of the .tif file in Capture One
- Capture One was fast and stable with no errors or hangs
- purchased Geekbench benchmark utility for Windows
- ran Geekbench utility for OpenCL performance
- OpenCL benchmark utility ran to completion with no errors or hangs
- the OpenCL benchmarks were in the range of other comparable Intel CPU/GPUs
- opened Affinity Photo, it hung this time after about 5 adjustments to the brightness of a layer (this is actually an improvement of the 1 or 2 adjustments before)

I see no evidence of a problem with my hardware.

I am now refocused on Affinity Photo. Perhaps Photo development is using an older OpenCL compiler, SDK, and/or environment. Whatever it is, it is isolated to Photo. At least I can use Photo with hardware acceleration turned off. 

Memory test results.jpg

Capture One installed.jpg

Capture One hw accelleration.jpg

Capture One HW acceleration with OpenCL.jpg

Capture One 21 using OpenCL.jpg

Geekbench 5 OpenCL test.jpg

Geekbench 5 OpenCL test results.jpg

Geekbench Intel P630 OpenCL benchmark.jpg

Link to comment
Share on other sites

17 minutes ago, Lem3 said:

Did you ever use DDU to completely remove the Intel graphics driver and then do a clean install of either 27.xxx or 30.xxx?

Do you know if DDU removes Intel drivers? I'd like to try this, but the website only mentions AMD/NVIDIA drivers.

Link to comment
Share on other sites

Lem3: Thanks for your comment. 

From what I read, DDU is for AMD/NVIDIA drivers. And, I'm hesitant to completely remove a display driver and restart with bios/default.

I used Intel Driver & Support Assistant to install OpenCL, and the UHD Graphics 630 driver. It handled it easily with no complications.

I have little to no evidence of a display driver problem. I need more reasons before I completely remove it. 

Link to comment
Share on other sites

2 hours ago, PeteMacca said:

Do you know if DDU removes Intel drivers? I'd like to try this, but the website only mentions AMD/NVIDIA drivers.

There has been one instance in the forums where Intel recommended using DDU to remove drivers.  After a new clean driver installation the user's problem was solved.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.