Jump to content
You must now use your email address to sign in [click for more info] ×

Photo 1.9.2 - Unsplash is still crashing the app


Recommended Posts

The pinned FAQ was recently updated to say: 

Quote

The latest ver 1.9.2 release builds on all platforms should have fixed this issue now, and adding content from the Unsplash stock panel is functional again.

I'm sorry to have to say "Oh no it isn't!"  And since I'm briefly in unseasonable panto mode, let's add: (Bugs?) "They're behind you!"  #ahem

Photo, Designer (both Mac App Store) and Publisher (Affinity Store) - each the latest v1.9.2 production releases - are still crashing when searching for a keyword in Unsplash stock.  This is on my Mac mini M1 running the current version of Big Sur.

Searches in Pexels and Pixabay are functioning as expected.

Repeatable steps in all three apps: 

  1. launch app
  2. create new blank document (any size) and save file <-- this step is optional
  3. display Stock panel
  4. select Unsplash
  5. type keyword in search field
  6. press [Return]  (and retreat to a safe distance)
  7. crash!

I wonder if there have been two problems all along, since I've not seen anyone else report this continued problem since 1.9.2 went through beta and was subsequently released to production?

I've attached the crash logs from each app and they all seem pretty much identical.  I'm afraid my ability to interpret them is limited, so I can't read much into them.

Let me know if there's any additional information that you'd like to see…

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

The earlier problem was not with searches, as far as I know, but with adding an Unsplash stock image to an Affinity project.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

41 minutes ago, GaryLearnTech said:

Repeatable steps in all three apps: 

  1. launch app
  2. create new blank document (any size) and save file <-- this step is optional
  3. display Stock panel
  4. select Unsplash
  5. type keyword in search field
  6. press [Return]  (and retreat to a safe distance)
  7. crash!

Must be an M1/Bug Sir thang.
IntElCapitan is Solid Rock now.

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

Thanks @walt.farrell - that supports some further testing I've just done.  I got to thinking that just maybe there was a conflict with something running in the background of my environment (though there's nothing especially exotic).

UPDATE

I rebooted into Safe Mode.

I logged in to a test account - while holding down the shift key to disable login items, etc.  I'm 99.9% certain that I had never used any of the Affinity suite in this account before, so the environment was as clean as you could possibly get.

I did the now familiar steps from above – and it worked fine.

I repeated this with my main account – and it crashed as usual.

So rather than a conflict with another app (I had been sceptical) it looks as if there's a dud setting in a Prefs file - or something along those lines - that's causing the Unsplash crash for me.  Possibly lurking from the original Unsplash crash (under v1.8?), and carried over when I migrated my account from the old Mac to the my current M1 Mac late last year, for me it was masking the problem everyone else had been recently experiencing.

My apologies to the fine team of developers for suggesting that they hadn't managed to fix the crash after all - and apologies also for the corny panto humour!  Though I was right that there is another problem.

Does anyone know where Unsplash-specific settings might be stored?  I don't really want to reset everything back to out-of-the-box defaults if at all possible.  (I should also say that this is not a big deal for me - it's more of an academic curiosity.)

Thanks also to @loukash, though I think  I've now ruled out the suggestion that it's M1 or Bug Sir related.

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

4 minutes ago, GaryLearnTech said:

Does anyone know where Unsplash-specific settings might be stored?  I don't really want to reset everything back to out-of-the-box defaults if at all possible.  (I should also say that this is not a big deal for me - it's more of an academic curiosity.)

You could certainly capture copies of the things we know are not related to the Stock panel (the brush files, assets, styles, etc.) from the "user" directory and restore them after a reset.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

11 minutes ago, GaryLearnTech said:

Does anyone know where Unsplash-specific settings might be stored?

MAS or Serif store version?

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

1 minute ago, loukash said:

MAS or Serif store version?

Mac App Store: Photo and Designer

Serif Store: Publisher

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

Actually, if:

1 hour ago, GaryLearnTech said:

Repeatable steps in all three apps

… then it's not in the Affinity domain because each app has its own sandbox.

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

1 minute ago, loukash said:

… then it's not in the Affinity domain because each app has its own sandbox.

And the same prefs file (or whatever) corrupted three times over - back when the first great Unsplash problem raised its head a year and a half to two years back.  I'm the kinda guy that would test if it really was crashing in each of the three apps…  😀

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

In similar cases, I'd launch Onyx and clear all system and user caches (with the exception of browser history, cookies and the like).
Just the other day, I couldn't connect to Teh Intervebz from the Catalina partition: likely DNS cache corruption, so Onyx to the rescue, problem fixed within minutes.

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

3 minutes ago, GaryLearnTech said:

he same prefs file (or whatever) corrupted three times over - back when the first great Unsplash problem raised its head a year and a half to two years back.  I'm the kinda guy that would test if it really was crashing in each of the three apps

Ah, okay, this scenario could then affect all three simultaneously.
So yeah, rename all three Affinity Library folders in Containers and App Support  respectively and launch with vanilla settings. If no crash, then the culprit is in there, after all.

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

That sort of cache problem was in my mind when I rebooted into Safe Mode - and held the shift key down when logging in.  It certainly used to be the case that those two process would clear and rebuild various levels of cache files.  That's why I'm slightly more suspicious of something like a 'damaged' prefs file.

Aha, the locations I'd vaguely recalled seeing in the dim and distant past - thanks!

It's late here now and I'm going to call it a day – but I might well try Onyx tomorrow if renaming those folders doesn't provide more info (or anything more specific comes to light).

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

2 minutes ago, GaryLearnTech said:

Safe Mode

Yeah, that also helps sometimes, but Onyx is usually more thorough.

4 minutes ago, GaryLearnTech said:

I'm going to call it a day

Same here, 7.6°E

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

UPDATE

I made several visits to this over the weekend, to see how far I could advance things.  The answer is: not very far.  😞   I'm currently stumped and am looking for more suggestions on further trouble-shooting!

I tried Onyx, as suggested, no joy.

In Big Sur, there seems to be some hidden folder name masking going on in /Users/gary/Library/Containers, so rather than simply rename folders (and then possibly be confused about restoring old names afterwards), I created a temporary folder on my Desktop and moved all Serif-related folders from both Containers and Application Support out of my Library folder.  The end result is the same - when any of the three apps run (I decided to test just with Photo), it's as if they're running for the first time - the appropriate new settings are created afresh.

And the same crash problem persisted - as described in my original post at the top of this thread.

I can add a little more detail to the original description.  If I mistype an Unsplash search term, such that no hits are returned - for example, waterrr instead of water - then it doesn't crash.  It's only when hits are found that it crashes.  However, it crashes before it displays any thumbnails.

On a related note, while successful Pexels or Pixabay searches populate the following folder with files and update the SQLite database with corresponding entries, the app crashes before this happens with Unsplash searches:

    /Users/gary/Library/Containers/com.seriflabs.affinityphoto/Data/Library/Caches/com.seriflabs.affinityphoto

Thinking about it, I'm pretty certain that I recall this no-hits-no-crash aspect from when the original Unsplash problem raised its head back in, I think, 2019.

One other minor thing I originally overlooked mentioning: when I tested this with the Test account (and it worked), that was an ordinary account - no admin rights.  My regular day-to-day account does have admin rights.

I'm going to try to uninstall Photo and reinstall it and will report back, but I doubt it will make any difference.  

 

 For example, the "Affinity Photo" folder from Containers is actually called "com.seriflabs.affinityphoto".  Rename it in the Finder in the normal manner (for example, to "Affinity Photo (disabled)") and it continues to display "Affinity Photo" - although it is renamed behind the scenes.

2021-04-12_17-26-34.png.ef3c15655e81ea2faa9d4ee42dfa953b.png

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

Just as an FYI, I'm still using AP beta 1.9.2.236 and Unsplash works fine for me on Mac Catalina. While my "regular"/working version is still Affinity Store 1.8.6, I've been upgrading the betas through the 1.9 series and now using the last one. Doesn't provide a solution for your issue, but at least a reference point.

--------------------

iMac (Retina 5K, 27-inch, 2020 i7 72GB) • AMD Radeon Pro 5700 XT 16 GB • macOS Ventura
MacBook Pro, 13", M1 2020 • 16 GB • macOS Ventura
iPad Air 2022

Link to comment
Share on other sites

Thanks @nwhit - I've just grabbed the Photo beta and will give it a try if reinstalling from the Mac App Store doesn't solve this.  (Got a few chores to go do just now, so this will be later on.)

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

Uninstalling and then reinstalling v1.9.2 from Mac App Store made no difference.

Updating to v1.9.3 - no difference.

v1.9.4 beta - no difference - Unsplash search still crashes.

Temporarily removing my admin rights (remove, reboot, etc) - no difference.

Quick recap…

  • Pexels and Pixabay Stock searches work fine.
  • Unsplash crashes Photo (and Designer and Publisher) instead of receiving and displaying thumbnails from a successful search.  (No crash if no search results returned.)
  • Reboot into Safe Mode and log in with [shift] held down to produce the 'cleanest' environment possible (eg no third party utilities, etc for possible conflicts) and it still crashes when search results should be returned.
  • Unsplash search works fine when used with a different login account.
  • This is all with fully reset settings in /Users/gary/Library/Containers/Affinity Photo/…

It's fortunate that I'm not depending on this functionality - but I don't like being beaten like this.  I'm still open to further trouble-shooting suggestions…

Edited by GaryLearnTech
Add additional comment about testing removing admin rights

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.1.1 release

Mac mini (M1, 2020), 16GB/2TB, macOS Ventura 13.4.1(c) • MacBook Pro (Intel), macOS Ventura • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

21 minutes ago, GaryLearnTech said:

Updating to v1.9.3 - no difference.

v1.9.4 beta - no difference - Unsplash search still crashes.

Rarely (outside of testing it, never) use the Stock panel but I don't see this crashing on Mac OS 10.14.6

Mac Pro (Late 2013) Mac OS 12.7.2 
Affinity Designer 2.3.1 | Affinity Photo 2.3.1 | Affinity Publisher 2.3.1 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

26 minutes ago, GaryLearnTech said:

I don't like being beaten like this

I feel your pain…
Sometimes there must be some quantum foam fluctations at work somewhere. :D

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

^ Where's Schrödinger when you need him…

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

Hey, Serif!
We already have the Cat tool.
Can we also have a Schrödinger tool, please?!

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

1 minute ago, loukash said:

Hey, Serif!
We already have the Cat tool.
Can we also have a Schrödinger tool, please?!

I shudder to think of what happens if we don't use it.

Mac Pro (Late 2013) Mac OS 12.7.2 
Affinity Designer 2.3.1 | Affinity Photo 2.3.1 | Affinity Publisher 2.3.1 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.