Jump to content
ConnectCreative

Update a linked, modified resource resizes it

Recommended Posts

I'm about to send a brochure to print and converting a large number of linked images from RGB to CMYK. I've converted the colour format/profile of my linked images in Photo, returned to Publisher and clicked 'update' on the modified linked image. Boom! ALL my updated images have now resized in Publisher, leaving me to manually resize each one again.

I could understand that happening if I'd of resized them in Photo, but all I've done is update the colour profile. Why have the changed dimensions in Publisher?

Share this post


Link to post
Share on other sites
14 minutes ago, ConnectCreative said:

Why have the changed dimensions in Publisher?

Bug? Regression? Oversight? Looks like this is fixed in the last beta of AD. Nothing helpful of course. Until this BUG is fixed (with priority) the only workaround I know of, is to move the image temporarily out of the picture frame, update it and move it back in. And of course turning off to update automatically modified external resources (Preferences >> General).


------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 8 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Share this post


Link to post
Share on other sites

Yes, this is a super bug. A real nighmare in a production. We have as a test produced large architectural presentation in Publisher, 6 large panels with tens of attachments in very thigh time competition schedule. All attachments needed to be updated frequently as on this project worked 6 to 8 people, non stop change, standard development of the content. Every update of each linked PDF caused that the frame of the inserted file was reset, reference file lost its scale and location.  What we could do? We finished the presentation in pain. Until this is fixed we unfortunatelly have to stay in production with Adobe InDesign, which just works smootly. This really needs to be fixed! I wrote it in more section of the forum with no response. Otherwise we really enjoyed work with Designer, node tool is great, many fantastic tools, etc. But this is so major BUG, that for now we cannot use the Affinity for our job.

Share this post


Link to post
Share on other sites
6 minutes ago, Boris.Volosin said:

Yes, this is a super bug. A real nighmare in a production. We have as a test produced large architectural presentation in Publisher, 6 large panels with tens of attachments in very thigh time competition schedule. All attachments needed to be updated frequently as on this project worked 6 to 8 people, non stop change, standard development of the content. Every update of each linked PDF caused that the frame of the inserted file was reset, reference file lost its scale and location.  What we could do? We finished the presentation in pain. Until this is fixed we unfortunatelly have to stay in production with Adobe InDesign, which just works smootly. This really needs to be fixed! I wrote it in more section of the forum with no response. Otherwise we really enjoyed work with Designer, node tool is great, many fantastic tools, etc. But this is so major BUG, that for now we cannot use the Affinity for our job.

I can imagine it becomes a real pain when you have lots of images constantly updating! Hope for a fix soon. 

Share this post


Link to post
Share on other sites

This is test from current Beta version with sample section drawing in PDF where moving the content with the crop tool within the frame works really in uncontrolable way. Content should not be changing while manipulating the frame. Furthermore it is changing proportions. I hope this is fixed soon.

Share this post


Link to post
Share on other sites
22 hours ago, Joachim_L said:

Bug? Regression? Oversight? Looks like this is fixed in the last beta of AD. Nothing helpful of course. Until this BUG is fixed (with priority) the only workaround I know of, is to move the image temporarily out of the picture frame, update it and move it back in. And of course turning off to update automatically modified external resources (Preferences >> General).

Your idea led me to a solution. I have tested your procedure and finally I did it little bit differently. Try it. You do not have to move picture from picture frame. I tried just to turn the picture frame off in Layer manager. Then reload or replace the file. Then Turn the picture frame back on. And it works. Much simpler then resizing all linked files, but still manual work if you have many references. Still it is a bug and a temproary workaround. Publisher should not work this way. Hope it helps.

Share this post


Link to post
Share on other sites
6 minutes ago, Boris.Volosin said:

Your idea led me to a solution. I have tested your procedure and finally I did it little bit differently. Try it. You do not have to move picture from picture frame. I tried just to turn the picture frame off in Layer manager. Then reload or replace the file. Then Turn the picture frame back on. And it works. Much simpler then resizing all linked files, but still manual work if you have many references. Still it is a bug and a temproary workaround. Publisher should not work this way. Hope it helps.

That's an interesting solution, thank you Boris!

Share this post


Link to post
Share on other sites

Hayyyaaaa, just ran into this problem as well while doing a fun project with AfPub.

I almost used Publisher for an international book project that is being designed with OPI data and will be updated with fine data later. Luckily I didn't start it in Publisher, that would have been an absolute horror with a 90% image content... and my colleagues would have killed me 😱

Such detail Serif should better keep in mind, deciding between serious Adobe competitor or just another gimp/paint.

Share this post


Link to post
Share on other sites

Hi, yes. It's even worse... much worse. 

I made a few picture frames with linked content.  After modifying the source image - only the color change and switch back to Publisher and update (automatic update is ON), all the picture frames lost (!) its content except for the one that has its properties set to "None". - see pics attached

Seems like the manual update (automatic update is OFF) keeps the content, but way out of its position. Sometimes even out of the page - pic 3.

And the visibility of frame is gone, and the other pic frames keeps crossed even with new content placed.

It doesn't matter if the source image is layered or flatten, CMYK or RGB, jpg or whatever... Just happens with any type source. And with no logic or pattern, seem like randomly moving content around the page :)

This is basic. Absolute essential basic of a layout program. Something went wrong.

Windows 10, Affinity 1.9.1

 

scrnshts0.jpg.bde41097d3d4f7a7a0a8a6e2ca58a6fb.jpg

scrnshts1.jpg.f5ea98122ba71b3d782f7930e921f293.jpg

scrnshts_2.jpg.f65ae3d01030c96bb21a15ca7d8e96af.jpg

Share this post


Link to post
Share on other sites

Please see my post regarding this issue below - 

This issue has been fixed in the latest beta version, which you can find linked in the above post.

I will be locking this thread from further replies, as these above reports are from previous (mostly retail) versions and don't belong in the beta section of the forums.

If you encounter any further issues when using this new beta version, please create a new post in the beta section of the forums, clearly denoting the version number you are using and the issue you are having. Many thanks!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.