Jump to content

Recommended Posts

Designer and Publisher 1.9.0.932

In the keyboard shortcuts page, I set Q as View>...>Studio Preset 1 and save it as an afshort file. It works as long as the programme is running but when I close the programme and restart it, the shortcut has gone.

I had the same in the beta version but assumed it was because it was beta.

Is it me?

Link to comment
Share on other sites

This shortcut is extremely flakey on AD 1.9.0 on my iMac. Sometimes it appears in the Designer > View keyboard shortcuts list & sometimes it does not appear at all, as if a keyboard shortcut for any Studio Preset is not supported.

I tried using "Q" as a shortcut for my (only) current preset. That worked once to reset the studio after I changed the panels around a bit, but never after that first time, producing a system beep each time I tried it thereafter.

Worse, when I went into keyboard shortcuts & tried to delete the "Q" preset while it was showing, AD hung & I jad to force quit it to recover.

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

Thanks R C-R, at least now I know I'm not the only one having problems.

I've used it successfully on several betas but only by loading the saved afshort file for each session. When I close and restart the programme, it's 'forgotten' the shortcut.

As you can see by the picture below, once loaded, the shortcut appears in the View menu, but again only for the current session.

One for Serif, it seems.

preset shortcut.png

Link to comment
Share on other sites

2 hours ago, Lagarto said:

... its shortcut key did not work, trying to remove or reassign shortcut key crashed the app, and no shortcuts for created views get listed subsequently.

My test shortcut key ("Q") worked once only, then produced a system beep if invoked again during the same session. Trying to remove it hung the app, requiring a force quit to recover. On the next launch, the shortcut was gone, as was my preset in the keyboard shortcuts View options -- IOW, there was no place to add it back. The preset still works if invoked from the View > Studio Presets menu but I no longer have a way to assign any shortcut to it.

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

It looks like this 1.9 has problems with keyboard shortcuts.

With Designer: Shortcut doesn't take effect when switching to Pixel Persona. I would have to reload my saved shortcuts ever time I start designer. The default Persona works fine. A similar problem also occurs with Photo. In Develop Persona, my custom shortcuts doesn’t work, no matter how many times I set or load it, it simply won't take effect.

Link to comment
Share on other sites

  • Moderators
On 2/7/2021 at 3:32 PM, Eddy-2 said:

In the keyboard shortcuts page, I set Q as View>...>Studio Preset 1 and save it as an afshort file. It works as long as the programme is running but when I close the programme and restart it, the shortcut has gone.

I had the same in the beta version but assumed it was because it was beta.

Thanks for letting us know - I believe this is now fixed in 1.9.1 beta. I've tried it in both 1.9.0 and 1.9.1 and I was unable to reproduce it in 1.9.1.Feel free to give the beta a try! Also please bear in mind that if you do spot an issue in the beta, do please tell as as we may not already know (such was the case here).

On 2/7/2021 at 7:19 PM, R C-R said:

I tried using "Q" as a shortcut for my (only) current preset. That worked once to reset the studio after I changed the panels around a bit, but never after that first time, producing a system beep each time I tried it thereafter.

Worse, when I went into keyboard shortcuts & tried to delete the "Q" preset while it was showing, AD hung & I jad to force quit it to recover.

This is a separate macOS only issue that we're aware of and is with development - Unfortunately the two are quite different when it comes to shortcuts.
 

Link to comment
Share on other sites

  • 2 weeks later...

Hello, i am using Designer, Photo & Publisher version 1.9.0.932 on a Windows 10 Computer.

I customize my shortcuts and save them.
After the restart of any application my shortcuts has gone and it is necessary to load them again.

What can I do to load my own shortcuts automatically?

Link to comment
Share on other sites

17 minutes ago, Ronny D. said:

Hello, i am using Designer, Photo & Publisher version 1.9.0.932 on a Windows 10 Computer.

I customize my shortcuts and save them.
After the restart of any application my shortcuts has gone and it is necessary to load them again.

What can I do to load my own shortcuts automatically?

Welcome to the Serif Affinity forums, Ronny.

Note: You posted in a thread in the "Designer Bugs found on MacOS" forum. As you're using Windows, it would have been better to post in the general desktop questions forum, or in a topic in the Windows bug forum :)

Are you closing each of your applications after you customize the shortcuts? They aren't really saved until the application is closed successfully.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0.4  and 2.1.0.1709 beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.4  and 2.1.0.1709 beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.4  and 2.1.0.1709 beta
iPad Pro M1, 12.9", iPadOS 16.3.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.7 and 2.0.4 and 2.1.0.1713 beta/ Affinity Designer 1.10.7 and 2.0.4 and 2.1.0.1713 beta/ Affinity Publisher 2.0.4 and 2.1.0.1709 beta

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.