Jump to content

Painting: Brush Opacity/Accumulation buggy in beta


Recommended Posts

Hello there,

Photo Beta (1.9.0.815) and think I found something buggy. 

Simply put: Opacity on pen pressure seems to be nonexistent or malfunctioning in the current beta version, it kind of behaves like flow instead.

The stable version (right now I have 1.8.5.703) installed does it as I want, gives me a smooth, even transition between pressing lightly and pressing harder on the stylus. While the beta looks a bit as if it would only use the flow and not the accumulation of the brush. I exported the brush from my older version to the beta and so I am sure it is 100% the identical brush in both.

Settings are identical, Tablet on low precision, nothing changed in the Wacom drivers. Using the same settings. Hardware acceleration in beta on or off doesn't make a difference. Changing tablet modes doesn't make a difference either.


*Also, the UI is randomly unresponsive/frozen and can occasionally catch itself by alt+tab in and out of the program, but not always. I would guess you guys have already heard of that.


image.png.c4fee8e73b6d62056a5184961df37bc0.pngimage.png.83143482144b3bd442b019a0e51be2f8.pngimage.png.28a6fa71d3c05a3f3fa6da3ef9203065.png

Link to post
Share on other sites
  • 2 weeks later...
  • 2 months later...

Hi @Gabe, do you guys still have this bug on your radar? Haven't seen a fix in the newer betas. That would be great, as a lot of painters and illustrators are looking into AP from what I can see on social media. Would be nice to see it working well in the final 1.9 release :)

Link to post
Share on other sites
  • 2 weeks later...
On 1/21/2021 at 11:23 AM, TheFlow said:

Hi @Gabe, do you guys still have this bug on your radar? Haven't seen a fix in the newer betas. That would be great, as a lot of painters and illustrators are looking into AP from what I can see on social media. Would be nice to see it working well in the final 1.9 release :)

I'm just seeing this post as I have the same issue and posted about it today. As a painter using this as a replacement for Photoshop this is such a huge thing for me. Glad to know they're working on it. Painting on pause for now :(

Link to post
Share on other sites

I updated today and I also have this problem. I use Photo for painting and I can't use it being like this.

I'm rolling it back to the previous version for now, but I hope it gets fixed soon, so I can use the new version.

Link to post
Share on other sites

Yeah it is unfortunate. I still think they should get up and running with a small team of concept artists and illustrators while they're at it and talk general improvements. Brush engine is a masterpiece. The programs also get faster, slowly but surely. It's a strange thing, they almost can take PS out for painting, but just not yet.

@ the whole Serif team: guys, take a close look to www.artstation.com, there are literally thousands if not millions of people using PS for painting only.

I think the opacity bug will be fixed in the 2.0 betas.

Link to post
Share on other sites

 I could roll it back to the previous version by uninstalling and installing the previous version again, but I had already opened the file of the illustration I'm working on right now with the new version, and now I can't open the file with the previous version. I really need to keep working on the painting and finish it. Please fix this bug ASAP! 😰 @Gabe

I'll also keep an eye on betas.

Update: Fortunately, I could recover a previous version of the file via Google Drive's version history, and now I can safely open the file. Thank goodness!

I had the workaround this time in my case, but I assume there could be other users who have problems like I did and don't have the means to get back the previous versions of their files, so I do recommend fixing this as soon as possible.

Edited by Numan
Link to post
Share on other sites

Yeah I ended up going back to 1.8 with a different workaround:

First I opened the files I wanted to work with in 1.9 and then saved as .psd. Once I reverted back to 1.8 I opened the .psd files in Affinity and then saved as .afphoto again. This was the only way I could continue working on my paintings with the original brush behavior.

Link to post
Share on other sites
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.