Jump to content
GarryP

Should I be able to clone what’s in a pixel selection with the Move Tool?

Recommended Posts

Windows 10 Home 1909, Photo 1.7.3.481 and 1.8.0.526 beta.

When I make a selection with the Rectangular Marquee Tool, then change to the Move Tool, I can move the selected pixels but the CTRL (clone) modifier – shown in the status bar – doesn’t seem to do anything. The SHIFT modifier does what I expect but the CTRL modifier doesn’t (see attached GIF).

Is this expected behaviour, or am I doing something wrong, or is it a bug, or something else?

cannot-clone-pixel-selection.gif

Share this post


Link to post
Share on other sites

I see the same behavior on my system.


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.7.3.481 and 1.8.0.532 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.532 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.535 Beta

Share this post


Link to post
Share on other sites

Well it's certainly not cloning it, it's cutting it, with it saying clone I would have expected a duplicate of the selected area.

The only way to do that is to copy/paste as in the example below but this is what I would have expected to see holding cmd down.
381241773_ScreenShot2020-01-14at13_12_36.png.1b6b0d0eb43f4cedac677c6bbce5ae06.png


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

I was hoping that it would be a quick way to do what copy/paste does (although Duplicate Selection – CTRL+J – works nicely, even if it’s an extra step on top of what would be a quick clone). When doing this remember to Deselect after the duplication, otherwise very strange things can happen.

So do we think that this is missing functionality, or is the status bar message wrong?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.