Jump to content

Recommended Posts

Bonjour,

Je viens de tester le correcteur orthographique français de Publisher, il est complètement à revoir.

(exemple un mot précédé d'une lettre suivie d'un apostrophe, le correcteur propose de supprimer cette dernière !!!)

Bon courage,

Bien cordialement

Alain CAILLAULT

 

Capture.JPG

Share this post


Link to post
Share on other sites

It seems to be an issue with the typographic apostrophe vs the straight apostrophe ' as the spellcheck accepts those words with the straight apostrophe but not with the typographic apostrophe.

Via Google Translate: Cela semble être un problème avec l’apostrophe typographique    vs l’apostrophe simple  ', car le correcteur orthographique accepte ces mots avec l’apostrophe simple mais pas avec l’apostrophe typographique.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.1.979 and 1.9.1.979 Beta   / Affinity Designer 1.9.1.979 and 1.9.1.971 Beta  / Affinity Publisher 1.9.1.979 and 1.9.1.967 Beta

Share this post


Link to post
Share on other sites

After further investigation, it seems that (at least) the French corrector accepts U+0027 ' APOSTROPHE  while not recognizing the  U+2019 RIGHT SINGLE QUOTATION MARK .

The second is the apostrophe produced by the French keyboard layout, and is the preferred character to use for apostrophe according to the Unicode standard (see Wikipedia).

So there should be a way to define in Puiblisher options the apostrophe char of the document, and maybe also a way to auto-correct to/from typographic apostrophe

Share this post


Link to post
Share on other sites

As I'm working in English and French as well, I know the French typographic rules are sometime more complexe than English's (and Orthographe and grammaire!!!). I hope a day Antidote will work with APublisher.

 

comme je travaille en anglais et francais aussi bien je connais que les regles typographies francaise sont plus complexes que l'anglais. J'espere un jour Antidote travaillera avec APublisher.

Share this post


Link to post
Share on other sites

Merci de régler ce problème rapidement, car désormais j'utilise Publisher en production et le correcteur orthographique n'est pas utilisable en état. Bien cordialement.

Un utilisateur très satisfait par ailleurs. Alain Caillault

Share this post


Link to post
Share on other sites

This is odd indeed. I work with text in French, but it is functioning as expected for me. See for example this screenshot to compare with what paco52 posted. Notice the apostrophe I used, and that I purposefully misspelled a word to show that spell check is functioning.224614708_ScreenShot2019-06-25at10_06_46AM.thumb.png.dbd1a1af35826897c9623d30eb724f95.png

 

The next step is to find out what is different so that it works for me and not for you. I'm on macOS 10.14.5. How about you who are experiencing the problem?

Also, this probably should be moved to the bug forum.

On 6/18/2019 at 4:37 AM, allen57301 said:

I hope a day Antidote will work with APublisher.

Yes!! I am looking forward to that too. Some time ago a representative of Druide posted here on the forum to ask whom to contact for integrating Antidote with Affinity, so I suppose now it is between Druide and Serif.

 

Share this post


Link to post
Share on other sites
On 6/25/2019 at 5:15 PM, garrettm30 said:

The next step is to find out what is different so that it works for me and not for you. I'm on macOS 10.14.5. How about you who are experiencing the problem?

I'm on 10.14.6 and I'm having the same issue. The only workaround, as said elsewhere on the forums, is to uncheck "Support language dependent single typographic quotes".

The weirder part, as you can see in the attached gif, is that despite the unchecked option french quotes seems still perfectly managed (I mean THANKS AFFINITY for automatic spaces).

___

Je suis sur 10.14.6 et j'ai le même problème. La seule solution, comme dit autre part dans le forum, est de décocher "Guillemets typographiques en fonction de la langue".

Le plus bizarre, comme vous pouvez le voir dans le gif ci-dessous, c'est que bien que cette option soit décochée les guillemets français restent parfaitement gérés (MERCI AFFINITY pour les espaces automatiques).

APfrenchbug.gif

Share this post


Link to post
Share on other sites
On 8/30/2019 at 8:55 AM, nicolasfolliot said:

The only workaround, as said elsewhere on the forums, is to uncheck "Support language dependent single typographic quotes".

La seule solution, comme dit autre part dans le forum, est de décocher "Guillemets typographiques en fonction de la langue".

Serif, what nicolasfolliot has said (especially in that he conveniently wrote in both languages) has highlighted the fact that this option is not adequately translated in French, and I believe it has led to the confusion of what he says here:

On 8/30/2019 at 8:55 AM, nicolasfolliot said:

The weirder part, as you can see in the attached gif, is that despite the unchecked option french quotes seems still perfectly managed (I mean THANKS AFFINITY for automatic spaces).

To reverse translate the French setting, it is simply "Typographic quotes dependent on language." Notice that it is missing the key element single typographic quotes, and that easily explains why nicolasfolliot was surprised that the French equivalent to double typographic quotes continues to work even when the option is unchecked.

@nicolasfolliot Je suis désolé pour la confusion, mais en fait, comme j'ai expliqué ci-dessus, l'option « Guillemts typographiques en fonction de la langue » n'est pas suffisamment traduite. Il s'agit de citation double. Par example :

« Je vous dis à tous et à toutes “bonnes vacances !” et j’espère vous retrouver bien reposés à la rentrée. »

En anglais, on utilise les guillemets anglais doubles (double typographical quotes) pour la citation, et les guillemets anglais simples (single typographical quotes) pour la citation double.

Si l'on coche cette option, voici ce qui en résulte en tapent cette phrase :

« Je vous dis à tous et à toutes ‹ bonnes vacances ! › et j ‹ espère vous retrouver bien reposés à la rentrée. »

Si on le décoche, en voici le résultat :

« Je vous dis a tous et à toutes ‘bonnes vacances ! ‘ Et j’espère vous retrouver bien reposés à la rentrée. »

Franchement, je trouve cette option peu utile en français, mais l'autre option n'est pas parfaite non plus.

Share this post


Link to post
Share on other sites
18 hours ago, garrettm30 said:

Je suis désolé pour la confusion, mais en fait, comme j'ai expliqué ci-dessus, l'option « Guillemts typographiques en fonction de la langue » n'est pas suffisamment traduite. Il s'agit de citation double. Par example :

« Je vous dis à tous et à toutes “bonnes vacances !” et j’espère vous retrouver bien reposés à la rentrée. »

:63_astonished: OK je comprends beaucoup mieux… Je n'aurais pas imaginé qu'ils iraient aussi loin dans le traitement typo, ça part d'une très bonne intention et je serais ravi de cocher à nouveau cette option s'ils arrivent à le faire fonctionner en français (même si, on est d'accord, ce n'est pas indispensable). Merci pour l'explication !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.