Jump to content
Gear maker

Appearance Panel delete option does not work

Recommended Posts

In the Appearance Panel a right click will pop up a menu with Duplicate and Delete options.  The Delete option does not do anything for me.  The Remove Layer icon does work to delete the Appearance Panel layer/entry/sublayer (whatever it would be called).


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

I had added two layers but couldn't delete any of them from the pop up menu.  But could from the Remove Layer icon.  So I don't think that's the issue.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

You are unto something because I've just played with the Appearance Panel a bit longer and now I can't delete the Fill layer I added.

I was able to eventually delete it by clicking the trash icon in the panel and not with the pop-up menu.

Share this post


Link to post
Share on other sites

Hi Gear maker,

Is it only the Fill layers that you can't remove? I've not found any issues with the stroke (except for a crash when deleting all strokes and trying to add a new one). However I just cannot get a Fill Layer to be removed using the right click option. I'll get that passed on to development.

Share this post


Link to post
Share on other sites

I'll have to check out the stroke side.  So far I haven't used that part of the Appearance Panel, yet.  Thanks Sean.  Mike


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites
On 3/11/2019 at 8:53 AM, Sean P said:

Is it only the Fill layers that you can't remove?

For me, yes, it is just Fill layers that can't be removed via the right-click popup, but it does work using the Remove Layer (trashcan) button.

On 3/11/2019 at 12:17 PM, Andrew Tang said:

This should all be fixed in the next beta! No worries. :)

Regarding that, there is a very minor issue that I hope also will be fixed: when an appearance layer is selected (highlighted), underline indicators appear, but after that when no layer is selected, the underline(s) of the last selected layer remain visible:
Underlines.jpg.a3002da396418e37dce208a841568fb2.jpg

Anything that causes the panel to be redrawn (like dragging it into or out of a panel group) removes the underlines, so it is just a cosmetic update thing, but it is just bothersome enough to trigger a minor OCD spasm in my addled old brain. ;-)


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
12 hours ago, R C-R said:

For me, yes, it is just Fill layers that can't be removed via the right-click popup, but it does work using the Remove Layer (trashcan) button.

Regarding that, there is a very minor issue that I hope also will be fixed: when an appearance layer is selected (highlighted), underline indicators appear, but after that when no layer is selected, the underline(s) of the last selected layer remain visible:
Underlines.jpg.a3002da396418e37dce208a841568fb2.jpg

Anything that causes the panel to be redrawn (like dragging it into or out of a panel group) removes the underlines, so it is just a cosmetic update thing, but it is just bothersome enough to trigger a minor OCD spasm in my addled old brain. ;-)

Thanks for that - it is definitely the same issue then. 

With regards to the underline, how are you getting it to say highlighted? Could you record a quick video showing it please? I have a feeling it could well be OS specific, as I'm on Mojave.

Share this post


Link to post
Share on other sites

Sean I'm seeing the same thing about the underline as R C-R.  I'm clicking in the blank area of the Appearance Panel below any layers to deselect all layers.  I'm on Sierra.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites
3 hours ago, Gear maker said:

Sean I'm seeing the same thing about the underline as R C-R.  I'm clicking in the blank area of the Appearance Panel below any layers to deselect all layers.  I'm on Sierra.

That is the same thing I am doing on High Sierra. This only happens after selecting a layer & then deselecting it by clicking on an empty spot below the layers. 


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
16 hours ago, Gear maker said:

Sean I'm seeing the same thing about the underline as R C-R.  I'm clicking in the blank area of the Appearance Panel below any layers to deselect all layers.  I'm on Sierra.

 

12 hours ago, R C-R said:

That is the same thing I am doing on High Sierra. This only happens after selecting a layer & then deselecting it by clicking on an empty spot below the layers. 

Thanks! Seems I had my panel a bit smaller so didn't have a gap! I'll get this passed on to development.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.