Jump to content
RaSu

en dash at the end of row, when using nonbreaking space to avoid one letter at the end of row.

Recommended Posts

5 hours ago, RaSu said:

en dash at the end of row, when using nonbreaking space to avoid one letter at the end of row.

I've reported that already so hopefully this will be fixed in the next beta. :)

Share this post


Link to post
Share on other sites

Not sure what one has to do with the other (a non-breaking space prevents two words from being placed on different lines, but should have nothing to do with hyphenation within a word), but you might want to verify that the "Minimum prefix" setting under the "Hyphenation" setting of the Paragraph studio panel is set to at least 2.

Share this post


Link to post
Share on other sites
On 2/18/2019 at 3:00 PM, Seneca said:

I've reported that already so hopefully this will be fixed in the next beta. :)

Unluckily the bug still remains - even in production/live version of Affinity Publisher :-(

Share this post


Link to post
Share on other sites

I've not been able to reproduce this. For me it won't break at all after a non-breaking space. Can you attach a small document which shows the problem?

Share this post


Link to post
Share on other sites
On 2/18/2019 at 3:06 PM, fde101 said:

Not sure what one has to do with the other (a non-breaking space prevents two words from being placed on different lines, but should have nothing to do with hyphenation within a word), but you might want to verify that the "Minimum prefix" setting under the "Hyphenation" setting of the Paragraph studio panel is set to at least 2.

I don’t have the Czech dictionary installed, but using the Italian one will also allow to reproduce the behaviour in the example document uploaded by @jirka. When you set the minimum prefix to 3 for the paragraph, the issue disappears. Strange.

Not sure, but maybe this will help squishing that bug. :/

Share this post


Link to post
Share on other sites
1 hour ago, A_B_C said:

I don’t have the Czech dictionary installed, but using the Italian one will also allow to reproduce the behaviour in the example document uploaded by @jirka. When you set the minimum prefix to 3 for the paragraph, the issue disappears. Strange.

Not sure, but maybe this will help squishing that bug. :/

 

Prefix.mov

Yes! It works the same even with Czech dictionary. Thank you Sir!

Share this post


Link to post
Share on other sites
1 hour ago, A_B_C said:

I don’t have the Czech dictionary installed, but using the Italian one will also allow to reproduce the behaviour in the example document uploaded by @jirka. When you set the minimum prefix to 3 for the paragraph, the issue disappears. Strange.

Not sure, but maybe this will help squishing that bug. :/

 

Prefix.mov

... but - the side-effect is not usable - hyphenation of many czech words commonly needs to be splitted after first two characters and with setting the minimum prefix to 3 it does not works.

Share this post


Link to post
Share on other sites

Oh, of course, I didn’t mean to suggest this as a workaround, but rather as a piece of additional evidence for the developers such that they might get down to the root of the problem more easily … if that does make sense at all … :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.