Jump to content
jmwellborn

Text wrapping not working

Recommended Posts

I just began a new file.  Created a text frame.  Checked the Text Frame Studio.  Ignore Text Wrap is checked.  Even though I left it unchecked when I saved the .afpub fiddling file.   So the default position -- at least in the MAC version of v. 140, appears to be the checked position.  Meaning that each time one creates a new file and plans to use an image, one has to go in and uncheck this box.  Never too old to learn new things.   


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.8.3, Affinity Photo 1.8.3, Affinity Designer 1.8.3 

Magic mouse.9_9

Share this post


Link to post
Share on other sites

Or here is an idea!  How about a little brain in the software which understands that when one clicks on the Show Text Wrap Settings (in the toolbar) that one wants to have Ignore Text Wraps unchecked in the Text Frame panel.   That way, one could then just adjust the wrap settings for the chosen wraps selection and they would show up in the document.   Voilà!!!


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.8.3, Affinity Photo 1.8.3, Affinity Designer 1.8.3 

Magic mouse.9_9

Share this post


Link to post
Share on other sites
2 minutes ago, jmwellborn said:

So the default position -- at least in the MAC version of v. 140, appears to be the checked position.

It would be useful to have someone else confirm that on a Mac :)

It's not that I doubt you, but

  1. It's an unlikely default for Serif to have chosen; and
  2. It's possible that you had a text frame with that option active when you last told Publisher to set its defaults (Edit > Defaults > Save).

(In fact, if you're willing to experiment, you might try Edit > Defaults > Revert (or even, though I have less idea what it should do, Edit > Defaults > Factory Reset), and then see if that's still the default for your text frames.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.734 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.734 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.742 Beta.

Share this post


Link to post
Share on other sites

Great idea in theory, but it didn't work.  Edit>Defaults>Revert was entered.  The file was saved.  The file was reopened.  There is the click mark on Ignore Text Wraps.  Just the way it is when I open a new file.   Hopefully the Affinities will be able to figure this one out.   Perhaps my version of 140 is just sick of Peter Piper and the pickled peppers.


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.8.3, Affinity Photo 1.8.3, Affinity Designer 1.8.3 

Magic mouse.9_9

Share this post


Link to post
Share on other sites
42 minutes ago, jmwellborn said:

So the default position -- at least in the MAC version of v. 140, appears to be the checked position.

Correct.

 

44 minutes ago, jmwellborn said:

Meaning that each time one creates a new file and plans to use an image, one has to go in and uncheck this box.

I will put text over a colour, an image etc quite frequently so for  me I would say it is about 50/50.  The last used setting was saved with a file but no amount of fiddling would get the unchecked be the default for a new file.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.8.4 | Affinity Photo 1.8.4 | Affinity Publisher 1.8.4 | Affinity Designer Beta 1.9.0.2 | Affinity Photo Beta 1.9.0.199 | Affinity Publisher Beta 1.9.0.742

Share this post


Link to post
Share on other sites
3 minutes ago, Old Bruce said:

Correct.

 

I will put text over a colour, an image etc quite frequently so for  me I would say it is about 50/50.  The last used setting was saved with a file but no amount of fiddling would get the unchecked be the default for a new file.

Thank you so much!   I was beginning to think that I had lost my mind.   All brain cells present and accounted for after all.  


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.8.3, Affinity Photo 1.8.3, Affinity Designer 1.8.3 

Magic mouse.9_9

Share this post


Link to post
Share on other sites
4 hours ago, jmwellborn said:

Great idea in theory, but it didn't work.  Edit>Defaults>Revert was entered.  The file was saved.  The file was reopened.  There is the click mark on Ignore Text Wraps.  Just the way it is when I open a new file.   Hopefully the Affinities will be able to figure this one out.   Perhaps my version of 140 is just sick of Peter Piper and the pickled peppers.

You would have needed to Revert the settings and then create a new file to test my theory. But it sounds like Old Bruce has confirmed it. That's a terrible default, and perhaps a bug in its own right.

Edit: But I do like your idea of Edit Text Wraps overriding it automatically.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.734 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.734 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.742 Beta.

Share this post


Link to post
Share on other sites
On 10/9/2018 at 6:24 PM, jmwellborn said:

Or here is an idea!  How about a little brain in the software which understands that when one clicks on the Show Text Wrap Settings (in the toolbar) that one wants to have Ignore Text Wraps unchecked in the Text Frame panel.   That way, one could then just adjust the wrap settings for the chosen wraps selection and they would show up in the document.   Voilà!!!

There's a bug with the default Ignore Text Wraps setting. It was never supposed to be on by default. We'll fix in a future beta.

Changing the setting automatically would not be right, because the object whose text wrap settings you are editing is different to the object you want to wrap around it. It shouldn't be necessary when the Ignore setting has the right default.

Share this post


Link to post
Share on other sites
1 hour ago, Dave Harris said:

There's a bug with the default Ignore Text Wraps setting. It was never supposed to be on by default. We'll fix in a future beta.

I just checked with the .145 update, and it seems that after making an new document the default is off. or am I just deluding myself. Is .145 the 'future beta'? I see it is listed as fixed in Windows but I am on Mac. Sorry if this is incoherent, I haven't had my morning coffee yet.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.8.4 | Affinity Photo 1.8.4 | Affinity Publisher 1.8.4 | Affinity Designer Beta 1.9.0.2 | Affinity Photo Beta 1.9.0.199 | Affinity Publisher Beta 1.9.0.742

Share this post


Link to post
Share on other sites
25 minutes ago, Old Bruce said:

I just checked with the .145 update, and it seems that after making an new document the default is off. or am I just deluding myself. Is .145 the 'future beta'? I see it is listed as fixed in Windows but I am on Mac. Sorry if this is incoherent, I haven't had my morning coffee yet.

Sorry, no: the fix didn't make 145. It will be in .146 and later.

Share this post


Link to post
Share on other sites
4 hours ago, Dave Harris said:

There's a bug with the default Ignore Text Wraps setting. It was never supposed to be on by default. We'll fix in a future beta.

Changing the setting automatically would not be right, because the object whose text wrap settings you are editing is different to the object you want to wrap around it. It shouldn't be necessary when the Ignore setting has the right default.

Thank you!!!   I am so glad that this will be fixed in a future beta.   Meanwhile, "patience is a virtue."  As usual, you Affinities are splendid!   Gentlemen and ladies par excellance! 


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.8.3, Affinity Photo 1.8.3, Affinity Designer 1.8.3 

Magic mouse.9_9

Share this post


Link to post
Share on other sites
3 hours ago, Dave Harris said:

Sorry, no: the fix didn't make 145. It will be in .146 and later.

I noticed once I was more awake. Thanks anyway for the other stuff.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.8.4 | Affinity Photo 1.8.4 | Affinity Publisher 1.8.4 | Affinity Designer Beta 1.9.0.2 | Affinity Photo Beta 1.9.0.199 | Affinity Publisher Beta 1.9.0.742

Share this post


Link to post
Share on other sites

Ran into the same problem today, text wrap setting just didn‘t work.

Text wrap of placed AfPhoto file set to ‘Jump’; “Ignore Text Wrap’ in text frame settings off.

The other placed AfPhoto file with same text wrap settings on the same page wrapped jus fine.

The solution I found is to just click Text > Text Wrap > Edit Wrap Outline in the menu and text wrapping jumped to the desired shape.

Can't explain what happened, but I‘m glad it did.

That's beta 1.8.4.561 meanwhile.

Share this post


Link to post
Share on other sites

Hi,

I too was struggling with the same issue, being relatively new to Affinity Publisher. 

The below steps solved the issue for me: 

  1. Select the image within the text frame.
  2. Uncheck "Inline in Text" from the Layer Menu.

See screenshot.

 

Uncheck_Inline_in_text_make_text_wrap_work.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.