Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

1.6.1.93 - Win10 Mask Layer and Brush performance


Recommended Posts

Hello.

First of all let me just clarify that I excellent performance doing anything else, this bad performance is specifally just this for some reason.

But when I create a "Mask Layer" performance just grinds to a halt. it is 100% un-usable.

just alt + lmb to display it takes 20 sec and I can even see how it slowly changes one "tile" at a time into the white mask it applied.

pressing ctrl+i to invert it takes another 30 sec 

and then trying to paint in some information with a brush, simply forget about it. The preview brush under the marker will not even display, and if i do a brush stroke it takes upwards to 1-2min before it displays and then ofcourse it is not smoth at all.

I am not sure what is causing this, I have opend a 36mp .TIF file in ProPhoto RGB, and again all edits such as a regular levels layer or curve layer works perfectly fin, full performance super smooth.

And creating a empty pixel layer and painting with a brush there works perfectly fine. It is just Mask Layers that will cause this slowdown.

I've searched the forums finding nothing to this specific problem, changed performance settings, un-installed and re-installed... but the issue reamins

This is currently making the software 100% un-useable for me.

 

Link to comment
Share on other sites

For adjustment layers using their build in masking capability works fine, but for pixel layers the absurd slowdown can still happen. I just had 3 brusk strokes in a Mask Layer of a pixel layer take 3 minutes before i decided to close the image and then affinity crashed.

 

The odd part was that it was working just fine until i alt+lmb to display the mask and view it...that seems to be what starts the problem...then affinity just grinds to a half....the brush strokes still happen but at a glacial speed.

Link to comment
Share on other sites

On my computer it's not that bad but I can confirm that drawing on masks is generally very slow. I edit a lot of 32 bit RGB files and masking is definitely no fun at these waiting times before a brush stroke is finally applied. This is still the case with the latest stable release.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

This post starts mentionning version 1.6.1.93, and latest beta is currently 1.6.3.96....

The problem exists in official release 1.6.2.97, I wouldn't say that it makes it unusable on my system (quite low specs) but there is quite some lag.

But it seems to be fixed in the latest beta 1.6.3.96, speedy and no lag at all.

-- Window 11 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad Pro 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 9th gen 256 gb - Apple Pencil 1

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.