Jump to content

MagnusL3D

Members
  • Content count

    15
  • Joined

  • Last visited

About MagnusL3D

  • Rank
    Newbie

Recent Profile Visitors

252 profile views
  1. This is one of those to me self fulfilling things where dev's go "there is no market" well there isn't..because you and other dev's like you keeping me in dual boot limbo, skewing your numbers by purchasing a windows license to make your "look how many windows users we have" more valid. shame on me.
  2. Tried this again in 16.3.100, and now it is _a lot_ better ..I would say 90% there, when you press alt+lmb to display a mask in B/W it still can drop performance down a bit but at least it is not un-useable anymore.
  3. Wops yeah I did, but as you say, same issue with regular brush.
  4. Here is a video, unfortunatly Nvidia didnt capture the actual brush circle so you have to imagen that around the mouse courser. Desktop 2018.02.13 - 22.15.08.02.mp4
  5. Tested it today on version 1.6.3.99, still completely broken and un-useable. How can such a core feature remain overlooked for this long ? this completely renders the hole software 100% un-usable for me.
  6. downloaded 1.6.1.93 and this still happens, so I updated the topic to reflect that it still happens in this version.
  7. For adjustment layers using their build in masking capability works fine, but for pixel layers the absurd slowdown can still happen. I just had 3 brusk strokes in a Mask Layer of a pixel layer take 3 minutes before i decided to close the image and then affinity crashed. The odd part was that it was working just fine until i alt+lmb to display the mask and view it...that seems to be what starts the problem...then affinity just grinds to a half....the brush strokes still happen but at a glacial speed.
  8. Ah I think I realize the problem, there is probably no support to have a "Mask Layer" inside a adjustment layer such as a curve layer. I wanted to do "double" masking that way so to speak.
  9. Hello. First of all let me just clarify that I excellent performance doing anything else, this bad performance is specifally just this for some reason. But when I create a "Mask Layer" performance just grinds to a halt. it is 100% un-usable. just alt + lmb to display it takes 20 sec and I can even see how it slowly changes one "tile" at a time into the white mask it applied. pressing ctrl+i to invert it takes another 30 sec and then trying to paint in some information with a brush, simply forget about it. The preview brush under the marker will not even display, and if i do a brush stroke it takes upwards to 1-2min before it displays and then ofcourse it is not smoth at all. I am not sure what is causing this, I have opend a 36mp .TIF file in ProPhoto RGB, and again all edits such as a regular levels layer or curve layer works perfectly fin, full performance super smooth. And creating a empty pixel layer and painting with a brush there works perfectly fine. It is just Mask Layers that will cause this slowdown. I've searched the forums finding nothing to this specific problem, changed performance settings, un-installed and re-installed... but the issue reamins This is currently making the software 100% un-useable for me.
  10. Ah yeah so it becomes like the default gradient in photoshop :) I can live with that...but yeah something atleast so people have control over the behaviour they want because now it is so frustrating.
  11. Yeah I might have phrased that bad, but I personally in 90%+ cases want it to be black and white, so I would love to be able to set it for myself so that is how it behaves..right now I have to change it every time since I havent figured out a way to make it default for me to the settings I prefer. It seriously takes me like 20-30 sec to put out a gradient like I want..that is just ..unacceptable...
  12. Thanks MBd ! is there realy no "live" gradient as the Gradient tool on the left tool bar ? or am I just blind...?
  13. Well not sure if this is Feature Request or Feedback but i'll put it here. I went a head and bought Affinity Photo and this is a list of things that annoys me after a couple of days usage, on windows btw. Curves: - Can not undo curve edits, except when in picker mode then you undo way to much with a single ctrl-z ..please find a middle ground for both, this is just silly. - Slightest miss click creates a new curve point, needs to be more forgiving (same thing goees for when in "picker" mode, it's impossible to work with). - Only the center grid is overlayed on top of the histogram, makes it hard to do precis edits - No numbers for added "keys" so I can not make exact edits specially important in LAB mode - No shortcuts to switch between L/A/B in LAB mode, having to use the drop down slows down workflow - 1 more subdivision of grid drawing - Please don't be like photoshop with a fixed size of the Curve interface, I relay want to scale it up. - When using the "Picker" option you can not just click on the image to set out "safe" areas, you have to click and drag to change the value, which breaks LAB color workflow rather hard. - When using "Picker" mode there is no preview in the curve editor where my point new points might be added. Blend Options: - Histogram display would be nice - Preview of mask generated by curve would be nice - Would be nice to have a "picker mode" like thing for this, not sure how it would work but feels like it could be awesome Gradient Tool: - Probably user error but why does it always started in white to %50 gray, I want it to be white to black always. Presets: - Adding presets is easy and nice, but I can not access them from my tool, like my curve presets..I have to have the "adjustment" window up for this...please give me direct access to preset within the current tool.
  14. I tried the beta a little and as a landscape photographer the first thing I was looking at was how I could mimic photoshop "luminosty mask" workflow. And as far as I understood it was that you do not need to do it, you have a seperate curve controller for that in your adjustments but I must say I lake some sort of preview for that, perhaps there is but then it needs to be made more visible. But on a whole I would love if there was some real though and awesome experience working with luminosity masks in Affinity Photo, because the current workflow with the extra controller in adjustments feels more like a after thought than designed to perfection.
×