Jump to content

Recommended Posts

Hiya,

One of my fonts has just decided to stop working. I have used it loads previously but I opened a file I had been working on and even thought it is on the list and I can select it what comes out is not the font. It then also has a '?' in front of the font name.

Any help is much appreciated.

 

 

Screen Shot 2017-08-24 at 08.16.16.png

Share this post


Link to post
Share on other sites

The Glamor font is missing from you Mac and will have to be reinstalled, To install the font double click the font file and at the bottom of the font preview screen click Install .

Share this post


Link to post
Share on other sites

Hi DWright,

 

It's not. I thought that might be the case so checked and it is still there and so I actually installed it again and added the other font options of bold and italic etc and it still wont find any of them.

Screen Shot 2017-08-24 at 08.48.03.png

Share this post


Link to post
Share on other sites

For what little it is worth, I downloaded the Glamor font from http://fontm.com/glamor-font/ to test its usability. The first thing I noticed was while that page says, "OTF & TTF files are in attached ZIP folders," only TTF fonts were in the zip file I got by clicking on the green Download button.

 

I decided to install only one of the TTF files for testing & picked the Glamor-Medium.ttf file for that. When I tried to install it using Font Book, I got a warning:

599eaa51ae3e0_prblemsfound.png.f1c7765791c9f6f0668db9673f2c971c.png

It took several tries to install this font file (I don't know why, could be some dumb error on my part) but I got the same "?" when I tried to use it in Affinity Designer. It works OK in TextEdit but my guess is there is something about the 'name' table usability or structure warnings that makes it incompatible with Affinity.

 

EDIT: I also had a lot of trouble removing this font after testing -- Font Book did eventually move it to the trash after several tries but it continued to show up in the All Fonts list until I quit & restarted Font Book. I think there is something wrong with the font, at least for the version I got from this web site.

Share this post


Link to post
Share on other sites

No idea if this will work or not, but I noticed it earlier - and it'll cost you nothing to try…

 

Preferences > Miscellaneous > Reset Fonts

 

Worth a shot, especially since you've described having used the font with Affinity Designer projects in the past…

Share this post


Link to post
Share on other sites
On 8/24/2017 at 9:46 PM, GaryLearnTech said:

Preferences > Miscellaneous > Reset Fonts

Not knowing what this button really does in detail and therefore not using it yet: I experienced that also deactivating + reactivating an affected font in the computers font manager might solve such an issue.

Share this post


Link to post
Share on other sites

Looking at the selection of data that can be reset, I'd guess that each Affinity application builds its own caches and uses that data to speed up day-to-day operations.  Reseting, say, Fonts would then clear the relevant cached data and cause it to be rebuilt afresh.

In cases where the cached data has somehow become corrupted and has begun to cause problems, discarding the cached data and recreating it would resolve some of those problems.

@thomaso in the case you describe, that might be the equivalent of a "micro reset" - causing the cached data for an individual font to be first cleared and then recreated.  But that's just a guess.  

Anyways, glad my old comment was able to help @Father ODD Creations:)

Share this post


Link to post
Share on other sites
On 8/24/2017 at 12:46 PM, GaryLearnTech said:

Preferences > Miscellaneous > Reset Fonts

I know you are using a Mac, but is this v1.7.1.404 or a later Beta?
Because this setting does not appear in the Windows v1.7.1.404 version of either Designer or Publisher.
Thanks.

Share this post


Link to post
Share on other sites

Hi @LibreTraining This same preference panel appears in each of the Mac versions of Designer, Photo and Publisher.  My versions are each simply v1.7.1, with Designer and Photo coming from Apple's Mac App Store and Publisher coming from Serif's own store.  No beta versions.

I don't recall the exact list of options that would have been available when this thread originally ran just under two years ago but if it wasn't the exact same as now, it wasn't far off it.  In other words, not much has changed for this on the Mac version.  image.png.492d74b8d575f1d47c7b7b9cd9d05bbd.png

 

A more detailed version of this exists - at least it does on the Mac - if you hold down ctrl-option (aka ctrl-alt) when the app is launched.  I've seen this mentioned here several times over the years.  I would imagine you'd have something similar on your Windows version - production or beta.  This screenshot obviously shows the options for Designer. Photo has a few more options and Publisher one more option than Photo.

image.png.005192f42d6e4878480cb8e249182c3c.png

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.