Jump to content

AD: adding objects with drag & drop to assets doesn't work


Recommended Posts

In the help section it says the following: 

 

 

To create an asset:

  1. Select one or more objects or groups on the page or via the Layers panel.
  2. Do one of the following:
    • Drag the selection into the Assets panel (the cursor will change to show a plus icon).
    • On the Assets panel, click a subcategory's options menu and select Add from Selection.

 

While the second option works, the first one doesn't. If I drag a selected object on the assets panel (subcategory is created) it won't work. And it also doesn't change the mouse cursor to a plus. it even moves the object behind the assets panel instead.

 

Anyone else got the same problem?

 

I'm working with Affinity Designer 1.5.2.58 on a Windows 10 machine.

Link to comment
Share on other sites

Hi JokeRat,

 

Indeed it is impossible to add an object by pulling it to release it in the panel. This is a problem that has already been raised in the previous version.

Fortunately the add function from the selection works, even if it is less fast.

I'm with the same configuration as you: W 10 and AD 1.5.2.5

Link to comment
Share on other sites

Bonjour reglico

 

Thanks for confirming it.

 

Yes, at least we can add it with the other option even though we also can't reorder the assets with drag&drop, which is a big bummer as it makes the whole collection very, very messy. :(

 

I hope they will correct this bug with 1.6.

Link to comment
Share on other sites

Not much help for Windows users but the drag & drop method does work on the current retail Mac version, although the cursor does not change to show a plus icon.

 

In use it is a bit unsettling: dragging the selection moves it on the canvas, as if the user is trying to change its position there. Only after it is dragged into the Assets panel (& may no longer be visible on the canvas) & dropped there does it reappear at its original location on the canvas & appear as an asset in the Asset category it is dropped onto.

 

Definitely room for improvement on both versions!

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

  • 10 months later...

Nothing on this topic since February? I'm having the same problem.

iMac: iMac (Retina 4K, 21.5-inch, 2017)  -   3.4 GHz Intel Core i5   -   8 GB 2400 MHz DDR4  -  Radeon Pro 560 4096 MB 

Windows: Nvidia GTX 960m 4k UHD 2gb ram video (Windows 10 Pro) -  Laptop screen (resolution 3840x2160 magnified 300%)

2nd Monitor: Phillips 226E9Q HD 1920 x 1080 (125%)

Link to comment
Share on other sites

  • 4 months later...
  • 1 year later...
  • Moderators

We have made fixes/improvements to this area (Cannot drag objects into Assets) of the program in the latest Windows customer beta of Affinity Photo and/or Affinity Designer. If you would like to try these changes the beta software is available in the forum posts listed below.

The 1.8.0.526 beta builds are in links at the top of these beta forum posts.

Once these programs have been through a full beta process the change will be released in a future free 1.8.0 update/patch to all customers.

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

17 hours ago, Patrick Connor said:

We have made fixes/improvements to this area (Cannot drag objects into Assets) of the program in the latest Windows customer beta of Affinity Photo and/or Affinity Designer. If you would like to try these changes the beta software is available in the forum posts listed below.

The 1.8.0.526 beta builds are in links at the top of these beta forum posts.

Once these programs have been through a full beta process the change will be released in a future free 1.8.0 update/patch to all customers.

Thanks for the information Patrick - this is good to know. Unfortunately, I don't have time to test this beta at the moment as I'm busy illustrating a book and can't risk losing anything. I look forward to 1.8.0 being released.

iMac: iMac (Retina 4K, 21.5-inch, 2017)  -   3.4 GHz Intel Core i5   -   8 GB 2400 MHz DDR4  -  Radeon Pro 560 4096 MB 

Windows: Nvidia GTX 960m 4k UHD 2gb ram video (Windows 10 Pro) -  Laptop screen (resolution 3840x2160 magnified 300%)

2nd Monitor: Phillips 226E9Q HD 1920 x 1080 (125%)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.