Jump to content
You must now use your email address to sign in [click for more info] ×

Data Merge Grid Layout Missing on Creation


Recommended Posts

A minor cosmetic issue but when using the Data Merge tool in the 2.4.2.2371 Beta the grid layout is missing when the grid is initially drawn, i.e., the rows and columns are only shown on mouse release...

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

I also noticed the problem with Affinity Pubisher. Unfortunately, things have become very quiet lately. Various
Bugs that were reported have not been fixed to date. I particularly noticed this with the MacOS versions.

I'm looking forward to the beta version of Affinity Designer, Photo and Publisher 2.50 to see which errors have now been fixed.

--
Apple 2020 Mac Mini M1 Chip (16 GB RAM, 512 GB SSD)
Affinity V2 Universallizenz 2.3.1 + always latest beta

Link to comment
Share on other sites

Thanks Chris... :)

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

  • Staff

Hey Hangman,

I've just tried to record my own video for the bug report and for some reason, it's not happening now. Well, it will only happen at extreme sizes. I'm pretty sure I got it on a standard A3 document before.

I asked Sean and he can't get it either

Link to comment
Share on other sites

Hey Chris,

I've tried it on everything from an 85 mm x 55 mm through to A0 and I'm seeing the same issue...

Any chance it's Monterey specific?

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

  • Staff
25 minutes ago, Hangman said:

Any chance it's Monterey specific?

Well, I did see it on Sonoma initially. However, we have seen a few Monterey-specific issues lately - or at least issues have been easier to reproduce on Monterey. I will try this again in the office on Monday but can happily still log the bug.

Link to comment
Share on other sites

41 minutes ago, Chris B said:

Well, I did see it on Sonoma initially. However, we have seen a few Monterey-specific issues lately - or at least issues have been easier to reproduce on Monterey. I will try this again in the office on Monday but can happily still log the bug.

I'd be interested to know whether it's still reproducible with Sonoma if you were initially able to reproduce it...

@anto, are you not seeing either issue, i.e., the initial draw issue failing to display rows and columns as well as the grid being invisible on the page when not selected?

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Thanks Chris... :)

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

36 minutes ago, anto said:

It seems work well.

Thanks for the screen recording... it certainly appears to be OS specific...

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Chris B,

 Interestingly, this is now working correctly in the 2.4.2.2371 Retail release but not in the 2.4.2.2371 Beta despite not appearing on the Retail Bug fix list...does that make any sense? 🤔


Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Sean P,

Is that a Windows file path you've referenced?

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

  • Staff
2 minutes ago, Hangman said:

Hi @Sean P,

Is that a Windows file path you've referenced?

D'oh It is indeed, I had it in my mind you were on Windows. Thats certainly not going to help you on macOS is it! Unfortunately macOS isn't as simple as Windows, but if you try and temporarily rename the 'com.seriflabs.affinitypublisher2.beta.plist' (whilst the app is closed) from the location below and then the app. It should generate a new plist with the default options, and see if that is still causing you problems.
 ~/Library/Preferences/

Thanks!

Link to comment
Share on other sites

Hi @Sean P,

No problem...

Renaming the 'com.seriflabs.affinitypublisher2.beta.plist' (whilst the app is closed) and renaming the app makes no difference. A new plist file is created but the problem persists in the Beta...

In many ways, I guess it's perhaps not so relevant since it's working in the Retail version but it's still very odd...

Let me know if you want me to upload any specific files from the Beta...

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

  • Staff
42 minutes ago, Hangman said:

Hi @Sean P,

No problem...

Renaming the 'com.seriflabs.affinitypublisher2.beta.plist' (whilst the app is closed) and renaming the app makes no difference. A new plist file is created but the problem persists in the Beta...

In many ways, I guess it's perhaps not so relevant since it's working in the Retail version but it's still very odd...

Let me know if you want me to upload any specific files from the Beta...

No worries - that is a shame though! :( 

Do you happen to use external monitors with your Mac at all?

Link to comment
Share on other sites

Just now, Sean P said:

Do you happen to use external monitors with your Mac at all?

No, this is just the MacBook Pro screen... :)

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Chris B,

That's interesting and thanks both for the update and for testing further... I'd certainly be interested to know what you discover should you manage to track down what is causing this, it's a really odd one... :)

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.