Jump to content
You must now use your email address to sign in [click for more info] ×

PDF will not export this graphic!

Recommended Posts

  • Staff

Hi imacken,

I'm not able to replicate this. It exports fine in all PDF/X formats for me.

Which version of Designer are you using? The Beta or MAS?

Have you tried to reset the app pressing and holding  ⌃(ctrl) while launching the app the selecting Clear from the dialog that will appear?

Link to comment
Share on other sites

MEB, try this.

1) Create a new A4 file, then 'Place' the png, then go to 'file/Export/PDF X1-A'and a file size will show OK. So far so good.

2) resize the png to 50mm wide and repeat. Again, the file size shows up OK, and everything is OK.

3) resize the png to 40mm, then you will see that the 'Export' dialogue just permanently says 'Calculating size....' and nothing further happens. No export possible.  

Happens with the latest beta and the MAS versions.

I have files of several layers with that graphic included.  The PDF X export always shows this issue, but if I uncheck the graphic, everything is OK.

Link to comment
Share on other sites

The error you got is because you tried to export it when the dialogue box was still saying 'Calculating....'.

What you have done by simply saving as a jpg and then saving again as a png is not the same as what I have done.

Take the jpg into Photo, select the 'Flood Select Tool', then uncheck 'contiguous', click on the white background, delete that selection. THEN export to png.

Create the A4 document and 'Place' the new png file in, reduce it to 30mm or 40mm width, try to export and you'll get the same problem.

If it is the file, then there is something 'glitchy' about Photo!

Link to comment
Share on other sites

Yes on the "calculating" thing.

So I am getting the same result as you are with that png.


My new png was/ is on transparent background (attached).

(although I did make mine differently.... if that's what you're getting at)


"Create the A4 document and 'Place' the new png file in, reduce it to 30mm or 40mm width, try to export"

Did all that.  Problem with old png. No problem with new png. (for me)


Yeah, there's a glitch. Just trying' to figure out where.


Link to comment
Share on other sites

For what it is worth, I get the same calculating forever results with the PDF X1-A export preset after resizing the image to 40 mm wide. However, if I rasterize the image before trying to do the export, I don't have any problems.


I also noticed that before rasterizing the image, in the export dialog box, just like in imacken's last screen shot, next to the Raster DPI setting, it says "(Nothing will be rasterized)" whereas after rasterizing it says "(Some areas will be rasterized.)" That doesn't make any sense to me since this is a bitmap image, so either way it should be rasterized on export.

All 3 1.10.8, & all 3 V23.0 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

I believe this is a Affinity Photo issue.

I have attached a Designer document that hopefully demonstrates the issue clearly.

This is what I have done. I took the original jpg file into both Photo and Photoshop, did the same process with each, i.e. removed all white and saved as a 'transparent' png.

The png from Photoshop behaves correctly, whereas the one from Photo causes the issue we have been discussing.

The attached Designer document is a blank A4 with both the Photo and Photoshop png files 'placed' inside.

If you look at the File>Export (PDF/X-1a) dialogue box where it says 'Estimated File Size' under these circumstances, this is what you will see:

1) the file as it is. Everything looks fine, file size is showing as 696k.

2) reduce the width of the Photoshop object to, say, 50mm, and still, everything is OK with the dialogue box saying 519k for the file size.

3) now, reduce the width of the Photo object to 50mm, and you will see that the 'Estimated File Size' box just gets stuck on 'Calculating....'.

Clearly, the issue is with the file exported by Photo.  If you hide the 'retro mother icon ap' by unchecking it, you will see the 'Estimated File Size' goes back to normal, i.e. showing a file size.

The break point appears to be 64mm width on the object, as any reduction to that point is OK, but reducing to 63mm and below causes the issue.


PNG test.afdesign

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.