Jump to content
You must now use your email address to sign in [click for more info] ×

Black background when open a transparent .tif file which was rendered from Blender

Recommended Posts

Hi, I got a weird issue with AP V2. When I opened a transparent ".tif" file which was rendered from Blender, AP did not open as transparent background, it did auto fill the transparent area of the image with black color. I've tested with different format: PNG, Targa, Webp,... it works fine.

I've tried to:

- Change all color profile of the Blender render setting => Not work.

- Use "File / Open" menu instead => Not work.

- Remove, re-install, update to latest Nvidia Studio / Game driver => Not work.


This bug did not happen with/when:

- AP V1

- Other transparent image format: png, targa, webp,...

- Create new AP transparent background then drag/drop the rendered .tif file into that new AP file.

I also uploaded the tif file, the color profile of the image and the video that demonstrates the bug then you can see the issue more clearly.

Anything I can do to fix this weirdo? As an 3D artist, especially CGI photography, rendered .tif file is a must working file I do everyday, I hope this could be fix soon. Thanks for stopping by 🙏

Screenshot 2022-12-22 153357.jpg

cube tif test.tif

Link to comment
Share on other sites

  • 2 weeks later...

Yes we hope so, it is not fixed yet version 2.0.3.

But I might have found a solution at least for now.  I have found out that there is a line in channels that says "not assigned alpha-channel" (why should that be?). When I right-click on that channel and select "load alpha in background" I get the alpha working and I can toggle alpha on and off.

As you mentioned every thing else works fine but opening .tif file with trans background does not, at least not coming from e.g. Blender. After saving .tif in AP with trans Background it works when reopen.

Even placing works...

Link to comment
Share on other sites

This solution is very similar to what was found out recently with a BMP of the 32 bits kind (the  glitch was different: it wouldn't show anything, just a transparent canvas). It gets solved doing a similar trick to what you just mentioned. As it'd be something to do in general with transparency/32bit (although this  tiff was saved in 8 bit) or transparency channel info, I don't know. But what I mean is that might not be just file format specific.

AD, AP and APub. V1.10.6 and V2.0.3 Windows 10 and Windows 11.  Both are regular Windows,  I'm not in the Windows Insider program.
Ryzen 9 3900X, 32 GB RAM,  RTX 3060 12GB, Wacom Intuos XL, Wacom L. Eizo ColorEdge CS 2420 monitor. Windows 10 Pro.
HP Omen 16-b1010ns 12700H, 32GB DDR5 (corsair), nVidia RTX 3060 6GB + Huion Kamvas 22 drawing screen, Windows 11 Pro.



Link to comment
Share on other sites

  • 1 month later...
  • 6 months later...
  • Staff

Hi @DaQuizz and @Sonny Sonny, this isn't actually a bug but rather an intentional behaviour: the TIFF metadata from Blender will be written as having unassociated alpha. Previously, Photo was ignoring this metadata and associating the alpha channel, which was actually undesirable for certain workflows. For example, when you save a final beauty pass from vRay without a separate alpha pass layer, it will write unassociated alpha data into the TIFF. This allows the user to optionally remove the background detail using the alpha channel, but they may not wish to: instead, they may just want to use that alpha data for other types of masking such as affecting just the sky or foreground with adjustments.

I did a tutorial on the process here: 


Hope that makes sense and helps?

Product Expert (Affinity Photo) & Product Expert Team Leader

@JamesR_Affinity for tutorial sneak peeks and more

Link to comment
Share on other sites

  • Staff
9 hours ago, Sonny Sonny said:

@James Ritson Thanks but I am still confusing about the issue. Why a small web-app like Photopea has none issue at all with these type of Tif/Tiff files?

Hi @Sonny Sonny, as I mentioned above it's not an issue. Possibly Photopea does not interpret unassociated alpha?

Product Expert (Affinity Photo) & Product Expert Team Leader

@JamesR_Affinity for tutorial sneak peeks and more

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.