Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Recommended Posts

Hello.

I bought and installed the "Affinity v2" suite, and I'm almost satisfied with it, except for a problem with the software crashing when I try to open a file.

I'm on macOS 10.15.7 and, when I do: "Right click" > "Open with..." > "Affinity Designer 2" / "Affinity Publisher 2" / "Affinity Photo 2" on a file (PNG, JPG, SVG, PDF, etc.), the software open before crashing immediately.

Now when I open "Affinity Designer 2", "Affinity Publisher 2" or "Affinity Photo 2" directly, sometimes it works fine and I can open my file, sometimes it crashes immediately (regardless of the file type I tries to open).

I was therefore forced to reinstall versions 1 of "Affinity" (which work without any problems) in order to be able to launch my software.

Do you have a solution to solve this problem?

Do you need the crash reports generated by macOS?

Awaiting your reply.

Best regards.

crash-affinity-designer2.png

crash-affinity-photo2.png

crash-affinity-publisher2.png

Edited by nobduck
Link to comment
Share on other sites

  • 2 weeks later...
  • Moderators

Hi @nobduckwelcome to the forums,

I've seen reports of this issue on Windows when opening a non native affinity file causes an app crash but not yet on Mac, I would initially suggest going through a full reset of the app(s) to their default settings by following the below:

  1. Back up any custom created assets/brushes etc. that have been imported into the app(s) as these will be wiped
  2. Close down all Affinity apps
  3. Hold down CTRL, launch Designer 2 whilst still holding down CTRL
  4. This will prompt a 'clear user data' menu, tick 'Affinity Designer 2' and 'All Affinity 2 apps' to tick all boxes on screen (do not tick deactivate at the bottom)
  5. Press clear, this will load up the app, try opening a file again.

If this still results in the same issue, could you provide me with the most recent crash report(s)? I'll need the full crash report file as a screenshot does not give all the information required.

Link to comment
Share on other sites

I earlier reported that Publisher V2 (Windows) becomes slower at responding after a few hours use - it seems to use a great deal of memory. It has now crashed (whilst trying to paste a MS word document) and will not restart properly - as soon as I try to continue working, it stops responding and I have to close it via Task Manager. This has happened twice in three days of use - last time this happened Affinity Photo2 would not load either - I re-downloaded the software from Affinity and re-loaded both programmes and this seemed to overcome the problem. There appears to be a serious issue with the V2 suite - a pity as the product could be excellent ... . 

Publisher crash.jpg

Link to comment
Share on other sites

  • Moderators
5 minutes ago, MWOO said:

I earlier reported that Publisher V2 (Windows) becomes slower at responding after a few hours use - it seems to use a great deal of memory. It has now crashed (whilst trying to paste a MS word document) and will not restart properly - as soon as I try to continue working, it stops responding and I have to close it via Task Manager. This has happened twice in three days of use - last time this happened Affinity Photo2 would not load either - I re-downloaded the software from Affinity and re-loaded both programmes and this seemed to overcome the problem. There appears to be a serious issue with the V2 suite - a pity as the product could be excellent ... . 

Welcome to the forums @MWOO,

This is the Bug forum for Designer 2 on MacOS, I would advise creating a separate post on Publisher 2 for Windows bugs giving as much detail as possible on the issue. This is to avoid any cross posting/confusion as your issue looks like it's completely different to the original poster's.

Link to comment
Share on other sites

Thanks @NathanC for your answer.

I performed the manipulations as advised.

No sooner had the procedure been completed than the "Affinity Publisher 2" application crashed (without even opening)!

Unfortunately for me, I'm still forced to use version 1 on this computer.

For information, I have a MacBook Pro with macOS 13.0.1 and the entire Affinity v2 suite works without any problems.

Can I send you the full crash report by PM?

Thanks in advance for your help.

Best regards.

Link to comment
Share on other sites

Hello, sorry but it's no good sending the crash report to me as I'm an end-user trying to report the problem to the Affinity tech chaps. I was told to put my issue in the Windows section of the forum but I cannot find a separate Windows section - the forum is just marked MacOS/Windows.

Link to comment
Share on other sites

35 minutes ago, MWOO said:

Hello, sorry but it's no good sending the crash report to me as I'm an end-user trying to report the problem to the Affinity tech chaps. I was told to put my issue in the Windows section of the forum but I cannot find a separate Windows section - the forum is just marked MacOS/Windows.

Hi @MWOO

I don't intend to send you the crash report 🙃

This will be done to someone from the Affinity team only. In this case, to @NathanC.

Best regards.

Link to comment
Share on other sites

I have a MacBook Pro and have upgraded to the Affinity 2.0 Suite and can attest that there is a major bug with SVGs and EPS files being used in documents. I have experienced several crashes after working on a document that has either an SVG or EPS logo.  Upon reopening the document the layer that held the SVG/EPS still shows, but the actual file has been removed/stripped. The only remedy I found is by converting the SVG/EPS file to an PNG and using it in the document, but then I'm left with a lower quality logo.

I hope this can be fixed rather sooner then later.

Link to comment
Share on other sites

  • Moderators
On 12/6/2022 at 3:50 PM, nobduck said:

This will be done to someone from the Affinity team only. In this case, to @NathanC.

Thanks for sending the crash report via PM @nobduck,

We'll focus on trying to get one app working rather than removing them all, could you try a complete re-install of Designer 2 by following the below:

  1. From applications, move Designer 2 over to the bin and delete it
  2. From finder, press CMD + Space to bring up Spotlight search and enter ~/Library/Application Support/
  3. In the Application Support folder, rename the 'Affinity Designer 2' folder to another name, like 'Affinity Designer 2 old'
  4. Go to the Affinity store and re-download and install Designer 2 again

Once installed, launch the app again and try and open and edit your files. If this works then this can be repeated for the other two apps.

 

Link to comment
Share on other sites

Hi @NathanC

Thanks for your answer.

I did all the manipulations as advised:
- I moved the "Designer 2" application to the trash
- I emptied the recycle bin
- I renamed the folder in "Application Support" as follows: "Affinity Designer 2 old"
- I re-downloaded "Affinity Designer 2" from the store
- I reinstalled the app
- I restarted it

As soon as the message asking me to import data from version 1 appeared, the application crashed.

I tried to launch the app again, but it crashed immediately!

Sorry that this solution didn't work.

Do you have another idea for me?

I send you in PM the last crash report generated by macOS.

Best regards.

Link to comment
Share on other sites

  • Moderators

Hi @nobduck,

At this point are you able to get into the app welcome screen or does it crash during the start up/splash screen?

Could you try launching the apps from a separate mac user/ if ones not available creating a temporary new mac user and then trying to launch/use the apps on the separate user? This helps rule out if there's something unusual in the user environment.

Link to comment
Share on other sites

Hi All, sorry but I keep trying to say that this problem is with my Windows 11 PC - not Apple. The forum name is 'Apple/Windows issues' - perhaps there should be definitive separate forums for the two systems? I haven't used Publisher for a few days as I need to get some publications 'out' quickly so I am reverting to Adobe InDesign for the time being - pity as I like the Publisher system.

Link to comment
Share on other sites

7 minutes ago, MWOO said:

The forum name is 'Apple/Windows issues'

No, it's not. The forum name this topic is in is "Designer 2 Bugs found on macOS".

Earlier, another user gave you a pointer to the appropriate forum for Publisher 2 bugs on Windows: https://forum.affinity.serif.com/index.php?/forum/82-publisher-2-bugs-found-on-windows/

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0..3  and 2.0.3.1670 beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta
iPad Pro M1, 12.9", iPadOS 16.3, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.3 / Affinity Designer 1.10.6 and 2.0.3 / Affinity Publisher 2.0.3

Link to comment
Share on other sites

  • 4 weeks later...

Hi @NathanC

First of all, I wish a very happy new year 2023 to the entire Affinity team.

To respond to your test request:
- I created a new session on my Mac
- I opened each Affinity application (Designer first)
- the update to version 2.0.3 has been done
- each application opened correctly, without crashing

So I went back to my main session, and again tried to open each Affinity application (Designer first).

Unfortunately, here, the app crashed once the splash screen was displayed.

Does this mean I could never use Affinity 2 on my main session? It would be a shame 😞 Switching sessions is not the most practical.

Do you have any solutions for me?
Do I need to check something specific in my main session?

Awaiting your reply.

Best regards.

Link to comment
Share on other sites

  • Moderators

Hi @nobduck

Thanks for coming back to me, I have since found another user with an identical problem to yours, it appears to be caused by a user environment specific issue on Mac to do with the most recent documents list (MRU.dat) causing the crashes. Unfortunately the only feasible workaround currently for this is to use an alternate Mac user, I've since collated and logged this issue with the developers for further investigation. I'll get back to you once I get any further information.

Link to comment
Share on other sites

Hi @NathanC

Thank you for your response and investigation.

I hope that the development team will find a solution so that we don't have to change sessions as soon as we need to use Affinity v2.

I look forward to your return.

Best regards.

Link to comment
Share on other sites

  • 2 weeks later...

Having shared everyone's pain and frustration I just wanted to provide a solution which worked for me.  I'm not sure if it will work for anyone on a Mac but my constant crashing during exports has stopped for me.

I'm a Windows 10 user and I changed two key things.

  1. Reduced the file path length of where the images were being saved by renaming so rather lengthy folders and moving the working project files.
  2. Cleared up lots of space on the drive in question.

I hope this may be of relevance and helps others.  

As this issue is so widely reported across the forum by many individuals, I won't cross-post, I'll leave that that decision to the forum administrators.

Cheers,
Richard.

Link to comment
Share on other sites

  • Moderators

Sorry that you have experienced this problem with the Affinity Suite. 

We have now released 2.0.4 on all platforms, and using that build we believe we have made an improvement in that area that should have fixed the crash 

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

Hi @NathanC and @Patrick Connor

Thanks for your help!

  • I uninstalled version 2 of the Affinity apps.
  • I downloaded the proposed 2.0.4 versions.
  • I installed them.

And it seems that, for the moment, everything is working well! Awesome ! 😁
I hope this will hold up over time.

Congratulations to the development team who seem to have solved the problem.

I think this post can be marked as "Solved".

Best regards.

Link to comment
Share on other sites

  • Moderators
1 hour ago, RHWebDesigns said:

Great stuff Patrick! What was the improvement made?

From the release notes, this thread benefitted from this change

  • App crash upon startup caused by a deleted "Recently Used" file on Catalina

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.