Jump to content

Affinity Photo Customer Beta (1.9.2.229)


Recommended Posts

  • Moderators

Status: Beta

Purpose: Fixes

Requirements: Purchased Affinity Photo

Mac App Store: Not Submitted

Download ZIP: Download

Auto-update: Available

 

Hello,

We are pleased to announce the immediate availability of the third build of Affinity Photo 1.9.2 for macOS.

If this is your first time using a customer beta of an Affinity app, it’s worth noting that the beta will install as a separate app - alongside your store version. They will not interfere with each other at all and you can continue to use the store version for critical work without worry.

This beta is an incremental update to the 1.9.1 version recently released to all customers (although it still installs parallel to the released version, as described above). We recommend that you use this beta in preference to the store version if you are affected by any of the issues listed below.

Affinity Photo Team  :ph34r:

 

Changes Since 1.9.2.228


- Added ability to organise LUT adjustment presets, including support for multiple categories and import / export as “.afluts” files.
- Added ability to drag / drop all adjustment presets to reorder them.
- Added support for OpenType reverse chaining contextual single substitutions.
- Significant performance improvements for assets (import, export, organisation, etc.).
- Typography panel performance improvements.
- Minor improvements to Gaussian Blur performance when GPU is enabled.
- Assorted visual fixes in the adjustments panel.
- Further fixes for deadlocks with multiple GPUs.
- Restored ability to plug an eGPU in while the app is running.
- Assorted other small fixes.
- Help improvements,
- Localisation improvements.

 

Changes Since 1.9.1

 

- Fixed issues introduced in build 227 for users with multiple GPUs.
- Fixed occasional screen corruption introduced in build 227.
- Fixed potential deadlock issue when loading large files.
- Fixed assorted small registration page issues.
- Fixed the size of the “General” section in preferences.
- Fixed localisation issues in preferences.
- Fixed inability to add / rename / delete export presets.
- Fixed issue where UI would remain hidden when a studio page was enabled from the menu.
- Assorted small fixes.

- Hardware acceleration has been improved to better make use of Metal (specifically to batch commands together into chunks, which gives the driver a better chance to optimise commands and provides a higher degree of abortability). The benchmark has also been tweaked to use multiple command queues for the Single GPU test, which makes it more representative of “real world” use.

This change affects both real-world performance and benchmark score. The benchmark version has been changed to 1920 - this means that results from this build should not be compared to results from previous builds with benchmark version 1900 (other than to measure the improvements which these changes yield). Once the iPad and Windows builds have been validated with these changes and new beta builds produced, a new forum thread will be created for 1920 benchmark results.

- Assorted performance improvements for assets.
- Assorted content download improvements and fixes.
- Added ability to optionally sort brushes by name.
- Improved performance of export and merge visible, especially in documents with Live Filters.

- Fixed a crash when using File -> Share after File -> Export.
- Fixed a bug where some Live Filters would appear to move after save / load.
- Fixed a crash when opening a brush category context menu with no selection.
- Fixed a bug which caused adjustment to fail to apply easily when clicking with a stylus.

- Assorted other small fixes.
- Localisation improvements.

Link to comment
Share on other sites

I am trying to use Affinity Photo1.9.1 and even the beta 1.9.2.229 with PortraitPro 21.4 Studio version (also tried with the 19) but it does not open the software, nothing happens. I have try with an MacBook Pro M1 and a 2012 iMac Pro (2.5 Gh, 480 SSD, 10gb RAM) it is just not working. 

Screen Shot 2021-03-11 at 7.54.53 PM.png

Link to comment
Share on other sites

8 hours ago, Jose Cuervo said:

I am trying to use Affinity Photo1.9.1 and even the beta 1.9.2.229 whit PortraitPro 21.4 Studio version (also tried with the 19) but it does not open the software, nothing happens. I have try with an MacBook Pro M1 and a 2012 iMac Pro (2.5 Gh, 480 SSD, 10gb RAM) it is just not working. 

Not sure if this is the right place for your observation, but as far as I know, PortraitPro (I'm still on v.19) has never worked with Affinity Photo. Trying to do so on my Mac results in a crash.

CANON cameras (7D, 350D, G9), lenses ranging from 10 to 400mm, and Speedlite 580EX II -  Intel iMac (27" late 2012) 3,4GHz 16GB RAM - 2TB HD (0S 10.15.7 Catalina) - iPhone XR (iOS 14.5.1) + iPad 6,11 (iOS 14.5.1)

Link to comment
Share on other sites

9 hours ago, LesC said:

Not sure if this is the right place for your observation, but as far as I know, PortraitPro (I'm still on v.19) has never worked with Affinity Photo. Trying to do so on my Mac results in a crash.

Hi, I have posted in several forums, I just posted in because I think that maybe they will be a little more prone to read it here, and tested with the beta version.

To answer the other part, yes, it use to work I have been using both for a few years and it was compatible with version 1.7 of Affinity Photo and Portrait Pro 19.

Link to comment
Share on other sites

On 3/12/2021 at 6:59 PM, Jose Cuervo said:

To answer the other part, yes, it use to work I have been using both for a few years and it was compatible with version 1.7 of Affinity Photo and Portrait Pro 19.

Wow! I have never got it to work on my Mac. Affinity Photo always crashed when I tried to launch PortraitPro from AP's filters/plugins.

CANON cameras (7D, 350D, G9), lenses ranging from 10 to 400mm, and Speedlite 580EX II -  Intel iMac (27" late 2012) 3,4GHz 16GB RAM - 2TB HD (0S 10.15.7 Catalina) - iPhone XR (iOS 14.5.1) + iPad 6,11 (iOS 14.5.1)

Link to comment
Share on other sites

On 3/11/2021 at 8:58 PM, Andy Somerfield said:

- Added ability to organise LUT adjustment presets, including support for multiple categories and import / export as “.afluts” files.

I still find the implementation not entirely convincing. For example, how do I select multiple LUTs in the Adjustment panel? From what I've found, it's not possible. So I can add multiple LUTs at once but have to remove them one by one – or delete the entire category, which seems equally desparate. Moving LUTs between categories can also be done only one file at a time.

In addition, I don't like that Affinity Photo doesn't prompt for a name when creating a new category. These are simply named "LUTs [index]" by default, and renaming them always involves an extra step. Granted, this is at least consistent with Photo's behavior in other places of the UI where categories are used.

Do you plan do address these issues as the beta progresses?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.