Jump to content
d3d13

Cant export ACES 1.2 OCIO what I see in 32-bit preview

Recommended Posts

I have an EXR from blender thats saved in ACES with the official 1.2 ACES package from the github . When I import it into AP, point the configuration file to pathTo/OpenColorIO/aces1.2/config.ocio and in the 32-bit preview window my display settings are set to the following. This gives me the correct image in the viewport which matches my blender render. However, when I go to export the image, the colors are not correct and washed out since I assume this is just a "preview" hence the 32-bit preview tab title and not applying the OCIO display transform to the final image. 

I tried adding a OCIO adjustment layer but couldnt get anything to work. When I did this I changed the display transform under 32 bit preview to ICC. The input colorspace is ACES-ACEScg since thats what it is and was rendered in in blender. In the Destination color space dropdown I tried a variety of options but none of them worked nor matched the OCIO display transform in the 32 bit preview of sRGB/ACES. The only way I could capture what it is supposed to look like is to either upload the "raw" ACES renders from blender or what i did which was to take a screen snip of the desktop with windows Snip & Sketch. 

Please help me. I am interested in being able to save ACES only - please dont direct me to look at things related to blender filmic 

 

 

 

screen0.png

Share this post


Link to post
Share on other sites

Thank you. I am just having trouble exporting as a PNG or JPG. They don't even look close to the same. If I export as an EXR the export works fine and matches the 32 bit OCIO preview .

 

In Blender I can render and save in any image format and have result look the same across all formats

Share this post


Link to post
Share on other sites

For the JPEG export, it's going to be RGB-8 rather than RGB-32, which is likely to have a noticeable effect of some kind.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.9.1.979 and 1.9.1.979 Beta   / Affinity Designer 1.9.1.979 and 1.9.1.971 Beta  / Affinity Publisher 1.9.1.979 and 1.9.1.967 Beta

Share this post


Link to post
Share on other sites

@d3d13 - What are you trying to accomplish specifically within AP?  Toward the end of your original post you mention trying to save your AP work to ACES [ACES cg presumably] but then you mention that you are trying to export to JPEG or PNG.  Are you trying to export a gamma-encoded version of the AP documented to an 8-bit JPEG or PNG in ACES or in sRGB?

See this video -

take deep breath and watch the entire thing before pointing me to the original post about not wanting to use Blender Filmic.  Even though the video is about using  Blender Filmic LUTs, the video spells out exactly how to generate correct output for a gamma-encoded format like JPEG or TIFF.

Here is the TL/DR version:

1) When you open a 32bit file into AP and have an OCIO configuration enabled in AP, you need to select "ICC Display Transform" in the 32bit Preview panel.  This is critical to getting your gamma-encoded, exported JPEG or TIFF to look correct.

2) Once that is sorted out, you can use your OCIO adjustment layers to do whatever it is you are trying to do - remember that you are now manually overriding color management to a certain extent.  For example, transform your linear ACES data into sRGB to do texture work.

3) Make your edits.

4) Use an OCIO adjustment to bring the file from the transformed sRGB state back to linear.

5) Export to a JPEG, or whatever you need to do.

The key to getting the "correct" low bit depth, gamma-encoded output is enabling the ICC Display Profile in the 32bit Preview panel, and keeping track of your OCIO transforms to make sure your data are transformed correctly for output.  The attached screenshot depicts a 32bit EXR opened in AP with the above workflow, and the exported JPEG of the composite 32bit document.  I used a Curves and a Levels adjustment AFTER the OCIO transform from linear ACES to sRGB (gamma-encoded data) and BEFORE the transform from sRGB back to linear ACES to manually tone map the bright, unbounded lighting of the celling lights back into the overall exposure range for the rest of the image.

As Walt noted, there will be some differences between the two files and how they are displayed, because of the differences in bit depth and the preview accuracy (like the shadow tones in the 32bit file displayed on the left side of the screenshot).  But that is minimal compared to the differences when ICC Display Transform is not used throughout the process.

 

Have fun!

Kirk

 

 

EXRComp.jpg

Share this post


Link to post
Share on other sites

I was originally trying to import an exr from a blender render that was rendered with ACES color management and then saved as an EXR into AP, make my adjustments to this image, then export it as a jpg or png in order to set it as user background in windows with my colors being constant and consistent in each program. EXR isnt supported in windows personalization as a background image, and even if there was a 3rd party program that would expand the amount of file formats available for background images, i would be curious to know the exact steps in order to get this process to work specifically for the many ACES source/destination color space options

Share this post


Link to post
Share on other sites

After some month that I change my workflow from 3ds Max to Blender and hours of research I have found a solution that work for my workflow.

In Blender
I work with  this Color Management settings:
Display Device: ACES
View Transform: sRGB
Look: None
Exposure: this parameter can be change if you use Photographer add-on because that change the exposure like on a real DSLR camera.
Gamma: 1
Sequencer: ACES - ACEScg

In Affinity Photo
Open the exr
Go to 32-bit Preview
Make sure that you have Display transform on ICC Display Transform, Exposure = 0, Gamma = 1
Select top layer
Add Exposure Adjustment in case you have chance Exposure in Blender - Color Managmente settings
Add OCIO Adjustment: Source: ACES - ACEScg; Destination: Output - sRGB
Add OCIO Adjustment: Source: Utility - Curve -sRGB; Destination: ACES - ACES 2065-1

 

Here my afmacros.

Let me know if that solution helps someone. 

Blender - ACES Adjustments.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.