Jump to content
Blasterbob31

Raw files open pixelated (Blasterbob31)

Recommended Posts

This is a known bug and apparently fixed in current beta.


IPad Pro 10.5/512GB   lpadOS 13.5.1   Affinity Photo 1.8.3 .180   Affinity Design 1.8.3.2 Publisher for iPad (2020?)

Share this post


Link to post
Share on other sites
29 minutes ago, Blasterbob31 said:

How do I access the beta version please?

Apply here: 

 


IPad Pro 10.5/512GB   lpadOS 13.5.1   Affinity Photo 1.8.3 .180   Affinity Design 1.8.3.2 Publisher for iPad (2020?)

Share this post


Link to post
Share on other sites

I have sent an email as requested but had no response. In the meantime I am in able to use Affinity Photo for IPad and if not resolved soon I will be forced to look at my options. Shame because I have previously found the app a pleasure to use.

Share this post


Link to post
Share on other sites

The current beta is a GM, so it’s close to public release date. 
 I think Apple sets a limit on number of users on TestFlight, so beta program may be full. 


IPad Pro 10.5/512GB   lpadOS 13.5.1   Affinity Photo 1.8.3 .180   Affinity Design 1.8.3.2 Publisher for iPad (2020?)

Share this post


Link to post
Share on other sites
6 hours ago, Blasterbob31 said:

Just updated to 1.8.2 and no improvement.

Can you do a screen recording of your process and attach here. It sounds as if you are loading a jpg icon associated with the raw file. If you have a jpg version on the Project screen make sure you use Import from Cloud, not Open from Cloud or it will continue to open the jpg version instead of the raw.


IPad Pro 10.5/512GB   lpadOS 13.5.1   Affinity Photo 1.8.3 .180   Affinity Design 1.8.3.2 Publisher for iPad (2020?)

Share this post


Link to post
Share on other sites
9 hours ago, Blasterbob31 said:

Pleases see attached screen recording.

Sorry, should have suggested this earlier. It would help greatly to turn on 'Show Touches' so mods can 'see' what actions you are taking rather than just the outcomes. Can't see whether you used Import from Cloud or Open from Cloud.

Check this post to see why some raws continue to open in edit mode rather than develop mode.

 


IPad Pro 10.5/512GB   lpadOS 13.5.1   Affinity Photo 1.8.3 .180   Affinity Design 1.8.3.2 Publisher for iPad (2020?)

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, Blasterbob31 said:

Just tried drag and drop from photos and it appears to work

Read this article. It is part of what DM1 pointed you to before.  
https://tidbits.com/2019/06/14/the-ins-and-outs-of-non-destructive-editing-in-photos-for-mac-and-ios/

This process of loading from images is a new process that has been introduced by AP, so yes it is now happening.

The problem resides in how Apple Photos works.  This article explains why.  So if want to load the image you edited in Photos it must be drag and dropped.  Other applications such as Capture One, has two processes when using the AP plug-in.

Edit with - in which case you are asked if you wish a copy be made before sending the edited image (no longer RAW) to AP with the CO edits  (tiff, jpg, … ). Transfers back any edits in AP to CO

Open with - that opens the Raw image without any CO edits.   This is like using CO as a photo catalogue.  No link to transfer back any edits in AP

As noted in the article Apple Photos hides the original RAW file and that is what causes the confusion.  The guy writing the article was an Apple engineer who helped develop Aperture so he knows what is going on.  

Edited by p_mac
spell check, grrrrrr

Share this post


Link to post
Share on other sites

Hey,

I also updated to version 1.8.2 but now the problem occurs only when i open vertical picture using import from photo.

the following message is displayed: “Assigned profile: Photo iPad assigned your working profile (sRGB IEC61966-2.1) to this unprofiled document”

attached below is the screenshot.

 

Can you anyone advise what to do next

6AF965B3-A38E-4183-A85F-C479E25E1422.png

Share this post


Link to post
Share on other sites
9 hours ago, Mh.elhassan said:

 

Hey,

I also updated to version 1.8.2 but now the problem occurs only when i open vertical picture using import from photo.

the following message is displayed: “Assigned profile: Photo iPad assigned your working profile (sRGB IEC61966-2.1) to this unprofiled document”

attached below is the screenshot.

 

Can you anyone advise what to do next

 

Is this a RAW file?  It is opening this image into the Photos Persona that would suggest it is not.  A RAW file should open in the Develop Persona.  You should attach the image and let the mods look at it.  If you do that start a new Topic so they will see because it probably will get buried in here.  

Share this post


Link to post
Share on other sites
10 hours ago, p_mac said:

 If you do that start a new Topic so they will see because it probably will get buried in here.

Ignore this last comment and continue this post here.  If you do this it will push it back to the top so that it can be seen.  

Share this post


Link to post
Share on other sites
On 3/20/2020 at 7:15 AM, p_mac said:

Is this a RAW file?  It is opening this image into the Photos Persona that would suggest it is not.  A RAW file should open in the Develop Persona.  You should attach the image and let the mods look at it.  If you do that start a new Topic so they will see because it probably will get buried in here.  

It is a raw file actually. I do not use JPG at all. the file was imported by the ipad photo app. When I imported it using affinity the raw symbol was on the pic, so i am 100% sure it is raw.

Share this post


Link to post
Share on other sites

This is not happening to me.

May I suggest that you attach the image to your post.  If you don’t want to do that the mods have a Dropbox account that you can upload to.  
I am thinking that because they are all working from home that you perhaps should try another image to see whether it too is not being imported as a RAW file.  

By adding to the comment, it keeps the post at the top.  If nothing else just type ‘bump’.

Share this post


Link to post
Share on other sites

Importing the picture from the cloud works fine. However importing the same picture from the iPadOS photo app does not work.

i attached what happens in my case. The one of the left is the pixelated one, and it is on the opposite direction. Moreover, it is reduced to 120 160 px

the one on the right is the one imported from cloud more specifically OneDrive.

F918597A-9D8B-4352-BB6A-0B3FFEE4F5AC.jpeg

Share this post


Link to post
Share on other sites
2 hours ago, Mh.elhassan said:

 

My camera is Nikon d610....raw file type is nef

 

So what I am seeing is others running Nikon's are having the same problem with nef files.  I use a Sony camera so am not experiencing your problem.  
Try the following,

sign in to your account

at the top of the page using the search symbol, type in nef.  (Make sure your spell checker doesn't take over here and spell something else.)  

You will then see other post about this same issue. 

It does seem like there is a problem.

try doing a drag and drop from Photos and see if that is a work around until it is fixed.  

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.