Jump to content
You must now use your email address to sign in [click for more info] ×

IDML hyphenation


Recommended Posts

There are some differences how text will be hyphenated. Have a look at the attached screenshot. Most values will be converted correctly, but the first "Minimalwert" = 5 (IDML import) and 0 (default) has no counterpart in Indesign CS 6 (mainly the reason, why the text will not be hyphenated good enough). The last 3 input fields in 1.8.0.502 have also no counterpart in Indesign CS 6. I have no idea if there a more options in later versions of Indesign.

This could be fixed easily, but when you first open the file the whole appearance of the text feels like a complete mess.

What I also noticed is, that the hyphenation is better in Indesign. Although not written wrong, the words won't break in APu. I do not know the internals of the APu code, but could it be helpful if you make your own proposals for hyphenation in the dictionary, like this -> Sil~ben~tren~nung?

hyphenation-idml.jpg

------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 32 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Link to comment
Share on other sites

  • 2 weeks later...
On 11/15/2019 at 9:00 AM, Joachim_L said:

There are some differences how text will be hyphenated.

This is what I've noticed, as well. Text import from InDesing went smoothly, even with a long text. It looks good in Publisher, too, apart from the hyphenation. There seems to be hardly any hyphenation at all, resulting in many gaps between some words.

Link to comment
Share on other sites

  • 4 weeks later...

Thanks, A_B_C. It looks as if some paragraphs (I guess due to the words occurring) are immune to any kind of hyphenation, no matter what the settings are. I have set the min score to 0, but  no change whatsoever. Played with other settings - same thing. I'll keep watching.... perhaps future betas/releases will be better in handling this. For now I am happy the way the IDML gets imported, but it would be nice if the functions were more reliable.

Helmar

Screenshot 2019-12-22 at 11.23.17.jpg

Edited by Helmar
added immage
Link to comment
Share on other sites

Did you manually add any soft hyphens into the original Indesign document or set any phrases to Keep together? Manual adjustments like these might prevent the execution of automatic hyphenation. 

Furthermore, you have huge end zones. Try to reduce these values, in particular the paragraph end zone. Again, start from 0 and have a look if it makes a difference. :)

Link to comment
Share on other sites

Quote

Paragraph end zone—specify the amount of space allowed at the end of a paragraph before hyphenation begins.

By the way, I think the explanation of paragraph end zones in the help files is muddled, or maybe I just don’t understand that particular explanation. It seems that the paragraph end zone specifies the desired minimum length of the last string in a paragraph, doesn’t it?

For if it would specify the allowed amount of white space after the string in the last line of a paragraph, increasing the value would result in an admission of shorter strings! “Allow larger white space” is the same as “allow shorter strings.”

But the opposite is true. To get a shorter string, you will have to decrease the value. Hence, the description seems misleading. It specifies the minimum length of the string in the last line of a paragraph. Right? :)

 

Link to comment
Share on other sites

These were all the defaults from the IDML import. Something still seems to be wrong, because despite hypenation enabled and the settings changed, nothing at all gets hyphenated, so it's gotta be something else. I'll keep trying, but for now it's a little unsatisfactory. That said, it's still beta, so there. :-)

 

Link to comment
Share on other sites

4 hours ago, Helmar said:

It looks as if some paragraphs (I guess due to the words occurring) are immune to any kind of hyphenation, no matter what the settings are.

Are you sure that the language is set properly? Check the Character panel to see what the Spelling and Hyphenation languages are set to.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

  • 2 weeks later...
1 hour ago, Joachim_L said:

@Helmar Maybe you could post a sample file here?

Sure thing. 

Here's the history:

  1. IDML document imported.
  2. Layout well imported, incl. linked text boxes
  3. Hyphenation options put to a test. No effect on the text.
  4. Did some style changes to the pullout quotes.
  5. Document saved in AFPUB format
  6. Joachim's mail received asking for a sample
  7. Opened the AFPUB.
  8. Linked boxes all moved from their original position, now overlapping the text.
  9. Linked boxes cannot be moved. Didn't find the option to unlock them. 
  10. Document not saved.
  11. Reply added and first saved AFPUB attached.

Cheers,

Helmar

Teil 10 APub.afpub

Link to comment
Share on other sites

7 minutes ago, Helmar said:

Yes. Both settings, same result.

Thanks.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

OK, took some time for me to see the fault. Have a look at the Paragraph panel Justification and hyphenation values of your document and compare them to the values in the screenshot. To get the document right you just have to edit the used styles justification values.

justification.jpg

------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 32 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Link to comment
Share on other sites

Of course there is a hyphenation. If alignment is set to left, the values from Justification in Paragraph panel won't be used. Have a look at your initial values for the paragraph I changed.

initial-paragraph-settings.jpg

------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 32 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Link to comment
Share on other sites

Ah, what a bitch! It was the maximum letter spacing that - if reduced from 25% to 0% - made the hyphenation happen for justified paragraphs, too. Thanks for again pointing it out, Joachim, and apologies for missing it the first time around.

Cheers,

Helmar

PS: if you import the IDML, as you have done, did you manage to unlock the text/image frames that belong into the margin, but have moved into the main text now? Unlock all doesn't do it for me.

Link to comment
Share on other sites

7 minutes ago, Helmar said:

PS: if you import the IDML, as you have done, did you manage to unlock the text/image frames that belong into the margin, but have moved into the main text now? Unlock all doesn't do it for me.

I would name this a bug. The elements are pinned to the text, but you can easily fix this by unchecking the marked checkbox or unpin it complete after unchecking the checkbox.

keepwithinbounds.jpg

------
Windows 10 | i5-8500 CPU | Intel UHD 630 Graphics | 32 GB RAM | Latest Retail and Beta versions of complete Affinity range installed

Link to comment
Share on other sites

  • 3 months later...
  • Staff

Sorry.

Thank you for reporting a problem using the pre 1.8.0 beta builds. It appears that a member of the Affinity QA team didn't get round to fully investigating this specific report posted in the bugs forums. We are very sorry for this oversight. Yours is one of a number of reports that I am posting this apology to, using an automated script. 

Now we have released 1.8.3 on all platforms containing many hundreds of bug fixes, and we hope your problem has already been fully addressed. If you still have this problem in the 1.8.3 release build, then the QA team would really appreciate you reporting again it in the relevant Bugs forum.

Each of those links above contains instructions how best to report a bug to us. If that is what you already did in this thread just copy paste your original report into a new thread. We appreciate all the information that you have including sample files and screen shots to help us replicate your problem.

This thread has now been locked as the QA team are not following the threads to which this automatic reply is made, which is why we would appreciate a new bug report if you are still have this problem in the release build.

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.