Jump to content
You must now use your email address to sign in [click for more info] ×

Search the Community

Showing results for tags 'export persona'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Frequently Asked Questions
    • Affinity Support & Questions
    • Feedback & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • V2 Bugs found on macOS
    • V2 Bugs found on Windows
    • V2 Bugs found on iPad
    • Reports of Bugs in Affinity Version 1 applications
  • Beta Software Forums
    • 2.4 New Features and Improvements
    • Other New Bugs and Issues in the Betas
    • Beta Software Program Members Area
    • [ARCHIVE] Reports from earlier Affinity betas

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Member Title

  1. Problem description I'm using Affinity Designer 2 Export Persona feature. I want to crop a long screenshot and export it. I divided them using guide lines and then went into the Export Persona panel. However, it failed to automatically capture my guides. This is very inconvenient. Expected result I hope that Export Persona can refer like Photoshop slicing tool, automatically identify my guide lines, and provide a quick cutting and export method without requiring me to manually cut the image. Thank.
  2. Hello, in Export Persona > Slices > Additional properties > Path components I can't find a variable for something like document name. I want to export all slices with the document name (file name) as prefix, e.g. instead of "MyNicePicture_[ Slice name ]" I'd like to have "[ Document name ]_[ Slice name ]". Maybe this is already available somewhere else? If not, I'd like to kindly add it as a feature request : ) Thx for any help. Additional Properties: >
  3. Not sur if this is a bug or a normal behavior. Software : Affinity Designer 2 Beta 2.3.0 (2165) My document hasn't the Transparent Background box checked on its settings window (see attached image). But when I export it in .png format using the export persona the background IS transparent. If I export it in .png using the File -> Export menu, the background IS NOT transparent (but white) as I would expect. If I export if in .pdf format using the File -> Export menu, the background IS transparent. So I'm a little confuse about it. This is a behavior I have on every files and for many time. It is anoying because I always have to put a white rectangle on my documents. Maybe I'm just misundertanding something ?
  4. See the images attached. There is some checkbox labels that are so small it is very hard to read (first image). I understand it is because window width is too small so the text becomes smaller. But I think it would be a good idea to always keep the text readable and find an other way like a new line for instance. Or even reducing the padding in this window that is quite big. I've also noticed that the responsivity is weird. When enlarging the window, the labels stays small, and we have to check a box to update de size (second image).
  5. Would be nice if palletizing can create a global/shared pallete from entire document or selected elements. Each exported slices often have inconsistent color on continuous area such as solid color background.
  6. There is a path field in the slice properties of photo's export persona. When I enter an absolute path there, like E:\secondary_project\exports it is converted to E\secondary_project\exports i.e. th colon is omitted. When I export this slice, I am prompted for a path. If I chose e.g. E:\primary_projects\export (just confirming the prompted path) the exported file is stored at: E:\primary_projects\export\E\secondary_projects\export Saving the path without drive letter doesn't help, becaus in this case the leading backslah is omitted. "\secondary_projects\exports" becomes "secondary_projects\exports". As a workaround I save relative paths and chose root directory on export.
  7. Slices in Export persona is shifted 1px or so and visually not collect. Exported images are ok but this is annoying behavior. very confusing.
  8. Working a lot with Moho Pro I saw myself rebuilding scenes I designed in Affinity Designer or Photo with exported images in Moho again. I never have to do that when using Spine to animate as Affinity has this great Spine JSON batch exporter in the Export Persona. So I was missing that when working in Moho. Until now; I've developed a free plugin script for Moho which let's Moho import all layers and exported cropped images from Affinity Photo and/or Designer via the exported spine.json file! For who is using both Spine and Moho, like me, it is even quite far in importing the setup pose with all images as exported from Spine too. Including all transformations of the images and even tinting of images. There are some limitations when importing spine.json files coming from Spine tho (see mohoscripts page for the script), like images which use meshes aren't supported. But the most important features are supported already! [update] Also when the spine.json file has bone data (like files exported from Spine itself, or when using special layer naming in Krita's exporter), the skeleton will be recreated in Moho during import since v1.1.0! But the main reason for making this was to import layers from Affinity tho. And that all works great now! A real time saver. It also works for Krita, Photoshop, After Effects, Gimp etc. when you install an existing export to spine.json script in Krita. The script is free to download. Downloadlink and more information is here: https://mohoscripts.com/script/wp_spine_import And here are some demo's/tutorial videos I just created. Have fun!
  9. This is latest published AD2 on iPadOS 16.6.1 (yesterday). I have a document that I use as a template even though it’s not saved as a template, with 16 slices created from distinct layers. Initially these slices take the name of the source layer. I have noticed that changing a layer name in Designer Persona does not always propagate to the derivative slice - sometimes does, and sometimes does not, and its inconsistent within a single document. I guess that’s a bug? I have this behaviour on both iPad and MBP. Regards
  10. This is latest published Designer 2 on MacBook with most current OS for my 2016 MBP. The Issue My problem is that slices created from layers in Export Persona do not have same width (in Export Persona) as the source layers, as reported by Transform tool in Designer Persona. Slices are 2662px but layers are 2661px wide. Background I have a document that I use as a template even though it’s not saved as one. It includes 16 slices that were created from layers (these are all groups that represent a small section of the host artboard). I sometimes have to edit the constituent layers in these groups, specifically to change their width to a very specific value using Transform (Designer Persona). After getting ambushed a few times I now check individual layers one at a time to make sure they are the correct size, and at the correct location on the artBoard. Each export group is renamed following my naming convention. Groups are completely distinct, with no shared layers. To make sure the derivative slices have the desired name, the first thing I do after switching to Export Persona is to delete the previous slices. I then select all the source layers, and create new slices. My problem is that the 16 slices created this way (from different source groups) are ALL the wrong size - by which I mean that the size of a newly created slice differs from what Transform reports in the Designer Persona - by 1 pixel. Export Persona reports 2662px, Designer Persona claims 2661px - the value I specified when doing the Transform. I’ve checked sizes in Designer Persona before and after creating the slices, and the outcome is always the same: Export wants to give me 2662px from a 2661px-wide group. The 2661px target width is specific to this document, and is based on document-specific content created very early in the edit process. I had another one yesterday with different width requirements, and that worked perfectly. I believe I have the same behaviour on my iPad running latest published AD2 with iPadOS 16.6.1. I’m open to suggestions, can make a document available to Affinity if they provide a link, please. I will provide a document for the forum if it survives sanitizing.
  11. The slices to export are 1500 x 1875. The exported jpgs result in 750 x 938. I have no clue why. Is there a hidden setting somewhere or is it a bug? For your convenience, I attached the .afphoto Version 2.1.1 for Mac Eine Band-L1010100-20230815-172257-Insta-C.afphoto
  12. Mac OS 13.2 Affinity Design 2.1.1 Steps: As designer persona, create an artboard of an arbitrary size. Assign a 64x64 simple grid to the artboard. Enable snapping. Place a small shape in the middle of a grid cell. Draw a transparent rectangle with no outline from the top-left to the bottom right corner of the same grid cell. Group the two objects together. Ensure that the resulting group is 64x64px in size, and its position is at integer coordinates. Navigate to the export persona. Open the Layers dock and select the group from step 6. Press the "Create" slice button at the bottom right. Expected: A 64x64px slice is created. Actual: A 64x65px or 65x65 slice is created. This issue doesn't allow me to quickly export a lot of same-size images. I'm forced to draw or adjust slices manually. Thank you.
  13. Until now I mostly created graphics inside Affinity and exported it with the export persona without any issues in both Photo and Designer. Today I imported a PSD file into Affinity and created slices of all layers (without even editing inside Affinity). But to my surprise the Slices don't have extensions in the Slices tab of the Export persona and export to files without extensions, eventhough PNG is selected on each slice. When creating a new file and create slices of the new layers everything still works fine; all slices get the PNG extension, because PNG is selected. So there is an issue in Affinity when starting with an already created PSD file to create and export layers as slices. This is how it looks when layers are created inside Affinity (pixel-layers) and we create slices from those layers: This is how it looks when layers are made externally and imported from PSD (to pixel-layers) and we create slices from those layers: As you can see the files don't get an extention when exporting either: The issue is already in the slice-name, so it looks like we cannot even change it [Edit] Added a test PSD file in the Attachment which throws this issue AND the Affinity file created from it where you can see the issue in the export persona. For the record; the PSD is created in the latest Krita (5.1.1). test.afphoto test.psd
  14. Using Affinity Designer 2.1.1 on Windows. In the Export persona and using the Slice Tool, I've tried to snap a few slices to objects on the artboard, and they don't snap... but I honestly can't remember if it has always been like this, or if it's a new bug? I've tried looking up the documentation but it says nothing about this. Trying to determine if I simply forgot this was always been like this before submitting a bug report. Snapping to the artboard edges and other slices works fine though, sooo...?? Thanks!
  15. In export mode, you can create slices from layers or with Slice Tool, but you cannot modify their size after they are created using any of the tools. You can, however, double click a layer and it will bring up the transform bounding box, which allows you to scale, rotate and move the layer. This does not seem to be intended behavior as at that point, there is no tool selected from the tool menu.
  16. Hi there! I am writing, because in the last view months I constantly have the same issue with affinity designer. The procedure is always the same: I do some work I change to the export persona Pick the slices to export press "export"... then the finder window appears, where to export to... then I can click one or two times on some folders (very different every time) then the rotating ball appears while searching the desired folder in the finder window... ...then designer get stuck... This is not always the case, but very regularly. There is no difference in my behavior if this occurs or not. I send the crash repot a lot of times...but now I thought its time to tell you directly. Hope you can fix this, its really annoying. Thanks Andreas
  17. In Designer 2, if you move an Art Board after creating slices, the position of the slices does not get adjusted to follow the Art Board. And it’s trivial to reproduce.
  18. Hi! I think, back in 2017, someone asked, if there would be some other tokens to choose from... So we have the awesome 2.0 release and I want to do some clever multi export as pdf of several artboards using tokens, but... only one <slicename> token?? Where are some other tokens I can use? For example, width, height, dpi, pdf-version, date,... But most of all: I need a filename token, please!
  19. I'm finding when using the Export Persona, saving to a Google Drive location locally, that it freezes and I just keep getting the spinner. I then have to force quit. However, when I use File > Export to a Google Drive location it does not Freeze. Not ideal as I don't get the features I rely upon from the Export persona. I'm on the latest version of the software (1.10.4) and also Mac Os (12.0.1 Monterey). What's going on?
  20. Hi! Is it possible to automatically adjust the size of the slice to the same size as the document? I have several layers and all of them I need to save as separate files with different file formats (some as PNG, some as JPEG, etc.). I need a little bit of support on this case from Affinity Photo community. ;) Thanks in advance for help! :)
  21. Question: In Affinity Photo Export Persona, is it possible to set the export path relative to the source document? Issue/situation: I have a small AppleScript setup which creates a predefined folder structure for most of my commercial photo work, and once I'm done editing an image I will need to export it in multiple resolutions. The exported files are always placed in a fixed location relative to the source document and it would be great if there were an option to then export relative to the source document. My folder structure looks as following: Project folder name – 01 Source –– 01 phocus capture –– 02 capture one –– 03 other – 02 process –– 01 focus stacking –– 02 retouch ( export from retouch folder into low res, high res and website ) –– 03 assets – 03 export –– 01 low res version ( low res versions folder, always relative to the source document in 02 process / 02 retouch ) –– 02 high res version ( high res versions folder, always relative to the source document in 02 process / 02 retouch ) –– 03 contact sheet –– 04 website version Operating system: OSX Catalina 10.15.3 Affinity Photo: Version 1.8.3 Any help or input on this matter is much appreciated, as I'm considering moving from other editors to Affinity Photo. Thank you in advance. PS: if this post is in the wrong forum, then please let me know, and I will submit it in another.
  22. Hi, My first time creating a topic on this forum, please excuse any errors / oversights. Today I encountered this error on Affinity Designer 1.8.5.703 on Windows 10. I had 6 artboards in a file. I created slices and exported jpegs and closed the file. Later on when modifications were done to some of the artboards and ready for exporting slices again, the file kept on crashing when the slices panel was opened. On searching the forums for similar issues reported by others, I came across this (and other similar) thread(s):- I think this issue was addressed earlier, but has resurfaced in this version. I updated Affinity Designer to 1.8.5.703 last Saturday (19th Sept 2020) from the earlier version 1.8.4.x. Since my workflow (almost always) involves creating multiple artboards and exporting slices I can say with confidence that I have never encountered this issue earlier, i.e. since Nov 2019 when I began using Affinity Designer. In the meanwhile, I copied the artwork to a new file and refrained from creating slices. The new file has been behaving OK. Please let me know if you require additional inputs from me.
  23. Hello, not 100% certain this is a bug, but its behavior I wasn't expecting. In Export Persona > Export Options tab > Mode set to Default - when choosing an option from the Preset dropdown, the parameters below do not update to show those belonging to that preset. They remain unchanged. For example, in the screenshot I've changed the Preset from EPS to JPEG, but the parameter options (including checkboxes and postscript which do not apply to JPEG) still remain. If I toggle modes from Defaults to Selection and then return to Defaults, it seems to load the selected preset's parameters. This is what led me to believe this is not behaving as intended. Thank you, Walt Affinity Designer: 1.10.4.1198 (in trial) Windows 10 64bit, ver. 21H2, OS 19044.1347, Exp Pack 120.2212.3920.0 I did try searching the forum before posting
  24. I want to suggest making it possible to keep the original files exif/metadata in ALL slices set. As far as I understood only the very first slice which is automatically set (not really a slice, but just the whole thing called by the projects name) keeps that data since it works with the same engine as the default export function (the one you can use over Data>Export from everywhere, which you can set to delete all exif data if you want). All other manually set slices will always loose their exif data and there is no option to change that! I imagine it to be not that hard to implement it that way that you have the ability to write exif in slices as well (since its only very little data to copy after the file creation), probably even by default. You can always set the options to ditch the exif if you want, just like with the normal export function. Yes, you can currently workaround by cropping multiple times in the normal Photo Persona and its nondestructive as well. But that defies the whole sense behind the existence of the export persona! If I change even the slightest thing in the image I have to redo every crop and pray to the crop gods that it is somewhat cropped the same as before.
  25. In the Export Persona of Affinity Photo, I can't see that layers are linked by Visibility. I would like to be able to see this or have the links panel visible there. If I have linked my layers and colour coded the ones that are associated, it also doesn't show, because the Export Persona doesn't show layer colours. So this means that both means I have at my disposal to tell linked layer visibility from within the layers studio are absent... 2022-10-23 11-45-55.mp4
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.