Jump to content

thomasp

Members
  • Content Count

    89
  • Joined

  • Last visited

Posts posted by thomasp


  1. 10 hours ago, Kal said:

    If the whole app is contained within a frame, then it's not what most of us are asking for here. Ever since MultiFinder appeared on the Mac in 1987, the whole point was that you could run multiple apps side by side and see both windows at the same time. With further improvements over the years came things like drag and drop between apps. You lose some of those benefits when an app takes up the whole screen, so you know… some of us old-timers still prefer the old multi-window approach. If seeing your desktop is a distraction, maybe you just need to clean it up…? 😉

     

    Well with an application frame such as the ones Adobe is using (or every app set up like that under the sun, really) you can scale the app to easily fit other windows around it. I don't see the benefit of having the desktop peek through during color critical work - and worse - having the app interface vanish if you happen to click outside a document window by mistake. That is a usability sin IMO.

    I'm old timer enough to have experienced Photoshop 3 on the SGI which also had this floaty interface. 24 years on I do recall how annoying I found using that.

    Main point for me though are documents opening half obscured by the interface and the need to resize/zoom documents within the document borders all the time.


  2. Yeah I agree with the OP's thoughts about the separated mode. I use it all day (tabbed interfaces just feel so restrictive) and the daily annoyances in window management are real.

    I'd also like to see an application frame for separated mode making its debut to block out the desktop background. Using a neutral/dark wallpaper only helps so much I'm afraid.

     


  3. Phew, well assuming you are using an Intuos Pro or Cintiq (I am not familiar with their other product lines and driver software - if different) then you will be able to configure application-specific profiles and assign keyboard shortcuts to pen and tablet-buttons. A quick test on my end reveals that it's not possible to assign modifier key+mouseclick combinations this way.

    Therefore I think a way to do it might be to use a freeware app called Karabiner that among other things lets you create shortcuts and macros including mouse buttons, map your desired combination onto a keyboard shortcut and assign that in the Wacom prefs. I imagine something like mapping CTRL + ALT + RMOUSE to a button and holding that down while putting the pen down on the tablet, thus invoking LMOUSE should do the trick?

    I should point out I haven't tested this myself nor do I use that AP shortcut personally.

     

    Oh and: I was referring to the Mac version. If you are asking about Windows there might be other tools - like Autohotkey - to look into to achieve the same thing.


  4. First of all I'm not sure if it's a bug or a wrong preference setting:

    What happens is that the circle showing brush size only appears during a paint stroke (pen down on Wacom tablet) and with pen up (pen hovering above the drawing area) it show the standard OSX mouse cursor. During normal operations that leads to a situation where the mouse pointer and the brush size preview or any gizmo to interact with layer contents constantly alternate (flicker).

    I've only recently upgraded my OS from High Sierra to Mojave and also updated AP and AD. I'm absolutely sure that I changed nothing in my preferences and that the behaviour wasn't there in 1.7.3 on High Sierra.

     

    It affects both AP and AD 1.8.1

    Also it seems to only happen when switching from another application to AP/AD via clicking into its interface (running in separated mode here).


  5. I just installed 181 for both AP and AD and was wondering what ever happened to this feature request? What would be the reason to not wanting to show the user context help in separated mode?

    I always feel gimped trying to do more involved masks/selections but the default tabbed interface is just too limiting (I always have multiple documents open and want to view them side by side).

     


  6. Just bumping this to voice my request for scripting features. In particular I dearly miss the ability to load/save/import/export files via shortcut, something the macro recorder does not allow.

    Also taking the opportunity to ask that if scripting is going to be added then please choose a language that is not locked down to one specific OS and ideally is a standard you can already find lots of resources to learn for. *cough* Python *cough* :)

     

     


  7. One feature I am missing from the Adobe camp is the ability to have the program save documents as a background task, allowing you to work on another document in the meantime. When you have to juggle large documents this is a very welcome ability. With AP in its current state however you have to just sit there and wait for any file save task to finish.

    I'm rather surprised at a quick glance the forum search did not unearth any earlier made request for this. Am I not using the correct terms? :)

     

    In the same vein I think it would be great to also have the program load in images in the background. Example use case is that you drag a series of large photos onto the program and start working on the first one that finishes loading. Then any subsequently loaded images pop in and steal your focus away.

     

    Comments related to 1.7.3's behaviour on the Mac.

     


  8. On 11/11/2019 at 4:51 PM, Lee D said:

    @thomasp I can only find a few references to that error, some refer to High Sierra. Which version of macOS are you running and have you tried running your mac in Safe Mode (hold SHIFT while booting)?

    Hi Lee, yes indeed I'm running 10.13.6. I'm just curious at this point if this error is indicative of anything serious happening behind the scenes? So far I've not experienced any crashes related to AP.


  9. I noticed that the console on Mac is reporting a lot of these errors (marked red) for me when running Affinity Photo in the foreground:

    void IOAccelFenceMachine::fence_timeout(IOTimerEventSource *): AMDRadeonAccelerator prodding blockFenceInterrupt

    Only AP seems to trigger them - Designer for example doesn't. Other graphics intensive software using Metal acceleration also seems unaffected. I've seen this error attributed to GPU freezes, hence the curiosity.

     

    What's the meaning of it? Happening on D500 GPU's on a 2013 Mac Pro.

     


  10. Hi MEB,

    Thanks for your efforts thus far.

    I've looked into this a bit more and it may be dependant on my setup - I have AP installed on my (NVMe->adaptor->Mac Pro 2013) system drive and I'm batch-outputting images to an external (modern, fast, FAT-formatted) USB3 spinning disk. After error checking filesystems and updating OS 10.13.6 to the latest security update I can not currently reproduce the zero-byte file creation issue.

    Still testing to see if now all files are being written whenever I run a batch with parallel processing turned off and after that will check if parallel processing behaves. Perhaps it's an issue with AP not waiting around for a comparably slower output device during batch export? Testing it over a slow network might get some results, too.

    What I can rule out is that it only affects files of a certain format or image dimension/file size threshhold.

     


  11. 16 hours ago, RPV69 said:

    Use of Lightroom 4 and DxO Optics Pro 9 is why I am still on 10.8.5.

    Quick sidenote: is LR 4 considered incompatible or gimped in newer OSes? Asking because I have LR 3 on High Sierra - not encountered any problems but not a heavy user either.

     

    Sorry for the offtopic. Giddy for that official 1.7.2 release! Special thanks for putting in the TGA export!

     


  12. I've never even looked at Publisher. :)

    As said I lost it in the Photo update but still have it running on the same machine in Designer 1.7.0 - separated mode, status bar visible in every open document.

    Proof (running on 10.13.6):

    ad_windowelement.thumb.jpg.6159a54018b4c6b269c0638c1034bf08.jpg

     

     

    So it appears this feature was already in but somehow got removed in the 1.7.1 update (which I have not done to Designer so far)?

    Well, now that I see that - if you reintroduce the status bar for separate mode then you might as well consider having the help text only display for the active window and dim or hide it for the background ones.


  13. 8 hours ago, MEB said:

    Hi thomasp,
    That bar is not displayed in Separated Mode (bye design). Gabriel has logged it as an improvement/suggestion so it can be considered for an upcoming version/update. Meanwhile go to menu Window and untick Separated Mode to switch to Window mode and get it back again.

     

    Riiight. Was already there in 1.7.0 though.

    My initial 'bug report' was about the behaviour of said bar and that it came up empty when I switched focus back from something else to AP/AD. Would be worthwhile to include that when you bring the 'bar' back as a feature.

     

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.