Jump to content

Recommended Posts

Designer crashed and brought down my computer. After rebooting, Designer won't open. I've tried restarting Windows again.

Watching the task manager, I can see Affinity Designer open in the background processes for roughly one second before disappearing.

NVidia graphics card, up to date on drivers.

Event Viewer is showing a .NET Runtime error:
Application: Designer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at Backtrace.BacktraceDatabase.LoadReports()
   at Backtrace.BacktraceDatabase.Start()
   at Serif.Affinity.Application.SetupBacktrace()
   at Serif.Affinity.Application..ctor()
   at Designer.Application.Main(System.String[])

Link to comment
Share on other sites

@Mark Ingram, my apologies for the delay, Gmail thoughtfully directed the notification to my spam folder.

%APPDATA%\Affinity\Designer\1.0\CrashReports does not exist. I verified this with an Administrator account. The 1.7.2.424 release works just fine.

One thing that I noticed is that there is no license.xml file in the %APPDATA%\Affinity\Designer\1.0 folder, unlike the Publisher and Photo folders. Is this intentional?
 

Link to comment
Share on other sites

  • 1 month later...
  • Moderators
On 7/23/2019 at 2:16 AM, Hephaestus said:

Designer crashed and brought down my computer. After rebooting, Designer won't open. I've tried restarting Windows again.

Watching the task manager, I can see Affinity Designer open in the background processes for roughly one second before disappearing.

NVidia graphics card, up to date on drivers.

Event Viewer is showing a .NET Runtime error:
Application: Designer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at Backtrace.BacktraceDatabase.LoadReports()
   at Backtrace.BacktraceDatabase.Start()
   at Serif.Affinity.Application.SetupBacktrace()
   at Serif.Affinity.Application..ctor()
   at Designer.Application.Main(System.String[])

Hi, this is an odd crash, as it's actually crashing whilst trying to initialise the crash reporter... The Backtrace library is a third party library which we use for this purpose, and I can see from their history that they fixed a crash in this exact location last month, so I'll make sure we integrate their latest code, and that will fix the issue - but unfortunately you'll have to wait for the next version of Designer to get this fix.

In the meantime, can you try renaming your %APPDATA%\Affinity\Designer\1.0 folder, and starting up? 

Link to comment
Share on other sites

Mark,

Thanks for the reply. I renamed the folder and rebooted, just to make sure that there weren't any old instances of libraries running. I then tried to run Designer without opening any other applications (other than the usual background items). The result was exactly the same. I checked the Event Viewer and the trace is identical.

I'm prepared to wait for the next release, since the beta version works for me. Let me know if you need someone to test the fix.

I appreciate you taking the time to explain the problem and I certainly have enjoyed the unique pleasures of buggy third-party libraries before, so you have my sympathy.

- Robert

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

Just another discovery for those looking for help. I have no idea the scenario. I all of a sudden ended up with Designer launching, gets to loading fonts, then just dies. Crash folder has structure even after deleting, but no content in the folders or the text files in root.

log.txt shows it getting so far through loading fonts... Then just stops.

My fix was to basically delete the 1.0 folder and then go back through and redo.

Link to comment
Share on other sites

  • Moderators

Hi Andy K,

Welcome to the Affinity Forums!

Do you still have the 1.0 folder in your Recycle Bin? If so would you be able to zip it up and upload it to our internal Dropbox account please? I take it deleting this folder resolved the crashes you were getting?
https://www.dropbox.com/request/1nnqPgDpR7zDcXo1KVP3

Would it be also possible you to attach a copy of your entire Fonts folder to the link above as well please? To do this go to C:\Windows\ and then right click the Fonts folder and select Send To > Compressed (zipped) Folder?

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.