Jump to content

Recommended Posts

Designer crashed and brought down my computer. After rebooting, Designer won't open. I've tried restarting Windows again.

Watching the task manager, I can see Affinity Designer open in the background processes for roughly one second before disappearing.

NVidia graphics card, up to date on drivers.

Event Viewer is showing a .NET Runtime error:
Application: Designer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at Backtrace.BacktraceDatabase.LoadReports()
   at Backtrace.BacktraceDatabase.Start()
   at Serif.Affinity.Application.SetupBacktrace()
   at Serif.Affinity.Application..ctor()
   at Designer.Application.Main(System.String[])

Share this post


Link to post
Share on other sites

@Mark Ingram, my apologies for the delay, Gmail thoughtfully directed the notification to my spam folder.

%APPDATA%\Affinity\Designer\1.0\CrashReports does not exist. I verified this with an Administrator account. The 1.7.2.424 release works just fine.

One thing that I noticed is that there is no license.xml file in the %APPDATA%\Affinity\Designer\1.0 folder, unlike the Publisher and Photo folders. Is this intentional?
 

Share this post


Link to post
Share on other sites

Unfortunately, after updating to version 1.7.1 from version 1.6.5, the Designer stopped loading.
Net framework and NVIDIA GTX960M drivers updated, Windows 64 Russian.

At startup, no error messages are displayed.

Share this post


Link to post
Share on other sites
On 7/23/2019 at 2:16 AM, Hephaestus said:

Designer crashed and brought down my computer. After rebooting, Designer won't open. I've tried restarting Windows again.

Watching the task manager, I can see Affinity Designer open in the background processes for roughly one second before disappearing.

NVidia graphics card, up to date on drivers.

Event Viewer is showing a .NET Runtime error:
Application: Designer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at Backtrace.BacktraceDatabase.LoadReports()
   at Backtrace.BacktraceDatabase.Start()
   at Serif.Affinity.Application.SetupBacktrace()
   at Serif.Affinity.Application..ctor()
   at Designer.Application.Main(System.String[])

Hi, this is an odd crash, as it's actually crashing whilst trying to initialise the crash reporter... The Backtrace library is a third party library which we use for this purpose, and I can see from their history that they fixed a crash in this exact location last month, so I'll make sure we integrate their latest code, and that will fix the issue - but unfortunately you'll have to wait for the next version of Designer to get this fix.

In the meantime, can you try renaming your %APPDATA%\Affinity\Designer\1.0 folder, and starting up? 

Share this post


Link to post
Share on other sites

Mark,

Thanks for the reply. I renamed the folder and rebooted, just to make sure that there weren't any old instances of libraries running. I then tried to run Designer without opening any other applications (other than the usual background items). The result was exactly the same. I checked the Event Viewer and the trace is identical.

I'm prepared to wait for the next release, since the beta version works for me. Let me know if you need someone to test the fix.

I appreciate you taking the time to explain the problem and I certainly have enjoyed the unique pleasures of buggy third-party libraries before, so you have my sympathy.

- Robert

Share this post


Link to post
Share on other sites

Just another discovery for those looking for help. I have no idea the scenario. I all of a sudden ended up with Designer launching, gets to loading fonts, then just dies. Crash folder has structure even after deleting, but no content in the folders or the text files in root.

log.txt shows it getting so far through loading fonts... Then just stops.

My fix was to basically delete the 1.0 folder and then go back through and redo.

Share this post


Link to post
Share on other sites

Hi Andy K,

Welcome to the Affinity Forums!

Do you still have the 1.0 folder in your Recycle Bin? If so would you be able to zip it up and upload it to our internal Dropbox account please? I take it deleting this folder resolved the crashes you were getting?
https://www.dropbox.com/request/1nnqPgDpR7zDcXo1KVP3

Would it be also possible you to attach a copy of your entire Fonts folder to the link above as well please? To do this go to C:\Windows\ and then right click the Fonts folder and select Send To > Compressed (zipped) Folder?

Thanks!

Share this post


Link to post
Share on other sites

I also am experiencing this: running the app nukes my machine. Bought it from the Microsoft Store and am unable to launch it. According to Windows, the version is: 10703.481.0.0.

Share this post


Link to post
Share on other sites

Hey,

 

same story here. I brought the Designer first time via Micrsoft store yesterday and Windows crashes with a blue screen after starting the designer. Publisher and Photo running nornaly.

 

I searched for an Windows update "KB451538" and could not find it. Using an Thinkpad T480s with NVidea 3.20.1.57 driver and the game driver (won't use it for gaming) 441.20.

 

 

Regards

Frank

Share this post


Link to post
Share on other sites

I just made a storno on the Designer within the Micrsoft store, uninstll it nd buy direct via serif.

Now ist is running!

Share this post


Link to post
Share on other sites
On 11/25/2019 at 4:27 PM, Ricardo Zea said:

And what have you tried in order to fix your problem?

Please provide some insight into the things you've tried so we know where to point you to.

Whilst I appreciate your effort in trying to help, an app purchased on the Microsoft Store should just work.

Share this post


Link to post
Share on other sites
3 hours ago, Lea Anthony said:

I don't have the ability to get a refund from the store. This sucks.

This is offtopic but if you got a receipt from Microsoft you are legally entitled to a refund. Worst case scenario, you may want to give Microsoft a call.

--

Ontopic:

Quote

Whilst I appreciate your effort in trying to help, an app purchased on the Microsoft Store should just work.

Well, the same goes for any app purchased anywhere else and sometimes that's not necessarily the case.

Look at this thread ‾\_(ツ)_/‾.

Nonetheless, I'm glad you have Designer working now.

Share this post


Link to post
Share on other sites
Just now, MEB said:

Hi Lea Anthony,
Are you also getting a BSD (Blue Screen of Death)? Please check this FAQ for instructions. It's most likely an issue related with a recent Window update/cldflt.sys. Let us know how it goes.

Thanks MEB. That FAQ just lists 3rd party software which I don't have installed. However, thanks for the cldflt.sys pointer! I found this thread about it. I'll try it on my desktop. For some reason it works fine on my laptop ‾\_(ツ)_/‾

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.