Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Affinity Photo has stopped launching.


Recommended Posts

I dont know why this has happened but suddenly I cannot get Photo to open. It opens the splash page & there's a bit for ticking consent but I cant tick it and it disappears and then nothing happens. Sorry if that's hard to understand. Bottom line is it wont open any more.

I have reinstalled .NET framework AND reinstalled Photo and nothing has helped

This is getting ridiculous now. Designer opens just fine.

I have a desk top PC with Windows 7 Pro

I'd really like some decent support on this as I've now spent hours and hours trying to do something that should be really basic. IE open the thing

Link to comment
Share on other sites

@wordjam

Try launching Photo with the Ctrl key held down. Might be an idea to Restart your PC first.

When the Clear User Data window appears, leave the first three options ticked, press Clear and see if that works..

clear.jpg.1aa49e7355b8000aaed87186bf5bff02.jpg

If that works, check in Preferences > General. The issue is sometimes caused by Photo trying to open a corrupted document.

Untick this if it is set.

reopen.jpg.822c06b13190b670800f338549830ce6.jpg

Windows PCs. Photo and Designer, latest non-beta versions.

Link to comment
Share on other sites

14 hours ago, wordjam said:

there's a bit for ticking consent but I cant tick it

What consent is it trying to ask for? o.O

Alfred spacer.png
Affinity Designer/Photo/Publisher for Windows 1.10 • Windows 10 Home/Pro
Affinity Photo for iPad 1.10 • Designer for iPad 1.10 • iPadOS 15.6.1 (iPad Air 2)

Link to comment
Share on other sites

Its literally too fast to even see what it is it just flashes up and then gone. But I think it's agreeing to terms maybe...... I can't do it again now cos I just uninstalled the whole thing with revo & removed everything. I dont know if I'll be re-installing it at this stage. I've spent 2 days just trying to open it. I'll take a break from it and maybe try again tomorrow,.

Note - still NOT having the same problem with Designer. It's Photo specific which makes me think it's not my computer set up

Link to comment
Share on other sites

Ok so I restored my computer to an earlier time, completely uninstalled Photo. deleted old download of it. Downloaded fresh file from Affinity shop. Installed it. All looked fine until I try to open it and same thing happens. The splash screen is up, then the popup for ticking "accept terms & conditions" flashes up then disappears & nothing happens. I ran a compatibility check & got this if it means anything to anyone. And thanks to you all for help but I have to say Affinity support is seriously bad if i cant actually get an official person to answer this basic issue

 

afftroubleshoot.JPG.e4d6eb3d5858a434b6d89e589ddea104.JPG

afftrouble2.JPG

Link to comment
Share on other sites

1 hour ago, wordjam said:

but I have to say Affinity support is seriously bad if i cant actually get an official person to answer this basic issue

I would have to strongly disagree with that. They are normally pretty good but they only work week days, and it is the weekend.

And how do you know it is a basic issue?

Windows PCs. Photo and Designer, latest non-beta versions.

Link to comment
Share on other sites

I am saying being able to open the program is fairly fundamental to being able to use it or even trouble shoot it.  And ok, I did not know they only work week days. But I'll wait and see what happens. At this point I'm deciding whether to try returning my Windows system to factory settings (which is fairly drastic & would really annoy me & cause all manner of inconvenience) or give up on Affinity Photo because I'm losing money & clients now and move on to a different program that actually works. That's just my reality.

Link to comment
Share on other sites

  • Moderators
5 hours ago, wordjam said:

Ok so I restored my computer to an earlier time, completely uninstalled Photo. deleted old download of it. Downloaded fresh file from Affinity shop. Installed it. All looked fine until I try to open it and same thing happens. The splash screen is up, then the popup for ticking "accept terms & conditions" flashes up then disappears & nothing happens. I ran a compatibility check & got this if it means anything to anyone. And thanks to you all for help but I have to say Affinity support is seriously bad if i cant actually get an official person to answer this basic issue

 

afftroubleshoot.JPG.e4d6eb3d5858a434b6d89e589ddea104.JPG

afftrouble2.JPG

3

Hi all. 

Any chance you can send a screenshot containing the rest of the "detection details"?

Have you looked at the Windows Crash report file? That TXT file?

affinitybetaproblem.JPG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.