Jump to content

Affinity Photo has stopped launching.

Recommended Posts

Just a quick update. The problem is not resolved. My installation of Affinity Photo is basically useless now. I am reluctant to reinstall windows but might try it when  I have time & resources to keep working on this and risk having to reinstall everything else. This is a nuisance. I'm thinking of digging out my old Adobe CS3 disk so I can at least do some client work.

Thanks all who tried to help.

Link to comment
Share on other sites

  • 1 month later...
1 minute ago, wordjam said:

Where am I creating a new user account??

On your Windows 7 computer, in case the issue is something messed up in your current account's settings.

-- Walt

Desktop:  Windows 11 Home, version 22H2 (22621.1413) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.2728) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0.4  and beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.4  and beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.4  and beta
iPad Pro M1, 12.9", iPadOS 16.3.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.7 and 2.0.4 and beta/ Affinity Designer 1.10.7 and 2.0.4 and beta/ Affinity Publisher 2.0.4 and beta

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

Ok thanks Gabriel! I havent tried that yet but I will if I need to. I just wanted to let everyone know I stumbled across a fix by accident. (I'd love to be able to say I was clever & thought of it but I can't tell a lie)

It all started when a massive thunder storm hit and killed my computer all of a sudden. When it started back up the safe mode option was up & I chose to start in safe mode with networking. I was tooling around checking things when I suddenly thought "hey I wonder if that bloody Affinity program starts in safe mode!!!"

So I launched Photo & after a while it popped up a message along the lines of "This Program requires DirectX 10 to operate and you do not have a compatible graphics card.We have fallen back to a software implementation to get it to work but it will not be at optimum speed unless you get a new graphics card" I clicked ok. Then the consent screen popped up & didn't disappear immediately. I ticked the box for yes & it launched as normal.

I restarted in normal mode & launched Photo with ZERO problems.

Tried Designer & it would not launch. Was doing the flashing up the consent box etc

So went back into safe mode, went through exact same thing as Photo & now Designer launches fine too

I have not tested either of them for functionality & speed since then nor do I know how they will go after next OS upgrade but for now that's fixed the problem so hopefully that will help others.

I have Direct X 11 installed, by the way & NVIDIAQUADRO FX 3800 graphics card

If I have further problems I'll give Grabriels idea a try

If anyone has info about why the graphics card is not compatible & whether or not I actually need to replace it that would be helpful

Thank you to everyone who offered suggestions. What a performance this has been but now I can get on with some work & try to catch up with the backlog.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.