Jump to content

Recommended Posts

using Affinity Designer for Ipad.

Still not fixed in 2020. Publisher has been released for Mac for quite some time now.

Please review and update.

 

Share this post


Link to post
Share on other sites
Posted (edited)

2020 and seemingly still no solution for this minor problem. It’s just a simple question of recognizing the Devanagari ligitures.

Instead of displaying correctly (Platform: mac OS; Application: Simply every app ever on mac OS, here TextEdit; Font: Google-Fonts Baloo 2; syllable to be displayed: "kscham"):

ksham_correct.jpg

it shows(Affinity Designer 1.8.1, late March 2020):

ksham_wrong.jpg

The problem could be identified as a false handling of Open Type implemented ligatures resp. of false interpretation or omitting of the so called zero width joiner (Unicode codepoint U+200D).

Dear Affinity Team, could you please please fix that issue after three years of users asking. Thanks a lot for your efforts in advance!

Edited by Magic Sunray
typo

Share this post


Link to post
Share on other sites

Hello, it's March 2020, over 3 years since the bug was reported.

I've just purchased Affinity Photo and that also has the same bug. Designer already does.

Do you have plans to fix this in the near future? Otherwise I'll look into another program. Thanks.

Share this post


Link to post
Share on other sites

I'm having the same issue and it has not been fixed. I'm having to create the correct spelling by editing the nodes which then I can no longer edit the word as text after... very time consuming. This is frustrating and disappointing to see this thread has been going on for almost 3 years and still no fix.

Share this post


Link to post
Share on other sites

These 

On 8/30/2020 at 9:51 PM, Abhishek Sachan said:

did anyone found any temporary fix or workaround? Its really frustrating to be limited on a bug which is open from past 3 years??

These guys are not at all interested in solving this bug cause it relates to certain languages. Pathetic service. No point complaining about it. 

Share this post


Link to post
Share on other sites
On 8/31/2020 at 9:12 PM, Pranab said:

These guys are not at all interested in solving this bug cause it relates to certain languages.

Are you implying this issue exists because of racism?
So "you better fix this bug or you're a racist"?
Disgusting.

 

Share this post


Link to post
Share on other sites

Somebody respond to these queries with responsibility. Font is such a very important thing in creating content. By dragging this sensitive issue for so long as 3+ years gives bad impression to anybody who reads this post. You are creating product for users to use them and we who bought your product with so much trust are loosing faith when we see your hopeless silence. This doesn't look good. This is an age where new product take on other products in no time. Quality and responsibility only builds faith in users but this is not happening with you people. Totally disappointed with Affinity.

Venkat.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.