Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Strong lag using the InPainting brush


Recommended Posts

I was hoping to see this serious issue resolved in the new version. Unluckily the InPainting brush in AP is still suffering from lag that makes it simply unusable for professional work. I'm aware that not everyone hast to deal with this effect - on the other side I'm not experiencing anything similar with PS or other products. As well my system requirements should allow a fluent workflow.

System config: Win 7 - 64Bit, iCore I7 3770K, 32GB Ram, 256GB SSD, Nvidia GeForce GTX 570, Wacom Intuos 4, Affinity Photo 1.5.1.51 Beta

See the example video:
https://youtu.be/nh3aNvkA8Oc

CRM.png.a048d588572393102ac3cc403bfa8af7.png

 i7-12700KF, 3.60 GHz, 32GB RAM, SSD, NVIDIA GeForce RTX 3070, Wacom Intuos 4 Tablet, Windows 11 Pro - AP, AD and APublisher V1 and V2
https://www.timobierbaum.com

Link to comment
Share on other sites

Bummer ... that's serious! This topic has been adressed before but noone from the staff commented on it. Either nobody has a slight clue or this topic is of no interest for the development team(?).
I do a lot of retouching work so this tool ist one of the major things I use on a frequent base. Even though I bought AP currently this keeps me away from any professional use of AP.

CRM.png.a048d588572393102ac3cc403bfa8af7.png

 i7-12700KF, 3.60 GHz, 32GB RAM, SSD, NVIDIA GeForce RTX 3070, Wacom Intuos 4 Tablet, Windows 11 Pro - AP, AD and APublisher V1 and V2
https://www.timobierbaum.com

Link to comment
Share on other sites

Hi DarkClown, do you mean the InPainting brush (Scroll through using Windows keyboard J)? Your video looks like it is, but I'm not quite sure.

Windows 11 Pro 64bit ¤ AMD Threadripper 3990x ¤ Nvidia RTX 3090 ¤ 256GB DDR4 Ram ¤ ROG Zenith II Extreme Alpha

Link to comment
Share on other sites

Hi DarkClown, do you mean the InPainting brush (Scroll through using Windows keyboard J)? Your video looks like it is, but I'm not quite sure.

 

Yes, sorry, since I'm using the german version of AP I got mixed up with the proper tool names. Of course it's the Inpainting brush tool. The healing brush tool does not show this lag-behaviour.

CRM.png.a048d588572393102ac3cc403bfa8af7.png

 i7-12700KF, 3.60 GHz, 32GB RAM, SSD, NVIDIA GeForce RTX 3070, Wacom Intuos 4 Tablet, Windows 11 Pro - AP, AD and APublisher V1 and V2
https://www.timobierbaum.com

Link to comment
Share on other sites

Yes, sorry, since I'm using the german version of AP I got mixed up with the proper tool names. Of course it's the Inpainting brush tool. The healing brush tool does not show this lag-behaviour.

 

Thanks, perhaps you could rename the thread title then perhaps the devs will take a look.

Windows 11 Pro 64bit ¤ AMD Threadripper 3990x ¤ Nvidia RTX 3090 ¤ 256GB DDR4 Ram ¤ ROG Zenith II Extreme Alpha

Link to comment
Share on other sites

perhaps you could rename the thread title

 

And the thread tags! I doubt that many users will search for "restauration brush": it sounds like something to do with dining out. :lol:

Alfred spacer.png
Affinity Designer/Photo/Publisher for Windows 1.10 • Windows 10 Home/Pro
Affinity Photo for iPad 1.10 • Designer for iPad 1.10 • iPadOS 15.6.1 (iPad Air 2)

Link to comment
Share on other sites

Thanks for your hints ... I changed the wording in the topic headline, content and tags. (Considering its not a service delay while dining out ;-) )

CRM.png.a048d588572393102ac3cc403bfa8af7.png

 i7-12700KF, 3.60 GHz, 32GB RAM, SSD, NVIDIA GeForce RTX 3070, Wacom Intuos 4 Tablet, Windows 11 Pro - AP, AD and APublisher V1 and V2
https://www.timobierbaum.com

Link to comment
Share on other sites

  • 3 months later...

I'm having a very similar issue with the Inpainting Brush Tool lagging, as well. In my situation, if I drag across a small area or just click once on an area (spot correction), after a few times of touching up with the Inpainting Brush Tool, I will get a progress bar that stops scrolling at about 75-80% of the way, hang for about 15-20 seconds freezing the program (can't scroll, or select menu, or items, etc.) during that time. Once the progress bar disappears, then I can continue working until at a random interval of using the Inpainting Brush Tool it hangs again. It really doesn't matter if it is a small or large area being inpainted for this to occur.

 

Affinity Photo 1.5.2 for Mac

In God's Harmony

Link to comment
Share on other sites

Hi there. Wanted to chime in as I'm having the issue roddy is having. Same version, 1.5.2 for Mac. 

 

After using the inpainting brush, the progress bar freezes about 2/3 of the way. It hangs continuously, I have to 'force quit' Affinity Photo.

Link to comment
Share on other sites

Have to agree with the OP. I find that the 'painting' part is ok but the change/update takes a noticable amount of time. I'd love to see the performance of this tool improved as I do use this rather a lot!

 

Edit: just realised this in in the beta thread. I know there is a lot of debug code in the beta's so that's probably not helping but I think there is an issue with the released version as well.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.