Jump to content
wishiwerevulcan

Big UI Error for Photo and Designer

Recommended Posts

Hi!

 

I've been using Designer Beta for awhile now on my laptop, which is a first generation Razer Blade Stealth running Windows 10. About two weeks ago (after the first RC was released), I started running into a problem where the UI for the program would not correctly load. I tried troubleshooting by myself for awhile (and it wasn't a huge rush), but I've not been able to find a solution.

 

Whenever I open designer on this laptop (my other computers function normally), the UI other than the artboard and rulers does not load.

post-41780-0-60129500-1479257038_thumb.png

 

The photo above shows what I'm talking about. In this case, I opened the program, selected "new document," then opened a standard print size document. During each of the three steps, the UI fails to load. In each of the photos attached, the Designer window should be displaying in full screen. However, I can see my desktop (clearly) but cannot interact with it until I "minimize" the non-existent Designer window. 

 

I've restarted my computer many times, uninstalled and reinstalled several times, and updated the betas as they are newly released - but to no avail. 

 

For the record, the same exact thing is happening to the Photo Windows beta, which I attempted to download and install yesterday. 

 

When I open a file that's previously been created, the file shows up correctly on the artboard, but still no UI. I know it's there as I can interact with it - but I can't tell what I'm doing. (I can access the menu's in the menu bar, for example). Any pop up windows I can access from the menu's (such as the preferences, the print dialog) come up without error. 

 

Any insight you can provide would be appreciated! :)

post-41780-0-17518200-1479257042_thumb.png

post-41780-0-85108000-1479257051_thumb.png

Share this post


Link to post
Share on other sites

Hey wishiwerevulcan,

Welcome to the Affinity Forums :)

 

Do you have any Windows theme managers installed at all? Could you attach a screenshot of all the running apps from Task Manager? We haven't seen this before so it has to be something running in the background causing this and we'd very much like to get to the bottom of it.

 

Cheers.

Share this post


Link to post
Share on other sites

Thanks for the screenshots. Looking at the list of apps I can see 'OSBase iDisplay' processes running. This appears to be a bit of software that extends Windows to USB displays which could interfere. Are you able to stop the process and try running the app up and see if that helps - if possible permanently stopping the process from running on startup and rebooting might help.

If that still doesn't help you could try closing the other processes such as the 'Slack' ones and also all the ones for the Razer products (GameScannerService, Razer Chromium Render Process, Razer Synapse, RazerIngameengine, RzStatsManager) to see if that helps.

Share this post


Link to post
Share on other sites

Ah-Hah!

 

I uninstalled Duet Display (my program for setting up my iPad as a USB external display) and that seems to have done it. 

 

It can be nice to use that program every once and awhile but I don't often anyways - so it's a small sacrifice. Thanks!

 

-Nathan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×