Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Live High Pass Filter


 Share

Recommended Posts

I am having a problem with the High Pass filter in Affinity Photo V2. When I apply a live High Pass filter, it covers the photo with with the gray filter (1st photo), as it did in V1. I then change the way the filter is applied from “Normal” to “Overlay”. When I do that, the filter changes to show the picture with more clarity/sharpness, as it did in V1 (2nd photo). However, when I click on any other layer, the application of the filter changes back to “Normal”, which it did not do in V1 (3rd photo).

Is there something else I need to do before leaving the High Pass layer? Or is this a bug that you are working to correct?

Thank you,

Neal Schneider

CFE69FDE-C599-405C-8929-19361FCF3627.png

B80B7EBD-97DC-44B8-A8AC-E2465E33F3F7.jpeg

DC98888D-9F3A-439F-9389-E5B0A775BBB6.jpeg

Link to comment
Share on other sites

Use the filter on a copy of your main image and make sur it's on top of your main image.

 

-- Window 11 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad Pro 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 9th gen 256 gb - Apple Pencil 1

Link to comment
Share on other sites

@AlainP,

Thanks for your quick response. Do you mean that I should duplicate the background layer and apply the High Pass filter to the duplicate? I normally do the High Pass filter as one of my last steps. Do I need to make that the first step after duplicating the background layer and before making all of my other adjustments?

Link to comment
Share on other sites

10 hours ago, eaglenws said:

However, when I click on any other layer, the application of the filter changes back to “Normal”, which it did not do in V1 (3rd photo).

It’s a known bug, reported to devs, hopefully fixed soon.🙂

IPad Pro 10.5/512GB   lpadOS 16.2 Apple Pencil (1st gen), Affinity Photo 1.10.5 Affinity Design 1.10.5 Affinity Publisher 2, Affinity Designer 2, Affinity Photo 2

Official Online iPad Help documents (multi-lingual) here: https://affinity.https://affinity.help/ 

 

Link to comment
Share on other sites

10 hours ago, eaglenws said:

@AlainP,

Thanks for your quick response. Do you mean that I should duplicate the background layer and apply the High Pass filter to the duplicate? I normally do the High Pass filter as one of my last steps. Do I need to make that the first step after duplicating the background layer and before making all of my other adjustments?

Yes, your first step is to make a duplicate of your main image, then apply your filter on this new copy (which should be on top) and then change its blend mode to Overlay of soft light as you like. It does not have to be your first step.

Never heard of that bug... it works fine here.

Edit: After searching I found a post about this being a bug. It could be as it sometimes works weird.... but I have to make more tests ... when I'll have time.

-- Window 11 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad Pro 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 9th gen 256 gb - Apple Pencil 1

Link to comment
Share on other sites

On 12/4/2022 at 2:23 AM, AlainP said:

Use the filter on a copy of your main image and make sur it's on top of your main image.

 

This is redundant / not required and does not relate to the bug report.

the bug is that the blend mode does not get stored / gets reset to normal when closing the dialog.

 

Mac mini M1 A2348

LG34WK950U-W, calibrated to DCI-P3 with LG Calibration Studio / Spider 5

iPad Air Gen 5 (2022) A2589

Special interest into procedural texture filter, edit alpha channel, RGB/16 and RGB/32 color formats, stacking, finding root causes for misbehaving files, finding creative solutions for unsolvable tasks, finding bugs in Apps.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.