Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Crashes when I try to copy a rectangle


Recommended Posts

Welcome to the forums @Neil Dobson

I’ve just tried this and it works fine for me on Windows 10 – create rectangle; change stroke colour; copy and paste the rectangle.

Would it be possible for you to upload a video of it happening?
If not, can you upload a full-screen screenshot of the application before you take the action which causes the crash?

In either the video or the screenshot it would be good if we can see the Context Toolbar and the Layers Panel showing the selected layer.

Link to comment
Share on other sites

Ups. I can confirm the error with your file. 
The curious thing is that after a resizing, this error does not occur.
If you set the size back to the original value, the Designer terminates again when you try to copy the rectangle.

AMD Ryzen 7 5700x | INTEL Arc A770 | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.1194)
Affinity Suite V2.0.4
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

"Life is one of the hardes"

Link to comment
Share on other sites

Sorry, can't get your file to crash.

Tried this duplicate methods on both rectangles - no errors:

1) menu ctrl + c -> ctrl + v (with original selected when pasting in OR original deselected - works both)

2) ctrl + drag

3) ctrl + j

But i observed a noticable response delay (1000+ ms) when simply deselecting one of the elements. I initially had hardware acceleration on.

a) Turned off h.a. restarted -> no more selection/deselection delay

b) Turned on h.a. again -> selection/deselection delay gone completely ?!

Hardware: Windows 10 Pro for Workstations (22H2, 19045.2364, Windows Feature Experience Pack 120.2212.4190.0), 8 core Intel(R) Xeon(R) W-2145 CPU @ 3.70GHz, 64 GB RAM, NVIDIA Quadro P4000 (driver 516.94), 2 x 1GB SSD. 1 Display set to native 2560 x 1440.
Software: Affinity v1 - Designer/Publisher/Photo (1.10.6.1665), Affinity v2 (universal license) - Designer 2.0.3 / Publisher 2.0.3 / Photo 2.0.3.

Link to comment
Share on other sites

  • Moderators

Hi @Neil Dobson

Are you on Windows 10 or 11? 

Do you find it crashes immediately or do you have to wait a while and then it crashes?

Could you check in Settings > System > Clipboard and see if Clipboard History is enabled

Or do have any other clipboard utility app? 

We also noticed the file is 10m x 7m at 300 dpi, this is quite a large file and a lot of pixel data, if you are working at these sizes then it would be best to set the dpi to 72.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.