Jump to content
You must now use your email address to sign in [click for more info] ×

Recommended Posts

I installed a small assets from forum and all assets disappeared after that! I reinstalled them , I closed the program, then I opened it, all the assets werer gone.... I had to reinstall them again. I did it four times on 22nd October and six times today, on 23rd October....

Very strange.  I had this problem in the past, but for a while no problems at all.

Also, some brushes disapperead, w/o no reason.

Any advice?

Thx

Link to comment
Share on other sites

  • Staff

Hi @mrs68tm,

Could you advise which asset pack was downloaded which then resulted in your other assets going missing? Are you finding that it is only this specific asset pack is causing the other's to disappear? Are you on Windows or Mac?

Any further detail/screenshots would be beneficial in us assisting further 🙂

Link to comment
Share on other sites

Windows 10. No matter what assets is, the Affinity Photo got blocked, then turned white. I had to stop it, when restarted no assets. No matter if I am on-line or offline. I stopped anti-virus software. The same problem. It took me one hour to reinstall them. Sometimes, Affinity is being closed itself without no reason. All assets are gone when I reopen it.

Thx

Link to comment
Share on other sites

  • Staff

I would highly recommend you backup the Assets.propcol file that can be found by following the below:

  1. Press Win + R and enter %AppData%\Roaming\Affinity\Designer\1.0\user\ (If you're doing this for Photo swap this to Affinity\Photo\1.0\user)
  2. Backup/Copy the Assets.propcol to a different file location
  3. If you encounter this again, instead of re-importing all the assets in the app, copy the backup assets file over to the directory to restore them.

The same can be followed for the other .propcol files such as the Raster/Vector brush propcol files if they are ever lost.

Since you're on Windows and it sounds like this is an issue you have only encountered recently, I would recommend following the below FAQ thread in case these crashes are related to the latest windows update.

 

Link to comment
Share on other sites

Thx a lot!

After I installed all assets (again), I closed the program and I tried to copy the assets.propcol, but there was no such file. When I opened the program, all the assets were vanished (again....).

I solved the problem with assets.propcol, but if I close the program and then I reopen it, no assets. I have to copy the assest.propcol from a backup folder to its original location and when I open the program it doesn`t recognize the assets, no assets, just one single assets.

Is there any solution to this very annoying problem?

Thx

Below the last crash reports.

b3914dfc-2b29-441c-900a-bb08e000b34a.dmp 6ca617fb-d66f-4d72-82b0-59f986e02c23.dmp 5bcc14bf-01cd-41eb-8172-db1c9faba895.dmp 03a459b7-1c69-406d-8c24-369b13028f54.dmp 1736d791-dbf4-44d8-a7bf-1a36a996321b.dmp af6036b4-ad14-44f1-b12d-4cb41b3c20e2.dmp 9e455e1b-c27c-47fa-9bda-0aca1aab8f1d.dmp f4b5c737-929d-4b14-8f07-89561315effc.dmp 7ea98b5c-5b29-41c2-ab2c-70d919283b4f.dmp 42f5f276-ce6c-4e38-870d-8cb85aaef771.dmp f6a78671-7e6b-49b0-b666-0efe283f7ba4.dmp 1be1a97d-46a1-467e-b9b6-2997f078ce78.dmp 8ff6aec6-f2c6-4a60-b80b-7c3cd17551ad.dmp 32996233-3d14-4bb3-a42f-569710363cc9.dmp c19ca906-dd30-4f2e-8abf-87632297392a.dmp fc80a510-169a-40c2-ba9b-285af6609e3f.dmp

Link to comment
Share on other sites

I tried to repair the program and after that I reintalled all my assest.

I made a backup from it (assest.propcol) , it has about 9,5 GB. Closed the program and reopened it, no assets at all, Affinity Photo deleted it.. I closed the program, put the assests in the original location (I let it open), then opened the program. Affinity Photo doesn`t see the asests.propcol

It sees all my macros and my brushes.

Is there any solution to this problem?

Thx

assets Affinity Photo.JPG

seen Affinity Photo.JPG

Link to comment
Share on other sites

20 hours ago, NathanC said:

I would highly recommend you backup the Assets.propcol file that can be found by following the below:

  1. Press Win + R and enter %AppData%\Roaming\Affinity\Designer\1.0\user\ (If you're doing this for Photo swap this to Affinity\Photo\1.0\user)
  2. Backup/Copy the Assets.propcol to a different file location
  3. If you encounter this again, instead of re-importing all the assets in the app, copy the backup assets file over to the directory to restore them.

The same can be followed for the other .propcol files such as the Raster/Vector brush propcol files if they are ever lost.

 

 

 

Presumably this method allows you to backup all the assets from the whereas exporting the assets from the application (using the hamburger menu) would have to be repeated for each category?

Link to comment
Share on other sites

  • Staff
11 minutes ago, Catshill said:

Presumably this method allows you to backup all the assets from the whereas exporting the assets from the application (using the hamburger menu) would have to be repeated for each category?

Essentially yes, it can save time if custom assets ever need to be moved to a different device, the same applies to the other .propcol files that are also kept within this user directory.

11 hours ago, mrs68tm said:

I made a backup from it (assest.propcol) , it has about 9,5 GB. Closed the program and reopened it, no assets at all, Affinity Photo deleted it.. I closed the program, put the assests in the original location (I let it open), then opened the program. Affinity Photo doesn`t see the asests.propcol

The crash reports don't indicate it's being caused by the Windows update, but don't give much information on what's going wrong.

The only asset files that don't get restored when following this method are addons that were installed via the 'My add-ons' on the account management page, If you do have custom assets that have been imported that are not showing, could you possibly provide me with your assets.propcol file? This may take a while to upload but i've provided a dropbox link below.

https://www.dropbox.com/request/hft0gChd5U2XxXIGsWD4

Link to comment
Share on other sites

Don't know if it helps, but I remember vaguely that there was a bug some time ago, that resulted in a somehow similar behavior. It could be fixed with a simple workaround. You only needed to change one file somewhere in the installation. Unfortunately I can't remember it more closely, but maybe some of the other members does. There must be a Thread about it somewhere in the forums. As far as I remember it had to do with the registration of the apps.

Link to comment
Share on other sites

Hi,

I opened AP, tried to re-install the assests, brushes bought from Afiinity Official Store, but some files are marked with X, I have to click on it, then in the pop up window  I have to click Retry in orer to download it. (see attached pic). After a while AP closes itself, no assets downloaded. When I open it again, it shows that the download works, but nothing installed in Assets.Normally, after a file is downloaded, it has to be seen in the Assets panel.

If I try to import my own assets oin Assets Panel by using hamburger menu, Import category option, nothing happens. See attaches pic

store-Affinity.JPG.553c022cb5046cbe3258497f930094ca.JPG

 

assets not-installed.JPG

import-assets.JPG

import-failed.JPG

Link to comment
Share on other sites

I did ad follows, I copied assets.propcol from Designer, put it in Photo user folder, opened AP, downloaded all assets from store, it was ok, I made a backup for assets.propcol, closed AP, reopened it, and it didn't see any assets. AP deleted the assets.propcol and put another assets.propcol. I tried three times, the same result.

Any tips for solving it? Maybe to uninstall AP and then to reinstall it?

Thx

Link to comment
Share on other sites

@mrs68tm

Have you done as @NathanC asked and uploaded your 9.5GB assets.propcol file?  

Win 10 Pro, i7 6700K, 32Gb RAM, NVidia GTX1660 Ti and Intel HD530 Graphics

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher, version 1 and now version 2.

iPad Pro (12.9") (iOS 17.4) running Affinity Photo and Designer version 1 and all three version 2 apps.

Link to comment
Share on other sites

5 hours ago, mrs68tm said:

No matter if I reinstalled it in user folder,

Just to be sure: you were, I hope, installing the correct assets.propcol file into the each application? You should not try to install an assets.propcol file from Photo into Designer or Publisher, for example. 

On 10/24/2022 at 6:26 AM, mrs68tm said:

No matter what assets is, the Affinity Photo got blocked, then turned white. I had to stop it

When you have an assets.propcol as big as yours are, it can take some time for any changes to be made to it. Possibly several minutes. How long did you wait before you force stopped it?

With files that size, I would give it at least 5-10 minutes before assuming the program was really hung.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

I let it 24 hours.

When I opened the folder, it was there. I closed the folder, opened Photo, no assets at all. Photo deleted it and replaced it with s very small assets file.

Today, in the morning, I uninstalled all three programs, right, cleaned the system, reinstalled them, and right now they are downloading the add-ons from the store.

I hope to work in a proper way.

Thx

Link to comment
Share on other sites

  • Staff
On 10/29/2022 at 11:59 AM, mrs68tm said:

I let it 24 hours.

When I opened the folder, it was there. I closed the folder, opened Photo, no assets at all. Photo deleted it and replaced it with s very small assets file.

Today, in the morning, I uninstalled all three programs, right, cleaned the system, reinstalled them, and right now they are downloading the add-ons from the store.

I hope to work in a proper way.

Thanks for uploading the file, it doesn't appear to be a local/environment based issue as I've encountered the exact same problem after adding your assets.propcol to all three apps, upon launching the apps the file resets to 1KB and wipes all the assets, this is indicating the file is corrupted and the app is re-creating the file, causing it to appear as 1KB, since the file has been corrupted this will require the files to be re-imported.

This could be caused by any of the .afassets files that you originally imported into the app, if you still have these could you also upload them to the dropbox link below?

https://www.dropbox.com/request/ifIcGipqsb7VCWq9LrbV

Link to comment
Share on other sites

On 10/28/2022 at 4:05 AM, mrs68tm said:

I did ad follows, I copied assets.propcol from Designer, put it in Photo user folder

In my experience, the assets.propcol file is not compatible across the 3 applications, so I am not sure that copying the file from Designer into Photo is a good thing to do.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

  • Staff
14 hours ago, mrs68tm said:

I will send them in more packages.

Thanks for sending over your files, I've been able to successfully import all the .afassets files you provided into Designer via drag and drop into the Assets panel, this has both successfully imported and is not deleting them upon closing/restarting the app.

I had noticed you had uploaded some duplicate .afassets files so I removed these prior to the import.

The total file size of my assets.propcol file came to 1.8GB after importing, which is drastically lower than the original file you provided. I've PM'd you a link to a copy of my assets.propcol file, so it may be worth confirming if this works for you after moving the file over to %AppData%\Roaming\Affinity\Designer\1.0\user\

Link to comment
Share on other sites

Hi,

 

I revert back on this topic.

I worked offline, and I installed my own assets and the ones from third party or from forum. It was OK.

Then, also I worked offline, I installed the assets from Affinity store ( I downloaded them before), I closed the Affinity Photo, when I re-opened it, no assests at all. Just a 1 kb assests.propocol

It seems the problem is one of this assests.

Any tips?

Link to comment
Share on other sites

Hi

The same story. When I try to install any assets from the Affinity store or from a third party, AP get blocked for a while, then it shows the assets being installed, but it installed only the name, no images in the assets. More than that, when I checked the assets.propcol, AP changed the size, from 7 gb to 745 mb or other value. I closed AP, reopened it, no assets. Then the story is being repeated. I install the backup,it works, then I try to install an assets and so on  I am running in the same circle.

Thx

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.