Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Text is created with black background


Recommended Posts

Hi,

I've been using Affinity Designer for awhile now, and just today it has started putting a black background on any text I create (both frame tool and artistic). 

I go to the character palette, and the background color is set, but it is not black. The frame background is black ,and there is no way to change this.

I tried relaunching Designer, and it is still happening. If I convert the text to curves, I get the text object and another object that is a black box. 

What can I do to stop this from happening??

Thanks,
Colin

Screen Shot 2020-09-06 at 1.35.44 PM.png

Link to comment
Share on other sites

3 hours ago, CPritchard said:

black background on any text

I don't know, but the text in your image doesn't have a black background. Its background color corresponds to the color selected on the Character panel. Black is the background of the frame. Your fill color is set in APublisher (Text Frame panel). 

Affinity Store: Affinity Suite (ADe, APh, APu) 1.10.5.1342, 2.0.0.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080, Windows 11 Pro, Version 22H2, Build 22621.819.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080, Windows 10 Pro, Version 21H1, Build 19043.2130.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200, Windows 10 Pro, Version 21H1, Build 19043.2130.

Link to comment
Share on other sites

Just started happening to me, too. It's only happening in one document, I tried making a new document and text works fine. But I can't put new text in the document I'm working on without a black background any more.

macOS 10.15.6
Affinity Designer 1.8.4

Link to comment
Share on other sites

With the misbehaving text frame selected, click the Revert Defaults button: image.png.c8e3ff3bf32901004a6194d999536b62.png

Or Edit > Defaults > Revert.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0.0 / Affinity Designer 1.10.6 (.1665)  and 2.0.0 / Affinity Publisher 1.10.6 (.1665)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.2 / Affinity Designer 1.10.6 and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

Just now, kwaaui said:

Thanks Walt, much appreciated. Any clue about how did that happen in the first place?

You're welcome. If you're absolutely sure you've never edited that document in Publisher, then I have no idea.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0.0 / Affinity Designer 1.10.6 (.1665)  and 2.0.0 / Affinity Publisher 1.10.6 (.1665)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.2 / Affinity Designer 1.10.6 and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

You're welcome.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0.0 / Affinity Designer 1.10.6 (.1665)  and 2.0.0 / Affinity Publisher 1.10.6 (.1665)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.2 / Affinity Designer 1.10.6 and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

Thanks, @kwaaui. In that case, if you can figure out what you did that caused the problem, it would be good documentation for a bug report. Creating that situation should not be possible using only Designer or Photo, as far as I know.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0.0 / Affinity Designer 1.10.6 (.1665)  and 2.0.0 / Affinity Publisher 1.10.6 (.1665)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.2 / Affinity Designer 1.10.6 and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

  • Moderators
12 hours ago, kwaaui said:

Thanks Walt, much appreciated. Any clue about how did that happen in the first place?

Hi @kwaaui,
Welcome to Affinity Forums :)
Have you have assigned black as the background colour in the Character Panel (second colour well on the right of the font style dropdown)?

Link to comment
Share on other sites

2 hours ago, walt.farrell said:

Thanks, @kwaaui. In that case, if you can figure out what you did that caused the problem, it would be good documentation for a bug report. Creating that situation should not be possible using only Designer or Photo, as far as I know.

I tried to understand what happened, but I was just adding text fields above artboards in order to export the whole document with artboards' titles included. At some point, while dragging a text box, I started seeing the black background

Link to comment
Share on other sites

CPritchard: I think part of the problem here may be that the image you gave in your first post does not match the problem you describe in the text.
For example, you say the text has a transparent background but in the image it has a geen-ish brown background.
It’s often difficult to diagnose problems where the image and text of the problem don’t match.
Also, it’s usually best to give a full-screen screen-grab which also shows your Layers Panel with the problem layer selected and visible in that panel.

The more we have to work with, the quicker we can find an answer for you.

Link to comment
Share on other sites

2 minutes ago, MEB said:

Hi CPritchard,
Your case is different from @kwaaui (to which i was referring to in my reply above). Can you please attach the afdesign file for inspection please? Thanks.

@MEB I had the same situation as @CPritchard, the background well in the Character Panel was set to transparent; I set it to a colour and then back to transparent to give it a try, but that only affected the line of text, not the whole text box. Once I clicked the Revert to defaults button, after @walt.farrell's suggestion everything was back to normal 

Link to comment
Share on other sites

  • Moderators

Sorry, my reply is still there but i've hidden it temporarily while I take a deeper look at this. At first sight seems a regular text frame with a background colour set (as created in Publisher). If you and kawaii were able to somehow create this in Designer from scratch then something's wrong. It's also a bit upsetting we can't remove it without reseting the whole object (i believe i've logged this one sometime ago - will check this out as well). I've unhidden the post now (completely forgot about the e-mail notifications). My apologies for the confusion.

Link to comment
Share on other sites

  • 1 month later...
47 minutes ago, friedeggstudios said:

Same issue here, when i type basic artistic text i get a solid colour background instead of being transparent. This is not the case in 1.8 where everything works correctly.

If you're having an issue with the 1.9 beta, then you should post a new topic in the appropriate application's beta forum.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0.0 / Affinity Designer 1.10.6 (.1665)  and 2.0.0 / Affinity Publisher 1.10.6 (.1665)  and 2.0.0
iPad Pro M1, 12.9", iPadOS 16.1.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.2 / Affinity Designer 1.10.6 and 2.0.2 / Affinity Publisher 2.0.2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.