Jump to content

"A platform update is required for Windows 7 SP1." received on Windows 10


Recommended Posts

I haven't used Affinity Photo in awhile, and upon a recent launch I started seeing the error "A platform update is required for Windows 7 SP1". I'm running Windows 10 Home version 1909. OS build 18363.778.

I did try updating to Affinity Photo 1.8.3, and the error remains on launch.

Link to comment
Share on other sites

  • 3 months later...

@Mark Ingram This thread looks pretty old, but I can confirm I am getting this also on Windows 10 Pro. I think you are on to something with the GPU thing, as I have an external Radeon RX 580 connected via USB-C. When I unplug it, it starts up fine without the warning. I'd rather not unplug it every time I want to run Affinity Designer though.

 

 

 

Annotation 2020-09-01 215522.png

Link to comment
Share on other sites

  • Moderators
17 hours ago, makenai said:

@Mark Ingram This thread looks pretty old, but I can confirm I am getting this also on Windows 10 Pro. I think you are on to something with the GPU thing, as I have an external Radeon RX 580 connected via USB-C. When I unplug it, it starts up fine without the warning. I'd rather not unplug it every time I want to run Affinity Designer though.

Annotation 2020-09-01 215522.png

Thanks @makenai. Can you give me some details of your external GPU setup?

Link to comment
Share on other sites

@Mark Ingram Sure, I'll do my best - I think my setup might be a bit exotic. First, here's some device id's for the card:

898718927_Annotation2020-09-02175044.thumb.png.28138fae0c543c7094bb25354292fa10.png

The actual card in question is this one from Sapphire: https://www.sapphiretech.com/en/consumer/pulse-rx-580-8g-g5

It's inside of this Razer Core X enclosure: https://www.razer.com/gaming-egpus/razer-core-x/RC21-01430100-R3U1

..and finally the it's connected through a Dell 3GMVT TB16 Thunderbolt 3 Dock to a Dell XPS 15 9560 laptop. Let me know if I can get you anything else. I can try taking the dock out of the equation and hooking up to the GPU directly if you think it might help narrow things down.

UPDATE:

I disconnected the dock and connected directly to the GPU and the issue didn't occur. What's worse, is now when I hooked everything back up the way it was before, it doesn't happen in theat configuration any longer either! On the one hand, it's nice things are working properly for me now. On the other hand, I wish I had more helpful info for the next person.

 

 

Edited by makenai
Link to comment
Share on other sites

  • 1 month later...

I also wish there was more useful info, as recently I have been facing the same "platform update" error for both Designer and Photo. Both worked perfectly fine beforehand, but now they only seem to work right after I restart my computer. If I wait too long, I get the error message and I'm unable to use either software. I'm also using an RX 580, however I've got a more traditional desktop setup and it's connected directly to my motherboard.

Edited by EBald32
Typo
Link to comment
Share on other sites

  • 11 months later...
  • 7 months later...

Hola a todos, ahora tengo el mismo problema, hace unos meses empecé con este tema y hasta el día de hoy, no he encontrado una solución en ninguna parte. Tengo una Radeon(TM) RX 460

Link to comment
Share on other sites

  • Moderators
6 hours ago, WebHeadMX said:

Hola a todos, ahora tengo el mismo problema, hace unos meses empecé con este tema y hasta el día de hoy, no he encontrado una solución en ninguna parte. Tengo una Radeon(TM) RX 460.

Solo para aclarar, ¿estás usando la RX 460 o la RX 460M? ¿Su máquina también tiene una GPU integrada? ¿Sabes qué versión de controladores estás usando para la GPU?

 

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.