Jump to content
larsbre

Varying behavior of vivid light + high pass

Recommended Posts

To increase the local contrast of an image, I apply the following approach in the photo persona:

1. Duplicate the layer

2. Set the blend mode of the upper layer to "vivid light" and the opacity to 20% - 30%

3. Apply "high pass" live filter to the upper layer with radius 100 px and monochrom checked

 

This was working fine for both jpeg files and raw files coming from the develop persona for all versions before 1.8.2.

For version 1.8.2 however, this leads to strange artefacts when using raw files from develop persona:

 

Jpeg

JPG.thumb.jpg.3150a448c7474d08eb48696c8e4962b0.jpg

 

RAW

RAW.thumb.jpg.209104673c96b25e1990a0ef4071668e.jpg

 

I also tried a workaround by using only one layer (no duplicate) and applying the "high pass" directly to the lower layer using "vivid light" as blend mode for the "high pass" with the other settings (radius, opacity) as above. This works fine for the jpeg file but same unsatisfying result for the raw file.

I have tested this for numerous jpeg-raw combinations and you can find 3 pairs attached.

Images.rar

Share this post


Link to post
Share on other sites

@larsbre,

I'm not sure what effect you're wanting to achieve, but most of the time when applying a high-pass filter, people generally use softlight or overlay blend modes. Vivid light produces bizarre results as you have found. 


Affinity Photo 1.8.5.703 ; Affinity Photo Beta 1.9.0.876); Win10 Home Version:1903, Build: 18362.207: Intel Core i7-4770, 3.90GHz, 32GB Ram, Nvidia GTX 645, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Share this post


Link to post
Share on other sites
1 hour ago, Ron P. said:

@larsbre,

I'm not sure what effect you're wanting to achieve, but most of the time when applying a high-pass filter, people generally use softlight or overlay blend modes. Vivid light produces bizarre results as you have found. 

Yeah, I know the other techniques for "high pass". Nevertheless, this was working properly in Affinity Photo without artefacts before, it is working properly in other software like GIMP or Darktable and is still working properly for jpeg files in Photo 1.8.2. Even if these "bizarre results", as you call it, are desired by Serif (I have high doubts that this is the case...), there should be the same artefacts for jpeg files directly in photo persona and raw files coming from develop persona....

Share this post


Link to post
Share on other sites

Thanks for your response, this gives a workaround for the moment. This concret example may be a rare special case that does not seem to be very relevant to many but in general: shouldn't the effect of a blend mode be independent from color depth? (And as far as I can tell, it did not matter up to now, at least I didn't experience this before version 1.8.2). So there might be a general issue in the code for blend modes that can have also other effects. Not sure, just a suggestion to have a closer look at....

Share this post


Link to post
Share on other sites

I'm experiencing same issue with 1.8.2.  I'm using the Extract Detail Macro that Pedro Soares created here:   https://forum.affinity.serif.com/index.php?/topic/36265-extract-detail-macro/&tab=comments#comment-178831 

It too uses Vivid Light filter. Works fine on Jpegs, but creates colored artifacts on raw (NEF) files.  Problem disappears when I convert to RGB/8 bit.

 

Share this post


Link to post
Share on other sites
On 3/30/2020 at 1:25 PM, Gabe said:

Hi all,

We are aware of this and it has already been logged with our developers. 

Thanks Gabe for your effort. Any news regarding this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.