Jump to content
Darryl  J SAUNDERS

(Dsrryl Saunders) Sony RAW files

Recommended Posts

Hey Darryl J SAUNDERS,

It seems to be working for me on a few .arw files I've tried from a few cameras. Would you mind attaching the raw for me and let me know which camera it is from? Thanks! 

Share this post


Link to post
Share on other sites
On 2/28/2020 at 1:54 AM, Tttt said:

I have the same problem with RAW files from my Sony camera (A5000: ARW, RAW+JPEG).

4F86FFDD-4C0B-467D-8DE3-6492589526A5.jpeg

I have same problem on SONYRX10IV camera when importing RAW+JPG format directly from SD card. Problem started after upgrading to 1.8.

Share this post


Link to post
Share on other sites

I got the same error message by doing the same things as described above. 
Not to take away from the bug reported above, but just wanted to report that I did drag and drop the same image into AP successfully.  
Don’t know whether this info will help isolate the bug, but thought I would let you know.

sony a7rm3

Edited by p_mac
Camera used

Share this post


Link to post
Share on other sites
On 2/27/2020 at 1:15 PM, Darryl J SAUNDERS said:

Unable to open Sony raw files after latest update 

Same for me ....

 

Share this post


Link to post
Share on other sites
14 hours ago, p_mac said:

I got the same error message by doing the same things as described above. 
Not to take away from the bug reported above, but just wanted to report that I did drag and drop the same image into AP successfully.  
Don’t know whether this info will help isolate the bug, but thought I would let you know.

sony a7rm3

Not sure how this works? Have iPad pro 12.9 inch.

Share this post


Link to post
Share on other sites
2 hours ago, Piro said:

Not sure how this works? Have iPad pro 12.9 inch.

I have the iPad Pro 12.9 as well.

Open the Finder window, main window where you see all the images you are working on.  

Then drag up the Photo App onto the AP app.

From there find the image you want to load that was altered in Apple Photo, and drag it onto the finder window of AP.

It will open from there.  

I noticed that this is still considered a raw file but it opens directly into AP's Photo Persona. If you open Document type you will see that it is a different file format when altered by the Apple Photo App.  

If you open the original image directly into AP without first editing it in Apple Photo it will open in the Develop Persona.  

This would be considered a 'work around' as of now, but help the mods help the devs figure out why this is happening.  This could be an Apple Photos problem.

Edited by p_mac
addition comment

Share this post


Link to post
Share on other sites

I am not looking at my iPad Pro right now but I read your comments and was seeing if I could produce your issue.  That is when I started looking at the file formats.  

I'm not sure why Chris B couldn't reproduce this.  

On 2/27/2020 at 8:47 AM, Darryl SAUNDERS said:

THE RAW FILES ARE FROM SONY A6300 AND SONY A73

I just want to add a comment and I have quoted your response above.  Don't know whether you didn't see that you were all caps here, but this is something that one should not do on this site, no need to shout.  

Chris B is really good here and if he asks for you to attach a file and you don't want to attach it on the forum site, let him know and he will provide a dropbox link for you to upload it to.  

This is why I commented here so that Chris B could see that others are having the same problem.  

Share this post


Link to post
Share on other sites
15 hours ago, p_mac said:

I have the iPad Pro 12.9 as well.

Open the Finder window, main window where you see all the images you are working on.  

Then drag up the Photo App onto the AP app.

From there find the image you want to load that was altered in Apple Photo, and drag it onto the finder window of AP.

It will open from there.  

I noticed that this is still considered a raw file but it opens directly into AP's Photo Persona. If you open Document type you will see that it is a different file format when altered by the Apple Photo App.  

If you open the original image directly into AP without first editing it in Apple Photo it will open in the Develop Persona.  

This would be considered a 'work around' as of now, but help the mods help the devs figure out why this is happening.  This could be an Apple Photos problem.

Thanks very much p_mac, that's incredibly helpful. This seems to work for me, though I'm not convinced that the file that opens is RAW, rather than JPEG: whereas under the previous 'import from photos' action the file would open in the Develop Persona with a RAW tag, your workaround (as you say) opens in the Photo Persona. 

Is there some way of knowing whether the file really is RAW? I should say that the JPEG/RAW (Sony .awr) files I am trying to open from Apple Photos are as they left the camera, and have not otherwise been processed in any way.

Thanks in advance.

Piro

Share this post


Link to post
Share on other sites
Posted (edited)

I am also unable to open raw files. Same error message. Sony a7ii

iPad Pro 2nd generation 13.3.1 software

 

Edited by Linda M

Share this post


Link to post
Share on other sites

Hi Piro,

I misunderstood you.  I thought that you had done some editing in Photo prior to your import to AP.  

So I went back and imported a few photos from both a Sony a7rm3 and a a7rm4 into Photos.  I did that by connecting the camera directly to my iPad, something I don’t often do because I usually have a large lens on them.  Much easier to just us the card and a reader, but works both ways.  

I also tried to import directly from my camera into AP and the app crashed each time for both cameras.  I was probably doing something wrong.   
So then I loaded them into AP as the video shows with no problem.   

The image I was loading was from the a7rm4 is 61mps, just to explain the load time.  Works really well.   Sony did some camera updates recently with Apple, just wondering if your camera software is up to date.

iPad Pro 12.9 6gb 1T
 

Share this post


Link to post
Share on other sites

OK so I've just tried two different processes: (1) took new photo on Sony RX100iii in RAW+JPEG format; (2) took new photo on same camera in RAW format.

(2) Imported correctly into Affinity Photo, showing as RAW and opening in Develop Persona. (1) (JPEG+RAW) failed to import, showing the 'Failed to open file' dialogue box. 

So no help in opening files where photos are in JPEG+RAW, as is the case with most of my photos going back some years.

Share this post


Link to post
Share on other sites

Sorry to be thick, but what is the '172 beta'? Does one need to subscribe to the beta programme to get this? Currently running 1.8.0.168.

Thanks

 

Share this post


Link to post
Share on other sites

Here is the link.  You need to have TestFlight installed. You need to apply to install it thru Affinity.  Hope the link works for you.

Share this post


Link to post
Share on other sites

 

3 hours ago, Piro said:

That's fine going forward, but not much use for the many RAW files already imported into Photos where originals of no longer exist on SD card. 

Have to ask.  Is your iPad the only computer you are using?  Even with 1T, that fills up quickly if there is no secondary storage.  
Right now I load my files to external hard drives thru my computer and when I want to use them with my iPad I load them onto a SSD. I can now load from that SSD (doesn’t have to be an SSD but it’s quicker).

I am too cheap to pay for cloud storage and besides it is very slow.  Hope those originals are not lost.  
 

Share this post


Link to post
Share on other sites

Actually I've just addressed this issue. I'm using iPad Pro 12.9 with 256gb, in conjunction with MacBook 500gb. Don't like Cloud storage for lots of reasons, so I also use external storage, including SSD and most recently WD Passport SSD Wireless which gives a 'personal Cloud' option which is useful when don't want to bother with wires. 

The originals are safe, though it's been a pain backing them up (as also discussed on here). In future I'll be shooting in RAW rather than JPEG+RAW which avoids some of the problems.

Share this post


Link to post
Share on other sites

I've tried the 172 beta and it seems fine opening from Photos. I've done some edits in Photos and tried the unedited version too. I can also import it from Cloud etc. Everything seems fine for me. I'd appreciate some additional checks if anyone has the 172 beta installed 🙏 Thanks! 

It seems really file specific. I've reproduced it from a Sony A700. I'll chat with dev.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.