Jump to content
You must now use your email address to sign in [click for more info] ×

The file could not be opened because permission was denied


relayer35

Recommended Posts

I am still having the problem described here after two years. I am currently using version 1.7.3.This is super annoying when I am working on a lot of files.: 

 

To recap the problem. When I open a file, about every fifth time I try to open the file (not always the fifth time, the amount of times varies), I get the permission error above. If I close Affinity Pro, and re-open it, I can open the file normally. This happens sometimes when trying to export a file as well. This happens with files stored locally on the Mac, or on files on a network drive. It doesn't seem to matter. Suggestions I've tried from other threads that did not work: Pruning the number of fonts active on my machine, giving Affinity Photo Full Disk Access in Security and Privacy.

Link to comment
Share on other sites

On 12/6/2019 at 6:06 AM, Gabe said:

Hi @relayer35

Can you please try to create a new user on your Mac and see if you can still replicate it there? 

I created a new user and opened about 15 files. I was unable to re-create the problem with the new user. 

Please do not suggest that I use a new user for Affinity Pro. I am not having an issue with my user account and any other program on the Mac. Just Affinity Pro. That would not be an acceptable solution.

Link to comment
Share on other sites

On 12/9/2019 at 5:53 PM, MikeW said:

Those are helpful suggestions, I tried some of them, but the problem wasn't completely solved.

Here's something I noticed, I usually open a file, work on it, save it, and close it and then open another file. After five or six times, the problem presents itself. However, I've noticed if I just leave the files open, and open another file, when the problem happens, if I close one of the files, I then can open one more file. Then if I try to open another file, I get the error message again, but again, closing one of the open files lets me open one more file.

Does that still sound like a user account issue?

Link to comment
Share on other sites

  • 1 year later...

I had the same issue and found that changing the file image type default action from Affinity photo to preview resolved the issue. The issue I was having was specifically related to JPEG files, which had recently been set to default open with Affinity Photo. However, once set to default open with Affinity, the files would get the permissions error. Once reset back to preview, the files would open fine (after restarting Affinity Photo).

Link to comment
Share on other sites

  • 2 months later...

I found the cause of this problem for  me. Seems like when I opened a designer file in affinity publisher it will no longer open in designer and instead gives the error message "The file could not be opened because permission was denied."

It opens fine in publisher though.  Please look into this as if the solution is to buy publisher that might not be a  valid solution for everyone. Also I don't always want to use publisher.

Link to comment
Share on other sites

  • 1 month later...

Hi

I have had success with the following after I created a new profile and couldn't open them due to the problem "The file could not be opened because permission was denied."

Right click the file and select properties, then security tab, then advanced, and then add you as a current user to the permissions. Basically the file did not have me as a new user with permissions. You'll need to find out what Windows thinks is your current user name which you can find out in C:\Windows\Users

There is probably a better tutorial on adding permissions to a file on the internet.

Link to comment
Share on other sites

  • 10 months later...

I'm getting hit by this when exporting from Exposure Software to Affinity Photo.  It says affinity photo doesn't have access, even though affinity photo has been assigned full disk access in Mac.  This seems to indicate that this is an affinity photo problem and a very annoying one at that.  I can export from Exposure software to any other of my editing apps, Adobe products, Topaz products etc.  Only Affinity has this issue.

Link to comment
Share on other sites

6 hours ago, Marshalleq said:

I'm getting hit by this when exporting from Exposure Software to Affinity Photo.  It says affinity photo doesn't have access, even though affinity photo has been assigned full disk access in Mac.  This seems to indicate that this is an affinity photo problem and a very annoying one at that.  I can export from Exposure software to any other of my editing apps, Adobe products, Topaz products etc.  Only Affinity has this issue.

Where did you purchase Affinity Photo: from Serif, or from the Mac App Store?

How many fonts do you have installed on your system?

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

Oh boy, I would usually get this from the web site, but in this case I wasn't aware you could do that and got it from the App Store.  Hopefully there aren't any missing features.

I don't have any additional fonts, just the standard fonts with Mac OS.

Link to comment
Share on other sites

57 minutes ago, Marshalleq said:

Hopefully there aren't any missing features.

The version from the Affinity Store and the version from the Mac App Store (MAS) are functionally the same, but the version from the MAS is subject to some "sandbox" restrictions that macOS applies to it.

One of those restrictions relates to how many files you can have open, and a common place to hit that restriction is with font files for users who have installed a lot of fonts. If you haven't done that, then that would not explain your problem.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

28 minutes ago, Marshalleq said:

Thanks for the explanation.  I wonder if I can cross grade it back to a non-mac App Store version.  Oh well.

You would have to re-purchase.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

  • 1 month later...

 

On 6/26/2022 at 10:13 PM, Marshalleq said:

I'm getting hit by this when exporting from Exposure Software to Affinity Photo.  It says affinity photo doesn't have access, even though affinity photo has been assigned full disk access in Mac.  This seems to indicate that this is an affinity photo problem and a very annoying one at that.  I can export from Exposure software to any other of my editing apps, Adobe products, Topaz products etc.  Only Affinity has this issue.

I'm having the same issue - started today and I've changed nothing on my Mac 

Link to comment
Share on other sites

  • 1 month later...

This is SO anoying. I use Adobe for years and nothing like this happened. Is possible Serif release one update to fix this? I always used font managers with a kind of a good number of fonts activated. (nothing absurd) and always worked fine. Since i started to use Right Font this issue started. For this reason i litterally cant use the software ultil this fix.

With Type Face font manager this not happen. (Adobe in general, Blender, Sketch, SketchApp and any other that i work dont have this issue, only Affinity Suite (i bought the 3 of then including all the books).

Schermata 2022-09-06 alle 09.31.07.png

Link to comment
Share on other sites

3 hours ago, giovinccent said:

This is SO anoying. I use Adobe for years and nothing like this happened. Is possible Serif release one update to fix this? I always used font managers with a kind of a good number of fonts activated. (nothing absurd) and always worked fine. Since i started to use Right Font this issue started. For this reason i litterally cant use the software ultil this fix.

With Type Face font manager this not happen. (Adobe in general, Blender, Sketch, SketchApp and any other that i work dont have this issue, only Affinity Suite (i bought the 3 of then including all the books).

If you purchased the Affinity application from the Mac App Store, then it runs in a "sandboxed" environment with limits on the number of files you can have open. That limit includes any fonts that the application is using.

How many fonts do you have activated?

 

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

  • 1 year later...

In my case this only happens when I create the afpackages, so I am guessing this is a problem with the packaging process.  It happens regardless of whether I make the package from Designer or Publisher.

I have my Mac connected to iCloud and the files sitting inside the Affinity folder have the problem, as do those sitting on the google drive.   I have no problems opening the publisher or designer file from the same location, but the packages will not open.  

I was under the impression that the packages would be a stable way of storing the images, fonts, and other resources, but none of them open. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.